aboutsummaryrefslogtreecommitdiff
path: root/finance/trytond28_production
diff options
context:
space:
mode:
authorBoris Samorodov <bsam@FreeBSD.org>2013-11-20 17:20:57 +0000
committerBoris Samorodov <bsam@FreeBSD.org>2013-11-20 17:20:57 +0000
commit6c6b72523502135a007ede6386683dc7f8d12905 (patch)
tree7fd4486a5fe95dc1c0f49e540a7a050e82c16883 /finance/trytond28_production
parentc9c7d169004f833c98fb9417e8dced9263b64219 (diff)
downloadports-6c6b72523502135a007ede6386683dc7f8d12905.tar.gz
ports-6c6b72523502135a007ede6386683dc7f8d12905.zip
. svn copy tryton -> tryton28 ports;
. update tryton28 ports; [1] . connect tryton28 ports to build; . register conflicts at tryton ports. PR: ports/181691 [1] Submitted by: Matthias Petermann <matthias@petermann-it.de> [1] Approved by: Matthias Petermann <matthias@petermann-it.de>
Notes
Notes: svn path=/head/; revision=334432
Diffstat (limited to 'finance/trytond28_production')
-rw-r--r--finance/trytond28_production/Makefile26
-rw-r--r--finance/trytond28_production/distinfo2
-rw-r--r--finance/trytond28_production/pkg-descr3
-rw-r--r--finance/trytond28_production/pkg-plist74
4 files changed, 105 insertions, 0 deletions
diff --git a/finance/trytond28_production/Makefile b/finance/trytond28_production/Makefile
new file mode 100644
index 000000000000..0f7f90f27c33
--- /dev/null
+++ b/finance/trytond28_production/Makefile
@@ -0,0 +1,26 @@
+# Created by: Matthias Petermann <matthias@petermann-it.de>
+# $FreeBSD$
+
+PORTNAME= trytond28_production
+PORTVERSION= 2.8.0
+CATEGORIES= finance python
+MASTER_SITES= https://pypi.python.org/packages/source/t/trytond_production/ \
+ http://downloads.tryton.org/${PORTVERSION:R}/
+DISTNAME= trytond_production-${PORTVERSION}
+
+MAINTAINER= matthias@petermann-it.de
+COMMENT= Tryton Application Platform (Production Module)
+
+LICENSE= GPLv3
+
+RUN_DEPENDS= trytond28_product>=2.8.0:${PORTSDIR}/finance/trytond28_product \
+ trytond28_company>=2.8.0:${PORTSDIR}/finance/trytond28_company \
+ trytond28_stock>=2.8.2:${PORTSDIR}/finance/trytond28_stock
+
+CONFLICTS= trytond_production-2.[46].*
+
+USE_PYTHON= yes
+USE_PYDISTUTILS=easy_install
+PYEASYINSTALL_EGG=${DISTNAME}-py${PYTHON_VER}${PYEASYINSTALL_OSARCH}.egg
+
+.include <bsd.port.mk>
diff --git a/finance/trytond28_production/distinfo b/finance/trytond28_production/distinfo
new file mode 100644
index 000000000000..bee5cca39955
--- /dev/null
+++ b/finance/trytond28_production/distinfo
@@ -0,0 +1,2 @@
+SHA256 (trytond_production-2.8.0.tar.gz) = 30eedf15d65a469bd0c380ab70fcdf62f4bc73cbdb8808bdec427f5140ce7bdc
+SIZE (trytond_production-2.8.0.tar.gz) = 41407
diff --git a/finance/trytond28_production/pkg-descr b/finance/trytond28_production/pkg-descr
new file mode 100644
index 000000000000..efe020ea7656
--- /dev/null
+++ b/finance/trytond28_production/pkg-descr
@@ -0,0 +1,3 @@
+This port adds the Production Module to the Tryton Application Platform.
+
+WWW: http://www.tryton.org/
diff --git a/finance/trytond28_production/pkg-plist b/finance/trytond28_production/pkg-plist
new file mode 100644
index 000000000000..73c4a9e690a1
--- /dev/null
+++ b/finance/trytond28_production/pkg-plist
@@ -0,0 +1,74 @@
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO/PKG-INFO
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO/SOURCES.txt
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO/dependency_links.txt
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO/entry_points.txt
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO/not-zip-safe
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO/requires.txt
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO/top_level.txt
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/production/__init__.py
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/production/__init__.pyc
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/production/__init__.pyo
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/production/bom.py
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/production/bom.pyc
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/production/bom.pyo
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/production/bom.xml
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/production/configuration.py
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/production/configuration.pyc
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/production/configuration.pyo
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/production/configuration.xml
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/production/locale/bg_BG.po
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/production/locale/ca_ES.po
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/production/locale/cs_CZ.po
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/production/locale/de_DE.po
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/production/locale/es_AR.po
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/production/locale/es_CO.po
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/production/locale/es_ES.po
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/production/locale/fr_FR.po
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/production/locale/nl_NL.po
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/production/locale/ru_RU.po
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/production/product.py
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/production/product.pyc
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/production/product.pyo
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/production/product.xml
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/production/production.py
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/production/production.pyc
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/production/production.pyo
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/production/production.xml
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/production/stock.py
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/production/stock.pyc
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/production/stock.pyo
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/production/stock.xml
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/production/tests/__init__.py
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/production/tests/__init__.pyc
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/production/tests/__init__.pyo
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/production/tests/scenario_production.rst
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/production/tests/test_production.py
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/production/tests/test_production.pyc
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/production/tests/test_production.pyo
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/production/tryton.cfg
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/production/view/assign_failed_form.xml
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/production/view/bom_form.xml
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/production/view/bom_input_form.xml
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/production/view/bom_input_list.xml
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/production/view/bom_list.xml
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/production/view/bom_output_form.xml
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/production/view/bom_output_list.xml
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/production/view/bom_tree_open_start_form.xml
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/production/view/bom_tree_open_tree_form.xml
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/production/view/bom_tree_tree.xml
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/production/view/configuration_form.xml
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/production/view/location_form.xml
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/production/view/product_bom_form.xml
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/production/view/product_bom_list.xml
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/production/view/product_bom_list_sequence.xml
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/production/view/product_form.xml
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/production/view/production_form.xml
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/production/view/production_list.xml
+@dirrm %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/production/view
+@dirrm %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/production/tests
+@dirrm %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/production/locale
+@dirrm %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/production
+@dirrm %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules
+@dirrm %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond
+@dirrm %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO
+@dirrm %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%