aboutsummaryrefslogtreecommitdiff
path: root/finance/xquote
diff options
context:
space:
mode:
authorAndrew Pantyukhin <sat@FreeBSD.org>2006-05-08 07:43:49 +0000
committerAndrew Pantyukhin <sat@FreeBSD.org>2006-05-08 07:43:49 +0000
commite120b50c21c229bfbf8202ce6b6f1065f990d3e0 (patch)
treea432de474acb5bf2554b91fbbfe44ae1712d340d /finance/xquote
parent5d8d0b1d16aa7503a390d27bce1f3909458133cb (diff)
downloadports-e120b50c21c229bfbf8202ce6b6f1065f990d3e0.tar.gz
ports-e120b50c21c229bfbf8202ce6b6f1065f990d3e0.zip
Notes
Diffstat (limited to 'finance/xquote')
-rw-r--r--finance/xquote/Makefile6
-rw-r--r--finance/xquote/distinfo6
-rw-r--r--finance/xquote/files/patch-Imakefile11
-rw-r--r--finance/xquote/files/patch-ad23
-rw-r--r--finance/xquote/files/patch-color.c (renamed from finance/xquote/files/patch-ae)6
-rw-r--r--finance/xquote/pkg-descr2
6 files changed, 21 insertions, 33 deletions
diff --git a/finance/xquote/Makefile b/finance/xquote/Makefile
index 1d4f340a8085..eb4654b123f4 100644
--- a/finance/xquote/Makefile
+++ b/finance/xquote/Makefile
@@ -5,13 +5,13 @@
# $FreeBSD$
PORTNAME= xquote
-PORTVERSION= 2.6.9
+PORTVERSION= 2.6.10
CATEGORIES= finance
MASTER_SITES= http://xinvest.sunsite.dk/ \
${MASTER_SITE_XCONTRIB}
-MASTER_SITE_SUBDIR= applications
+MASTER_SITE_SUBDIR= applications
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= infofarmer@FreeBSD.org
COMMENT= A quote retrieval tool for X
LIB_DEPENDS= Xbae.4:${PORTSDIR}/x11-toolkits/xbae
diff --git a/finance/xquote/distinfo b/finance/xquote/distinfo
index 621beaee969a..4c29598d9030 100644
--- a/finance/xquote/distinfo
+++ b/finance/xquote/distinfo
@@ -1,3 +1,3 @@
-MD5 (xquote-2.6.9.tar.gz) = e51f40e74acc476cd2a2e0129cb054cc
-SHA256 (xquote-2.6.9.tar.gz) = 4e194ba8b0242de33a6c6dfa4598e5676659f93c17820694c2f72cea28b8e80d
-SIZE (xquote-2.6.9.tar.gz) = 97913
+MD5 (xquote-2.6.10.tar.gz) = a8fec9c8951f4faa7a71d42f4bba008a
+SHA256 (xquote-2.6.10.tar.gz) = 7a1c1fc376c329cda8e6c1c919d9a8724ae5aa3504c0176004338bfb8fa76d35
+SIZE (xquote-2.6.10.tar.gz) = 106006
diff --git a/finance/xquote/files/patch-Imakefile b/finance/xquote/files/patch-Imakefile
new file mode 100644
index 000000000000..fb4176b79b64
--- /dev/null
+++ b/finance/xquote/files/patch-Imakefile
@@ -0,0 +1,11 @@
+--- ./Imakefile.orig Sun Apr 16 15:06:16 2006
++++ ./Imakefile Sun Apr 16 15:08:10 2006
+@@ -13,7 +13,7 @@
+
+ DEFINES = -DSHAPE -DXQUOTE
+ INCLUDES = -I$(INCROOT)/X11
+-SYS_LIBRARIES = -lXbae -lXm -lXpm $(XMULIB) $(XTOOLLIB) -lXext $(XLIB) -lm
++SYS_LIBRARIES = -lXbae $(MOTIFLIB) -lXpm $(XMULIB) $(XTOOLLIB) -lXext $(XLIB) -lm
+ DEPLIBS =
+
+ SRCS = about.c color.c fileXq.c help.c optdetail.c option.c optnet.c \
diff --git a/finance/xquote/files/patch-ad b/finance/xquote/files/patch-ad
deleted file mode 100644
index a0d080f8f317..000000000000
--- a/finance/xquote/files/patch-ad
+++ /dev/null
@@ -1,23 +0,0 @@
---- Imakefile.orig Sat May 1 16:45:28 2004
-+++ Imakefile Sun May 30 00:55:59 2004
-@@ -13,16 +13,16 @@
-
- DEFINES = -DSHAPE -DXQUOTE
- INCLUDES = -I$(INCROOT)/X11
--SYS_LIBRARIES = -lXm -lXpm $(XMULIB) $(XTOOLLIB) -lXext $(XLIB) -lm
-+SYS_LIBRARIES = $(MOTIFLIB) -lXpm $(XMULIB) $(XTOOLLIB) -lXext $(XLIB) -lm -lXbae
- DEPLIBS =
-
- SRCS = about.c color.c fileXq.c help.c optdetail.c option.c optnet.c \
- opttick.c optupdate.c parse.c pixmap.c remoteXq.c server.c session.c \
-- sessionXq.c status.c tape.c util.c view.c xquote.c xutil.c
-+ sessionXi.c status.c tape.c util.c view.c xquote.c xutil.c
-
- OBJS = about.o color.o fileXq.o help.o optdetail.o option.o optnet.o \
- opttick.o optupdate.o parse.o pixmap.o remoteXq.o server.o session.o \
-- sessionXq.o status.o tape.o util.o view.o xquote.o xutil.o
-+ sessionXi.o status.o tape.o util.o view.o xquote.o xutil.o
-
--ComplexProgramTarget(Xquote)
-+ComplexProgramTargetNoMan(Xquote)
- InstallAppDefaults(Xquote)
diff --git a/finance/xquote/files/patch-ae b/finance/xquote/files/patch-color.c
index ffb87a7190cd..e0eb3322b26f 100644
--- a/finance/xquote/files/patch-ae
+++ b/finance/xquote/files/patch-color.c
@@ -1,6 +1,6 @@
---- color.c.orig Sat Sep 28 23:16:31 2002
-+++ color.c Sat Sep 28 23:16:43 2002
-@@ -25,7 +25,7 @@
+--- ./color.c.orig Sun Apr 16 15:08:31 2006
++++ ./color.c Sun Apr 16 15:09:07 2006
+@@ -34,7 +34,7 @@
#include <stdio.h>
diff --git a/finance/xquote/pkg-descr b/finance/xquote/pkg-descr
index 6bdb2fa155d0..b71c4435632a 100644
--- a/finance/xquote/pkg-descr
+++ b/finance/xquote/pkg-descr
@@ -2,7 +2,7 @@ This is a port of Xquote, a quote retrieval program that allows you
to retrieve stock, mutual fund, and currency quotes from your favorite
quote spouting website.
-WWW: http://xinvest.sunsite.dk/
+WWW: http://xinvest.sunsite.dk/xquote.html
- Ian
ian@broken.net