aboutsummaryrefslogtreecommitdiff
path: root/finance/xtrader
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2014-01-07 19:41:56 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2014-01-07 19:41:56 +0000
commit3ac08185e03f1e1130e16afd6a514b4b726122fa (patch)
treec6ab30aafeccdc3595b8f2581832e461d015f0cb /finance/xtrader
parent568a8a0401f968d15e9c10c711e2a6f7b1c56e77 (diff)
downloadports-3ac08185e03f1e1130e16afd6a514b4b726122fa.tar.gz
ports-3ac08185e03f1e1130e16afd6a514b4b726122fa.zip
- Stage support
- USES gmake - New LIB_DEPENDS syntax
Notes
Notes: svn path=/head/; revision=339022
Diffstat (limited to 'finance/xtrader')
-rw-r--r--finance/xtrader/Makefile13
1 files changed, 6 insertions, 7 deletions
diff --git a/finance/xtrader/Makefile b/finance/xtrader/Makefile
index 4336aa3dfd8c..ef4bbcd8cb75 100644
--- a/finance/xtrader/Makefile
+++ b/finance/xtrader/Makefile
@@ -10,21 +10,20 @@ MASTER_SITES= SF/${PORTNAME}/OldFiles
MAINTAINER= ports@FreeBSD.org
COMMENT= Technical analysis program for financial instruments
-LIB_DEPENDS= ptypes.21:${PORTSDIR}/devel/ptypes \
- fltk.1:${PORTSDIR}/x11-toolkits/fltk
+LIB_DEPENDS= libptypes.so:${PORTSDIR}/devel/ptypes \
+ libfltk.so.1:${PORTSDIR}/x11-toolkits/fltk
MAKE_ENV= PTHREAD_LIBS="${PTHREAD_LIBS}"
MAKEFILE= Makefile.linux
USE_XORG= x11 xpm
BUILD_WRKSRC= ${WRKSRC}/${PORTNAME}
NO_WRKSUBDIR= yes
-USE_GMAKE= yes
+USES= gmake
PLIST_FILES= bin/xtrader \
%%DATADIR%%/sample.xt
PLIST_DIRS= %%DATADIR%%
-NO_STAGE= yes
post-patch:
${REINPLACE_CMD} -e 's|char|const char|' \
${WRKSRC}/xtrader/src/Resource.cpp
@@ -36,8 +35,8 @@ post-patch:
${REINPLACE_CMD} -e '/^#include <FL/s|.h>$$|.H>|; s|fl_file_chooser|Fl_File_Chooser|g'
do-install:
- @${MKDIR} ${DATADIR}
- ${INSTALL_DATA} ${WRKSRC}/${PORTNAME}/sample.xt ${DATADIR}
- ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME}/xtrader ${PREFIX}/bin
+ @${MKDIR} ${STAGEDIR}${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/${PORTNAME}/sample.xt ${STAGEDIR}${DATADIR}
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME}/xtrader ${STAGEDIR}${PREFIX}/bin
.include <bsd.port.mk>