aboutsummaryrefslogtreecommitdiff
path: root/finance
diff options
context:
space:
mode:
authorNicola Vitale <nivit@FreeBSD.org>2018-09-01 19:41:21 +0000
committerNicola Vitale <nivit@FreeBSD.org>2018-09-01 19:41:21 +0000
commit15a01eb990b38879398017eb62bcd6d0172091ae (patch)
tree0eea3f7b0e57ab242bd809e6012ba56169170ee4 /finance
parentaf1e5e64bea2ff767da3df8432658e10c9946086 (diff)
downloadports-15a01eb990b38879398017eb62bcd6d0172091ae.tar.gz
ports-15a01eb990b38879398017eb62bcd6d0172091ae.zip
Fava is a web interface for the double-entry bookkeeping software Beancount
with a focus on features and usability. You can try out an online demo: https://fava.pythonanywhere.com/example-with-budgets/income_statement/ WWW: https://beancount.github.io/fava/
Notes
Notes: svn path=/head/; revision=478720
Diffstat (limited to 'finance')
-rw-r--r--finance/Makefile1
-rw-r--r--finance/fava/Makefile33
-rw-r--r--finance/fava/distinfo5
-rw-r--r--finance/fava/pkg-descr8
4 files changed, 47 insertions, 0 deletions
diff --git a/finance/Makefile b/finance/Makefile
index 209af4c2f1c6..a229272f23da 100644
--- a/finance/Makefile
+++ b/finance/Makefile
@@ -31,6 +31,7 @@
SUBDIR += cointop
SUBDIR += electrum
SUBDIR += expense
+ SUBDIR += fava
SUBDIR += fixc
SUBDIR += frontaccounting
SUBDIR += gnucash
diff --git a/finance/fava/Makefile b/finance/fava/Makefile
new file mode 100644
index 000000000000..d67800c1d6fa
--- /dev/null
+++ b/finance/fava/Makefile
@@ -0,0 +1,33 @@
+# $FreeBSD$
+
+PORTNAME= fava
+PORTVERSION= 1.8
+DISTVERSIONPREFIX= v
+CATEGORIES= finance
+MASTER_SITES= LOCAL/nivit/${PORTNAME}/:static
+DISTFILES= ${PORTNAME}-static-gen-${PORTVERSION}.tar.gz:static
+
+MAINTAINER= nivit@FreeBSD.org
+COMMENT= Web interface for Beancount
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= beancount>=2.1.2:finance/beancount \
+ ${PYTHON_PKGNAMEPREFIX}Babel>0:devel/py-babel@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}cheroot>0:www/py-cheroot@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}Flask-Babel>0:devel/py-flask-babel@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}Flask>0:www/py-flask@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}Jinja2>0:devel/py-Jinja2@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}click>0:devel/py-click@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}markdown2>0:textproc/py-markdown2@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}ply>0:devel/py-ply@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}simplejson>0:devel/py-simplejson@${PY_FLAVOR}
+
+GH_ACCOUNT= beancount
+
+USES= python:3.5+ # same as finance/beancount
+USE_GITHUB= yes
+USE_PYTHON= autoplist distutils
+
+.include <bsd.port.mk>
diff --git a/finance/fava/distinfo b/finance/fava/distinfo
new file mode 100644
index 000000000000..faf101cb7bdf
--- /dev/null
+++ b/finance/fava/distinfo
@@ -0,0 +1,5 @@
+TIMESTAMP = 1535819146
+SHA256 (fava-static-gen-1.8.tar.gz) = 068d9e2bdbb3ebbb599cdb3e8b8fc1d7729ebe93591217865152b9b676042e9e
+SIZE (fava-static-gen-1.8.tar.gz) = 422835
+SHA256 (beancount-fava-v1.8_GH0.tar.gz) = 4262fb01daed2964c5f75700f4fdce6fedbfffdb25bdb221a41de87b5ba49ba0
+SIZE (beancount-fava-v1.8_GH0.tar.gz) = 332251
diff --git a/finance/fava/pkg-descr b/finance/fava/pkg-descr
new file mode 100644
index 000000000000..21178a0a1b27
--- /dev/null
+++ b/finance/fava/pkg-descr
@@ -0,0 +1,8 @@
+Fava is a web interface for the double-entry bookkeeping software Beancount
+with a focus on features and usability.
+
+You can try out an online demo:
+
+ https://fava.pythonanywhere.com/example-with-budgets/income_statement/
+
+WWW: https://beancount.github.io/fava/