aboutsummaryrefslogtreecommitdiff
path: root/finance
diff options
context:
space:
mode:
authorNicola Vitale <nivit@FreeBSD.org>2018-09-01 19:38:37 +0000
committerNicola Vitale <nivit@FreeBSD.org>2018-09-01 19:38:37 +0000
commitaf1e5e64bea2ff767da3df8432658e10c9946086 (patch)
treebf080834c6ad8a4b2bee10ca3460db8503bd0314 /finance
parentc32ab33b69d55e34081cba7bdc4674a7a5040414 (diff)
downloadports-af1e5e64bea2ff767da3df8432658e10c9946086.tar.gz
ports-af1e5e64bea2ff767da3df8432658e10c9946086.zip
A double-entry bookkeeping computer language that lets you define financial
transaction records in a text file, read them in memory, generate a variety of reports from them, and provides a web interface. WWW: http://furius.ca/beancount/
Notes
Notes: svn path=/head/; revision=478719
Diffstat (limited to 'finance')
-rw-r--r--finance/Makefile1
-rw-r--r--finance/beancount/Makefile41
-rw-r--r--finance/beancount/distinfo3
-rw-r--r--finance/beancount/files/patch-setup.py18
-rw-r--r--finance/beancount/pkg-descr5
5 files changed, 68 insertions, 0 deletions
diff --git a/finance/Makefile b/finance/Makefile
index 1815f474f75b..209af4c2f1c6 100644
--- a/finance/Makefile
+++ b/finance/Makefile
@@ -24,6 +24,7 @@
SUBDIR += alkimia-qt4
SUBDIR += aqbanking
SUBDIR += aqmoney
+ SUBDIR += beancount
SUBDIR += beanie
SUBDIR += bitcoin-armory
SUBDIR += cbb
diff --git a/finance/beancount/Makefile b/finance/beancount/Makefile
new file mode 100644
index 000000000000..d1f2fc1c939a
--- /dev/null
+++ b/finance/beancount/Makefile
@@ -0,0 +1,41 @@
+# $FreeBSD$
+
+PORTNAME= beancount
+PORTVERSION= 2.1.2
+CATEGORIES= finance
+MASTER_SITES= https://bitbucket.org/${BB_ACCOUNT}/${BB_PROJECT}/get/
+DISTNAME= ${PORTVERSION}
+DIST_SUBDIR= ${PORTNAME}
+
+MAINTAINER= nivit@FreeBSD.org
+COMMENT= Double-Entry Accounting from Text Files
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}beautifulsoup>=0:www/py-beautifulsoup@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}bottle>=0:www/py-bottle@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}dateutil>=0:devel/py-dateutil@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}lxml>=0:devel/py-lxml@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}ply>=0:devel/py-ply@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}python-magic>=0:devel/py-python-magic@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}beautifulsoup>=0:www/py-beautifulsoup@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}bottle>=0:www/py-bottle@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}chardet>=0:textproc/py-chardet@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}dateutil>=0:devel/py-dateutil@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}lxml>=0:devel/py-lxml@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}ply>=0:devel/py-ply@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}google-api-python-client>=0:www/py-google-api-python-client@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}python-magic>=0:devel/py-python-magic@${PY_FLAVOR}
+
+# Project hosted on Bitbucket
+BB_ACCOUNT= blais
+BB_COMMIT= 2b20d3017825
+BB_PROJECT= ${PORTNAME}
+
+WRKSRC= ${WRKDIR}/${BB_ACCOUNT}-${BB_PROJECT}-${BB_COMMIT}
+
+USES= python:3.5+
+USE_PYTHON= autoplist distutils
+
+.include <bsd.port.mk>
diff --git a/finance/beancount/distinfo b/finance/beancount/distinfo
new file mode 100644
index 000000000000..5fa8f84ae6e5
--- /dev/null
+++ b/finance/beancount/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1534755684
+SHA256 (beancount/2.1.2.tar.gz) = ee6f0a75bfffa0b3e386d2a93709809624f935cbddf72f57bae281c18026452f
+SIZE (beancount/2.1.2.tar.gz) = 1703555
diff --git a/finance/beancount/files/patch-setup.py b/finance/beancount/files/patch-setup.py
new file mode 100644
index 000000000000..a27eb9b13dc0
--- /dev/null
+++ b/finance/beancount/files/patch-setup.py
@@ -0,0 +1,18 @@
+--- setup.py.orig 2018-05-12 17:29:03 UTC
++++ setup.py
+@@ -168,6 +168,7 @@ assert isinstance(version, str)
+
+ def get_hg_changeset():
+ """Get the Mercurial changeset id."""
++ return None
+ try:
+ output = subprocess.check_output(['hg', 'parent', '--template', '{node} {date}'],
+ shell=False)
+@@ -179,6 +180,7 @@ def get_hg_changeset():
+
+ def get_git_changeset():
+ """Get the Git changeset id."""
++ return None
+ try:
+ output = subprocess.check_output(['git', 'log', '--pretty=%H %ct', '-1'],
+ shell=False)
diff --git a/finance/beancount/pkg-descr b/finance/beancount/pkg-descr
new file mode 100644
index 000000000000..a858a76cf47f
--- /dev/null
+++ b/finance/beancount/pkg-descr
@@ -0,0 +1,5 @@
+A double-entry bookkeeping computer language that lets you define financial
+transaction records in a text file, read them in memory, generate a variety
+of reports from them, and provides a web interface.
+
+WWW: http://furius.ca/beancount/