aboutsummaryrefslogtreecommitdiff
path: root/finance
diff options
context:
space:
mode:
authorTilman Keskinoz <arved@FreeBSD.org>2003-01-08 21:18:03 +0000
committerTilman Keskinoz <arved@FreeBSD.org>2003-01-08 21:18:03 +0000
commitf2d1dd6ec19fef9721f3a7ade587ca207636ef6b (patch)
tree5514e1f84555d15a73dc8d252148bfef9e8d86a5 /finance
parent944210f3e8a97b1995d10bc6f43e0f43fbe40254 (diff)
downloadports-f2d1dd6ec19fef9721f3a7ade587ca207636ef6b.tar.gz
ports-f2d1dd6ec19fef9721f3a7ade587ca207636ef6b.zip
Notes
Diffstat (limited to 'finance')
-rw-r--r--finance/Makefile1
-rw-r--r--finance/openhbci/Makefile20
-rw-r--r--finance/openhbci/distinfo1
-rw-r--r--finance/openhbci/files/patch-aa56
-rw-r--r--finance/openhbci/pkg-comment1
-rw-r--r--finance/openhbci/pkg-descr13
-rw-r--r--finance/openhbci/pkg-plist66
7 files changed, 158 insertions, 0 deletions
diff --git a/finance/Makefile b/finance/Makefile
index 8731adef9415..36e3dda0c3d0 100644
--- a/finance/Makefile
+++ b/finance/Makefile
@@ -1,5 +1,6 @@
# $FreeBSD$
#
+ SUBDIR += openhbci
SUBDIR += p5-Math-Financial
SUBDIR += qhacc
diff --git a/finance/openhbci/Makefile b/finance/openhbci/Makefile
new file mode 100644
index 000000000000..00ac5d40f85f
--- /dev/null
+++ b/finance/openhbci/Makefile
@@ -0,0 +1,20 @@
+# Ports collection makefile for: openhbci
+# Date created: Jan 3, 2003
+# Whom: Heiner Strauss <heiner@bilch.com>
+#
+# $FreeBSD$
+
+PORTNAME= openhbci
+PORTVERSION= 0.9.4
+CATEGORIES= finance
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= heiner@bilch.com
+
+GNU_CONFIGURE= yes
+CONFIGURE_ENV+= CXXFLAGS=-pedantic
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
+INSTALLS_SHLIB= yes
+
+.include <bsd.port.mk>
diff --git a/finance/openhbci/distinfo b/finance/openhbci/distinfo
new file mode 100644
index 000000000000..880fc1531787
--- /dev/null
+++ b/finance/openhbci/distinfo
@@ -0,0 +1 @@
+MD5 (openhbci-0.9.4.tar.gz) = 326e0a021ff3f3db106d00e64d4ee6ae
diff --git a/finance/openhbci/files/patch-aa b/finance/openhbci/files/patch-aa
new file mode 100644
index 000000000000..df7bb9c2264a
--- /dev/null
+++ b/finance/openhbci/files/patch-aa
@@ -0,0 +1,56 @@
+*** src/openhbci/core/posix/directory.cpp Mon Sep 9 15:52:41 2002
+***************
+*** 117,123 ****
+
+
+ string Directory::workingDirectory(){
+! char buffer[PATH_MAX];
+
+ if (!getcwd(buffer,sizeof(buffer)))
+ throw Error("Directory::workingDirectory()",
+--- 117,123 ----
+
+
+ string Directory::workingDirectory(){
+! char buffer[MAXNAMLEN];
+
+ if (!getcwd(buffer,sizeof(buffer)))
+ throw Error("Directory::workingDirectory()",
+*** src/openhbci/core/posix/inetaddress.h Mon Sep 9 15:52:41 2002
+***************
+*** 31,38 ****
+ #define C_INEDADDRESS_H
+
+ #include <string>
+- #include <sys/socket.h>
+ #include <sys/types.h>
+ #include <sys/time.h>
+ #include <netinet/in.h>
+ #include <netdb.h>
+--- 31,38 ----
+ #define C_INEDADDRESS_H
+
+ #include <string>
+ #include <sys/types.h>
++ #include <sys/socket.h>
+ #include <sys/time.h>
+ #include <netinet/in.h>
+ #include <netdb.h>
+*** src/openhbci/core/posix/socket.cpp Mon Sep 9 15:52:41 2002
+***************
+*** 453,459 ****
+ p=data.c_str();
+ i=data.length();
+ while(i) {
+! j=send(_sock,p,i,MSG_NOSIGNAL);
+ if (j<=0)
+ return Error("Socket::writeData",
+ ERROR_LEVEL_NORMAL,
+--- 453,459 ----
+ p=data.c_str();
+ i=data.length();
+ while(i) {
+! j=send(_sock,p,i,MSG_EOF);
+ if (j<=0)
+ return Error("Socket::writeData",
+ ERROR_LEVEL_NORMAL,
diff --git a/finance/openhbci/pkg-comment b/finance/openhbci/pkg-comment
new file mode 100644
index 000000000000..b1cfc71924b7
--- /dev/null
+++ b/finance/openhbci/pkg-comment
@@ -0,0 +1 @@
+HBCI is a bank-independent homebanking standard
diff --git a/finance/openhbci/pkg-descr b/finance/openhbci/pkg-descr
new file mode 100644
index 000000000000..09b0560099bc
--- /dev/null
+++ b/finance/openhbci/pkg-descr
@@ -0,0 +1,13 @@
+OpenHBCI -- the first free client-side implementation of the HBCI
+specification.
+
+HBCI is a bank-independent homebanking standard used by many German
+banks. This publicly available protocol describes communication,
+authentification, encryption, and business transactions taking place
+between a homebanking applications and a bank's server. OpenHBCI
+provides an object oriented library implementing the current
+client-side HBCI specification. The library is written in C++, with C
+wrappers also available. OpenHBCI provides the application programmer
+with a high-level abstraction of almost all business transactions, so
+that all HBCI details are totally encapsulated and do not need to be
+bothered with.
diff --git a/finance/openhbci/pkg-plist b/finance/openhbci/pkg-plist
new file mode 100644
index 000000000000..a7ca395e5a92
--- /dev/null
+++ b/finance/openhbci/pkg-plist
@@ -0,0 +1,66 @@
+include/openhbci/abstracttrans.h
+include/openhbci/account.h
+include/openhbci/accountparams.h
+include/openhbci/adminjobs.h
+include/openhbci/auth.h
+include/openhbci/balance.h
+include/openhbci/bank.h
+include/openhbci/bankparams.h
+include/openhbci/bpdjob.h
+include/openhbci/connection.h
+include/openhbci/cryptkey.h
+include/openhbci/customer.h
+include/openhbci/date.h
+include/openhbci/datetime.h
+include/openhbci/directory.h
+include/openhbci/dllimport.h
+include/openhbci/error.h
+include/openhbci/file.h
+include/openhbci/hbci.h
+include/openhbci/hbcistring.h
+include/openhbci/hbcistringlist.h
+include/openhbci/inetaddress.h
+include/openhbci/interactor.h
+include/openhbci/job.h
+include/openhbci/interactorcb.h
+include/openhbci/listwrappers.h
+include/openhbci/medium.h
+include/openhbci/mediumddv.h
+include/openhbci/mediumkeyfile.h
+include/openhbci/mediumrdhbase.h
+include/openhbci/messagequeue.h
+include/openhbci/pointer.h
+include/openhbci/rsakey.h
+include/openhbci/socket.h
+include/openhbci/standingorder.h
+include/openhbci/transaction.h
+include/openhbci/updjob.h
+include/openhbci/user.h
+include/openhbci/userparams.h
+include/openhbci/value.h
+include/openhbci/tree.h
+include/openhbci/conf.h
+include/openhbci/simpleconfig.h
+include/openhbci/loader.h
+include/openhbci/outbox.h
+include/openhbci/outboxjob.h
+include/openhbci/outboxjobs.h
+include/openhbci/outboxjobkeys.h
+include/openhbci/outboxaccjobs.h
+include/openhbci/outboxstojobs.h
+include/openhbci/api.h
+include/openhbci/cmdlineoptions.h
+include/openhbci/filestream.h
+include/openhbci/parser.h
+include/openhbci/stream.h
+include/openhbci/progressmonitor.h
+include/openhbci/progressmonitorcb.h
+bin/cmoney
+bin/rdhconverter
+bin/openhbci-config
+lib/libopenhbci.so.4
+lib/libopenhbci.so
+lib/libopenhbci.la
+lib/libopenhbci.a
+share/aclocal/openhbci.m4
+@dirrm include/openhbci