aboutsummaryrefslogtreecommitdiff
path: root/finance
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2013-01-16 19:36:26 +0000
committerPawel Pekala <pawel@FreeBSD.org>2013-01-16 19:36:26 +0000
commitc4f8259bdbc159a312345b3794ff9610680040e7 (patch)
tree1d3a82aef0be010b05e9bb12e287477581f9536f /finance
parenta05c4be176969ac911400db37a2e93a17fdcfcc2 (diff)
downloadports-c4f8259bdbc159a312345b3794ff9610680040e7.tar.gz
ports-c4f8259bdbc159a312345b3794ff9610680040e7.zip
Notes
Diffstat (limited to 'finance')
-rw-r--r--finance/homebank/Makefile27
-rw-r--r--finance/homebank/distinfo4
-rw-r--r--finance/homebank/pkg-plist161
3 files changed, 105 insertions, 87 deletions
diff --git a/finance/homebank/Makefile b/finance/homebank/Makefile
index 83875633069d..818f4654a479 100644
--- a/finance/homebank/Makefile
+++ b/finance/homebank/Makefile
@@ -1,21 +1,32 @@
# $FreeBSD$
PORTNAME= homebank
-PORTVERSION= 4.4
-PORTREVISION= 2
+PORTVERSION= 4.5
CATEGORIES= finance
MASTER_SITES= http://homebank.free.fr/public/
MAINTAINER= pawel@FreeBSD.org
-COMMENT= Manage your personal accounts at home
+COMMENT= Free, easy, personal accounting for everyone
LICENSE= GPLv2
-LICENSE_FILE_GPLv2=${WRKSRC}/COPYING
-USE_GNOME= desktopfileutils gnomehier gtk20
-USE_GETTEXT= yes
-USE_GMAKE= yes
+LIB_DEPENDS= pthread-stubs:${PORTSDIR}/devel/libpthread-stubs \
+ pcre:${PORTSDIR}/devel/pcre \
+ cairo:${PORTSDIR}/graphics/cairo \
+ png15:${PORTSDIR}/graphics/png \
+ freetype:${PORTSDIR}/print/freetype2 \
+ expat:${PORTSDIR}/textproc/expat2 \
+ osp:${PORTSDIR}/textproc/opensp \
+ xcb:${PORTSDIR}/x11/libxcb \
+ fontconfig:${PORTSDIR}/x11-fonts/fontconfig
+
GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_ICONV= yes
+USE_GETTEXT= yes
+USE_XORG= pixman x11 xau xcomposite xcursor xdamage xdmcp xext xfixes \
+ xi xinerama xrandr xrender
+USE_GNOME= desktopfileutils gnomehier gtk20
INSTALLS_ICONS= yes
CPPFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
@@ -28,7 +39,7 @@ OPTIONS_DEFAULT=OFX
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MOFX}
-LIB_DEPENDS+= ofx.5:${PORTSDIR}/finance/libofx
+LIB_DEPENDS+= ofx:${PORTSDIR}/finance/libofx
CONFIGURE_ARGS+=--with-ofx
.else
CONFIGURE_ARGS+=--without-ofx
diff --git a/finance/homebank/distinfo b/finance/homebank/distinfo
index 703d43561c47..7ec8798abf24 100644
--- a/finance/homebank/distinfo
+++ b/finance/homebank/distinfo
@@ -1,2 +1,2 @@
-SHA256 (homebank-4.4.tar.gz) = 13b89373575e3ac229d2683aa7296778ad7cdae1a7a019c9124a1d5b23dce7d2
-SIZE (homebank-4.4.tar.gz) = 2951876
+SHA256 (homebank-4.5.tar.gz) = 3c6dcb19fd975037857f84fd6a186a5b0b84f590f37ead0d37868fa484c6e547
+SIZE (homebank-4.5.tar.gz) = 1874660
diff --git a/finance/homebank/pkg-plist b/finance/homebank/pkg-plist
index 0fffeb8dd02e..6496fdd974d9 100644
--- a/finance/homebank/pkg-plist
+++ b/finance/homebank/pkg-plist
@@ -14,80 +14,37 @@ share/applications/homebank.desktop
%%DATADIR%%/datas/hb-categories-pt.csv
%%DATADIR%%/datas/hb-categories-ro.csv
%%DATADIR%%/datas/hb-categories-ru.csv
-%%DATADIR%%/help/00new4.0.html
-%%DATADIR%%/help/00new4.1.html
-%%DATADIR%%/help/00new4.2.html
-%%DATADIR%%/help/00new4.3.html
-%%DATADIR%%/help/00new4.4.html
-%%DATADIR%%/help/02balance.html
-%%DATADIR%%/help/02concepts.html
-%%DATADIR%%/help/02intro.html
-%%DATADIR%%/help/02minor.html
-%%DATADIR%%/help/03account.html
-%%DATADIR%%/help/03accountmenu.html
-%%DATADIR%%/help/03auto_addition.html
-%%DATADIR%%/help/03auto_assign.html
-%%DATADIR%%/help/03carcost.html
-%%DATADIR%%/help/03import.html
-%%DATADIR%%/help/03main.html
-%%DATADIR%%/help/03mainmenu.html
-%%DATADIR%%/help/03reconcile.html
-%%DATADIR%%/help/03trans_add.html
-%%DATADIR%%/help/04acco.html
-%%DATADIR%%/help/04arch.html
-%%DATADIR%%/help/04assign.html
-%%DATADIR%%/help/04bud1.html
-%%DATADIR%%/help/04cate.html
-%%DATADIR%%/help/04paye.html
-%%DATADIR%%/help/04pref.html
-%%DATADIR%%/help/04tran.html
-%%DATADIR%%/help/04wall.html
-%%DATADIR%%/help/05bud2.html
-%%DATADIR%%/help/05cost.html
-%%DATADIR%%/help/05over.html
-%%DATADIR%%/help/05stat.html
-%%DATADIR%%/help/05time.html
-%%DATADIR%%/help/06csvformat.html
-%%DATADIR%%/help/99filt.html
+%%DATADIR%%/datas/hb-categories-sk.csv
+%%DATADIR%%/help/00-intro.html
+%%DATADIR%%/help/00-lexicon.html
+%%DATADIR%%/help/00-whatsnew.html
+%%DATADIR%%/help/dlg-acco.html
+%%DATADIR%%/help/dlg-arch.html
+%%DATADIR%%/help/dlg-assi.html
+%%DATADIR%%/help/dlg-bud1.html
+%%DATADIR%%/help/dlg-cate.html
+%%DATADIR%%/help/dlg-filt.html
+%%DATADIR%%/help/dlg-paye.html
+%%DATADIR%%/help/dlg-pref.html
+%%DATADIR%%/help/dlg-spli.html
+%%DATADIR%%/help/dlg-tran.html
+%%DATADIR%%/help/dlg-wall.html
+%%DATADIR%%/help/frm-main.html
+%%DATADIR%%/help/frm-navig.html
%%DATADIR%%/help/help.css
-%%DATADIR%%/help/images/00import1.png
-%%DATADIR%%/help/images/00import2.png
-%%DATADIR%%/help/images/00import4.png
-%%DATADIR%%/help/images/00import5.png
-%%DATADIR%%/help/images/00import6.png
-%%DATADIR%%/help/images/03account1.png
-%%DATADIR%%/help/images/03import1.png
-%%DATADIR%%/help/images/03import3a.png
-%%DATADIR%%/help/images/03import3b.png
-%%DATADIR%%/help/images/03import4.png
-%%DATADIR%%/help/images/03main1.png
%%DATADIR%%/help/images/03main_added.png
%%DATADIR%%/help/images/03main_edited.png
%%DATADIR%%/help/images/03main_reminded.png
%%DATADIR%%/help/images/03main_validated.png
-%%DATADIR%%/help/images/03transauto1.png
-%%DATADIR%%/help/images/03transauto2.png
-%%DATADIR%%/help/images/03transmult1.png
-%%DATADIR%%/help/images/04account1.png
-%%DATADIR%%/help/images/04archive1.png
-%%DATADIR%%/help/images/04assign1.png
-%%DATADIR%%/help/images/04budget1.png
-%%DATADIR%%/help/images/04category1.png
-%%DATADIR%%/help/images/04filter1.png
-%%DATADIR%%/help/images/04payee1.png
-%%DATADIR%%/help/images/04prefs1.png
-%%DATADIR%%/help/images/04prefs2.png
-%%DATADIR%%/help/images/04prefs3.png
-%%DATADIR%%/help/images/04prefs4.png
-%%DATADIR%%/help/images/04prefs5.png
-%%DATADIR%%/help/images/04prefs6.png
-%%DATADIR%%/help/images/04transaction1.png
-%%DATADIR%%/help/images/04wallet1.png
+%%DATADIR%%/help/images/05balance1.png
+%%DATADIR%%/help/images/05balance2.png
%%DATADIR%%/help/images/05budget1.png
+%%DATADIR%%/help/images/05budget2.png
%%DATADIR%%/help/images/05carcost1.png
-%%DATADIR%%/help/images/05overdrawn1.png
%%DATADIR%%/help/images/05statistics1.png
+%%DATADIR%%/help/images/05statistics2.png
%%DATADIR%%/help/images/05trendtime1.png
+%%DATADIR%%/help/images/05trendtime2.png
%%DATADIR%%/help/images/1.png
%%DATADIR%%/help/images/10.png
%%DATADIR%%/help/images/11.png
@@ -98,26 +55,76 @@ share/applications/homebank.desktop
%%DATADIR%%/help/images/2.png
%%DATADIR%%/help/images/3.png
%%DATADIR%%/help/images/4.png
+%%DATADIR%%/help/images/45accfilter.png
+%%DATADIR%%/help/images/45topsending.png
+%%DATADIR%%/help/images/45txnsplit.png
%%DATADIR%%/help/images/5.png
%%DATADIR%%/help/images/6.png
%%DATADIR%%/help/images/7.png
%%DATADIR%%/help/images/8.png
%%DATADIR%%/help/images/9.png
-%%DATADIR%%/help/images/bg_page.gif
+%%DATADIR%%/help/images/arrow.png
+%%DATADIR%%/help/images/dlg-account1.png
+%%DATADIR%%/help/images/dlg-assign1.png
+%%DATADIR%%/help/images/dlg-budget1.png
+%%DATADIR%%/help/images/dlg-category1.png
+%%DATADIR%%/help/images/dlg-filter1.png
+%%DATADIR%%/help/images/dlg-filter2.png
+%%DATADIR%%/help/images/dlg-filter3.png
+%%DATADIR%%/help/images/dlg-filter4.png
+%%DATADIR%%/help/images/dlg-filter5.png
+%%DATADIR%%/help/images/dlg-filter6.png
+%%DATADIR%%/help/images/dlg-payee1.png
+%%DATADIR%%/help/images/dlg-prefs1.png
+%%DATADIR%%/help/images/dlg-prefs2.png
+%%DATADIR%%/help/images/dlg-prefs3.png
+%%DATADIR%%/help/images/dlg-prefs4.png
+%%DATADIR%%/help/images/dlg-prefs5.png
+%%DATADIR%%/help/images/dlg-prefs6.png
+%%DATADIR%%/help/images/dlg-prefs7.png
+%%DATADIR%%/help/images/dlg-properties1.png
+%%DATADIR%%/help/images/dlg-split1.png
+%%DATADIR%%/help/images/dlg-template1.png
+%%DATADIR%%/help/images/dlg-transaction1.png
%%DATADIR%%/help/images/doc_balance.png
%%DATADIR%%/help/images/doc_title.png
-%%DATADIR%%/help/images/go-home.png
-%%DATADIR%%/help/images/go-next.png
-%%DATADIR%%/help/images/go-previous.png
-%%DATADIR%%/help/images/no-home.png
-%%DATADIR%%/help/images/no-next.png
-%%DATADIR%%/help/images/no-previous.png
-%%DATADIR%%/help/images/shotback.png
-%%DATADIR%%/help/images/top-gradient.png
+%%DATADIR%%/help/images/tnt-multiedit.png
+%%DATADIR%%/help/images/use-assignment1.png
+%%DATADIR%%/help/images/use-budget1.png
+%%DATADIR%%/help/images/use-budget2.png
+%%DATADIR%%/help/images/use-budget3.png
+%%DATADIR%%/help/images/use-import2a.png
+%%DATADIR%%/help/images/use-import2b.png
+%%DATADIR%%/help/images/use-import3.png
+%%DATADIR%%/help/images/use-import4a.png
+%%DATADIR%%/help/images/use-import4b.png
+%%DATADIR%%/help/images/use-import5.png
+%%DATADIR%%/help/images/use-scheduled1.png
+%%DATADIR%%/help/images/use-scheduled2.png
+%%DATADIR%%/help/images/use-vehiclecost1.png
+%%DATADIR%%/help/images/use-vehiclecost2.png
+%%DATADIR%%/help/images/use-vehiclecost3.png
%%DATADIR%%/help/images/web_title.png
+%%DATADIR%%/help/images/win-account1.png
+%%DATADIR%%/help/images/win-main1.png
%%DATADIR%%/help/index.html
-%%DATADIR%%/help/main.html
-%%DATADIR%%/help/navig.html
+%%DATADIR%%/help/misc-balance.html
+%%DATADIR%%/help/misc-csvformat.html
+%%DATADIR%%/help/misc-minor.html
+%%DATADIR%%/help/misc-reconcile.html
+%%DATADIR%%/help/use-auto_addition.html
+%%DATADIR%%/help/use-auto_assign.html
+%%DATADIR%%/help/use-budget.html
+%%DATADIR%%/help/use-import.html
+%%DATADIR%%/help/use-tipsandtricks.html
+%%DATADIR%%/help/use-vehiclecost.html
+%%DATADIR%%/help/win-account.html
+%%DATADIR%%/help/win-balance.html
+%%DATADIR%%/help/win-budget.html
+%%DATADIR%%/help/win-main.html
+%%DATADIR%%/help/win-statistics.html
+%%DATADIR%%/help/win-trendtime.html
+%%DATADIR%%/help/win-vehiclecost.html
%%DATADIR%%/icons/hicolor/16x16/actions/hb-account.png
%%DATADIR%%/icons/hicolor/16x16/actions/hb-archive.png
%%DATADIR%%/icons/hicolor/16x16/actions/hb-assign-run.png
@@ -282,10 +289,10 @@ share/locale/vi/LC_MESSAGES/homebank.mo
share/locale/zh_CN/LC_MESSAGES/homebank.mo
share/locale/zh_HK/LC_MESSAGES/homebank.mo
share/locale/zh_TW/LC_MESSAGES/homebank.mo
-share/mime/packages/homebank.xml
share/mime-info/homebank.keys
share/mime-info/homebank.mime
share/mime/application/x-homebank.xml
+share/mime/packages/homebank.xml
@dirrmtry share/locale/zh_HK/LC_MESSAGES
@dirrmtry share/locale/zh_HK
@dirrmtry share/locale/ur/LC_MESSAGES