aboutsummaryrefslogtreecommitdiff
path: root/finance
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-10-28 11:47:36 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-10-28 11:47:36 +0000
commiteafb783d6167cdcc1062068ceb6f1a4a9c1068a9 (patch)
tree3f63516f7e80ff1adae7ea65e615f35e953b9802 /finance
parented5ff12835f06a3d45263e5e92349cb7829de97e (diff)
Notes
Diffstat (limited to 'finance')
-rw-r--r--finance/Makefile1
-rw-r--r--finance/p5-PayflowPro/Makefile33
-rw-r--r--finance/p5-PayflowPro/distinfo3
-rw-r--r--finance/p5-PayflowPro/pkg-descr10
4 files changed, 47 insertions, 0 deletions
diff --git a/finance/Makefile b/finance/Makefile
index b319f40c3554..bdd169aa0a5f 100644
--- a/finance/Makefile
+++ b/finance/Makefile
@@ -60,6 +60,7 @@
SUBDIR += p5-Locale-Currency-Format
SUBDIR += p5-Math-Financial
SUBDIR += p5-PFProAPI
+ SUBDIR += p5-PayflowPro
SUBDIR += pfpro
SUBDIR += php4-pfpro
SUBDIR += qhacc
diff --git a/finance/p5-PayflowPro/Makefile b/finance/p5-PayflowPro/Makefile
new file mode 100644
index 000000000000..41824ff77e66
--- /dev/null
+++ b/finance/p5-PayflowPro/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: p5-PayflowPro
+# Date created: Wed Oct 24 10:09:12 EDT 2007
+# Whom: Vivek Khera <vivek@khera.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= PayflowPro
+PORTVERSION= 1150
+CATEGORIES= finance perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= ../by-authors/id/V/VK/VKHERA
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= vivek@khera.org
+COMMENT= Pure Perl PayflowPro payment gateway interface
+
+RUN_DEPENDS+= p5-libwww>0.0:${PORTSDIR}/www/p5-libwww
+BUILD_DEPENDS+= p5-libwww>0.0:${PORTSDIR}/www/p5-libwww
+
+PERL_CONFIGURE= yes
+USE_BZIP2= yes
+
+post-install:
+ ${INSTALL_DATA} ${WRKSRC}/ca-bundle.crt ${LOCALBASE}/etc
+
+MAN3= PayflowPro.3
+PLIST_FILES= etc/ca-bundle.crt \
+ %%SITE_PERL%%/PayflowPro.pm \
+ %%SITE_PERL%%/%%PERL_ARCH%%/auto/PayflowPro/.packlist
+PLIST_DIRS= %%SITE_PERL%%/%%PERL_ARCH%%/auto/PayflowPro
+
+.include <bsd.port.mk>
diff --git a/finance/p5-PayflowPro/distinfo b/finance/p5-PayflowPro/distinfo
new file mode 100644
index 000000000000..62680a0e6360
--- /dev/null
+++ b/finance/p5-PayflowPro/distinfo
@@ -0,0 +1,3 @@
+MD5 (PayflowPro-1150.tar.bz2) = 934f7e6c0a08bf6a1e5394ac071dc1c3
+SHA256 (PayflowPro-1150.tar.bz2) = d104d2e775719a64b7d20998e23b7193f2a34e5e1a0beb52f88ba4442add4295
+SIZE (PayflowPro-1150.tar.bz2) = 162816
diff --git a/finance/p5-PayflowPro/pkg-descr b/finance/p5-PayflowPro/pkg-descr
new file mode 100644
index 000000000000..a3a7a687d4a5
--- /dev/null
+++ b/finance/p5-PayflowPro/pkg-descr
@@ -0,0 +1,10 @@
+Interface to HTTP gateway for PayPal's Payflow Pro service, as described on
+the PayPal developer forums at
+http://www.pdncommunity.com/pdn/board?board.id=payflow
+
+This module is intended to be a drop-in replacement for PFProAPI (a couple of
+minor changes to your code are necessary to use this module instead of
+PFProAPI). The major difference is that it is pure Perl, and not architecture
+dependent (ie, you can use this on your 64-bit FreeBSD platform.)
+
+WWW: http://labs.mailermailer.com/downloads/