aboutsummaryrefslogtreecommitdiff
path: root/finance
diff options
context:
space:
mode:
authorJason E. Hale <jhale@FreeBSD.org>2019-03-22 19:04:31 +0000
committerJason E. Hale <jhale@FreeBSD.org>2019-03-22 19:04:31 +0000
commitad828a3f04984e974818d76cc7e27ee7df2297be (patch)
tree20f8d9acac3bf1337ea0120fa64e29f12b61deca /finance
parent24803d0342d1ea2e647f04c7a1240d251b3af6ec (diff)
downloadports-ad828a3f04984e974818d76cc7e27ee7df2297be.tar.gz
ports-ad828a3f04984e974818d76cc7e27ee7df2297be.zip
Notes
Diffstat (limited to 'finance')
-rw-r--r--finance/libofx/Makefile4
-rw-r--r--finance/libofx/distinfo6
-rw-r--r--finance/libofx/files/patch-lib_ofx__utilities.cpp32
-rw-r--r--finance/libofx/pkg-plist2
4 files changed, 27 insertions, 17 deletions
diff --git a/finance/libofx/Makefile b/finance/libofx/Makefile
index 26662f1bb25b..1b80a01ce24a 100644
--- a/finance/libofx/Makefile
+++ b/finance/libofx/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= libofx
-PORTVERSION= 0.9.12
+PORTVERSION= 0.9.14
CATEGORIES= finance
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}
@@ -16,7 +16,7 @@ LIB_DEPENDS= libcurl.so:ftp/curl \
libxml++-2.6.so:textproc/libxml++26 \
libosp.so:textproc/opensp
-USES= gettext-runtime gmake iconv libtool localbase pathfix pkgconfig \
+USES= gettext-runtime gmake gnome iconv libtool localbase pathfix pkgconfig \
compiler:c++11-lang
USE_CXXSTD= c++11
USE_GNOME= glib20 glibmm libsigc++20 libxml2
diff --git a/finance/libofx/distinfo b/finance/libofx/distinfo
index 7462c5aa1cf1..97e4b53a7c66 100644
--- a/finance/libofx/distinfo
+++ b/finance/libofx/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1507465983
-SHA256 (libofx-0.9.12.tar.gz) = c15fa062fa11e759eb6d8c7842191db2185ee1b221a3f75e9650e2849d7b7373
-SIZE (libofx-0.9.12.tar.gz) = 1288227
+TIMESTAMP = 1550800754
+SHA256 (libofx-0.9.14.tar.gz) = b82757bfa15b27c02fb39dfd017cdfe5af51a063ba15afe495dd1b7367ff290a
+SIZE (libofx-0.9.14.tar.gz) = 1639297
diff --git a/finance/libofx/files/patch-lib_ofx__utilities.cpp b/finance/libofx/files/patch-lib_ofx__utilities.cpp
index 2b9730760fcb..4aca889f43b3 100644
--- a/finance/libofx/files/patch-lib_ofx__utilities.cpp
+++ b/finance/libofx/files/patch-lib_ofx__utilities.cpp
@@ -1,14 +1,24 @@
---- lib/ofx_utilities.cpp.orig 2013-04-16 19:50:51 UTC
+Emulate the behavior of the USG UXIX daylight variable implemented in glibc.
+It is supposed to be 0 if the time zone does not have any daylight saving time
+rules and non-zero if there is a time during the year when daylight saving
+time applies. [1]
+
+In FreeBSD, tzname[1] should be set to " " (three spaces) if DST is never
+observed. [2]
+
+[1] https://www.gnu.org/software/libc/manual/html_node/Time-Zone-Functions.html#Time-Zone-Functions
+[2] https://svnweb.freebsd.org/base/head/contrib/tzcode/stdtime/localtime.c?revision=313774&view=markup#l84
+
+--- lib/ofx_utilities.cpp.orig 2018-05-02 19:39:38 UTC
+++ lib/ofx_utilities.cpp
-@@ -115,6 +115,11 @@ time_t ofxdate_to_time_t(const string ofxdate)
- char time_zone_specified = false;
- string ofxdate_whole;
- time_t temptime;
-+ int daylight = 0;
-+
+@@ -142,6 +142,10 @@ time_t ofxdate_to_time_t(const string ofxdate)
+ std::time(&temptime);
+ local_offset = difftime(mktime(localtime(&temptime)), mktime(gmtime(&temptime)));
+ /* daylight is set to 1 if the timezone indicated by the environment (either TZ or /etc/localtime) uses daylight savings time (aka summer time). We use it here to provisionally set tm_isdst. */
++#if defined(__FreeBSD__)
+ tzset();
-+ if(tzname[1][0] != ' ')
-+ daylight = 1;
++ int daylight = ((tzname[1][0] == ' ') ? 0 : 1);
++#endif
+ time.tm_isdst = daylight;
- time.tm_isdst = daylight; // initialize dst setting
- std::time(&temptime);
+ if (ofxdate.size() != 0)
diff --git a/finance/libofx/pkg-plist b/finance/libofx/pkg-plist
index 12f7ebcfb3b5..4f1ef9a2841e 100644
--- a/finance/libofx/pkg-plist
+++ b/finance/libofx/pkg-plist
@@ -5,7 +5,7 @@ include/libofx/libofx.h
lib/libofx.a
lib/libofx.so
lib/libofx.so.7
-lib/libofx.so.7.0.1
+lib/libofx.so.7.0.2
libdata/pkgconfig/libofx.pc
man/man1/ofxconnect.1.gz
man/man1/ofxdump.1.gz