aboutsummaryrefslogtreecommitdiff
path: root/finance
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2005-11-30 21:43:04 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2005-11-30 21:43:04 +0000
commit3ba25b1904908cce1abda8d118c75ec808b92678 (patch)
tree912a4bfd7f84bb87c9b6dcb73166854fcfcaed29 /finance
parent187c534c836eb704d5f49f220d9baf2db1884106 (diff)
downloadports-3ba25b1904908cce1abda8d118c75ec808b92678.tar.gz
ports-3ba25b1904908cce1abda8d118c75ec808b92678.zip
Notes
Diffstat (limited to 'finance')
-rw-r--r--finance/Makefile1
-rw-r--r--finance/pfpro/Makefile58
-rw-r--r--finance/pfpro/distinfo3
-rw-r--r--finance/pfpro/pkg-descr4
-rw-r--r--finance/pfpro/pkg-message3
-rw-r--r--finance/pfpro/pkg-plist5
6 files changed, 74 insertions, 0 deletions
diff --git a/finance/Makefile b/finance/Makefile
index 4a9416769590..ddc91cfc2a21 100644
--- a/finance/Makefile
+++ b/finance/Makefile
@@ -49,6 +49,7 @@
SUBDIR += p5-Finance-Quote
SUBDIR += p5-Finance-QuoteHist
SUBDIR += p5-Math-Financial
+ SUBDIR += pfpro
SUBDIR += qhacc
SUBDIR += qtstalker
SUBDIR += quantlib
diff --git a/finance/pfpro/Makefile b/finance/pfpro/Makefile
new file mode 100644
index 000000000000..79a5ccc5d230
--- /dev/null
+++ b/finance/pfpro/Makefile
@@ -0,0 +1,58 @@
+# New ports collection makefile for: pfpro
+# Date created: November 29, 2005
+# Whom: durian@shadetreesoftware.com
+#
+# $FreeBSD$
+#
+
+PORTNAME= pfpro
+PORTVERSION= 3.0.8
+CATEGORIES= finance
+MASTER_SITES= #https://manager.verisign.com/
+DISTNAME= pfpro_freebsd
+
+MAINTAINER= durian@shadetreesoftware.com
+COMMENT= SDK for VeriSign's PayFlow Pro
+
+ONLY_FOR_ARCHS= i386
+RESTRICTED= "Only for VeriSign PayFlow Pro customers"
+NO_BUILD= yes
+INSTALLS_SHLIB= yes
+NO_WRKSUBDIR= yes
+
+PKGMESSAGE= ${WRKDIR}/pkg-message
+
+CERTDIR= ${PREFIX}/certs
+
+FBSDDIR= ${WRKSRC}/verisign/payflowpro/freebsd
+
+# XXX nees to be the same as DISTFILES
+PFP_BUNDLE= ${DISTNAME}${EXTRACT_SUFX}
+
+.include <bsd.port.pre.mk>
+
+# Check for SDK bundle
+.if !exists(${DISTDIR}/${PFP_BUNDLE})
+ECHO_MSG=/usr/bin/printf
+IGNORE= :\n\
+The VeriSign PayFlow Pro SDK is only available to customers who have\n\
+subscribed to this service. Please access your account at\n\
+https://manager.verisign.com/ and retrieve the FreeBSD 5.x version\n\
+of the SDK from the Downloads area. You will be required to agree to\n\
+some terms and conditions. After downing the SDK, place ${PFP_BUNDLE}\n\
+in ${DISTDIR}.\n
+.endif
+
+post-patch:
+ @${SED} -e "s,%%PREFIX%%,${PREFIX},g" ${.CURDIR}/pkg-message \
+ > ${PKGMESSAGE}
+
+do-install:
+ ${INSTALL_PROGRAM} ${FBSDDIR}/bin/pfpro ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${FBSDDIR}/bin/pfpro-file ${PREFIX}/bin
+ ${INSTALL_DATA} ${FBSDDIR}/lib/pfpro.h ${PREFIX}/include
+ ${INSTALL_DATA} ${FBSDDIR}/lib/libpfpro.so ${PREFIX}/lib
+ ${MKDIR} ${CERTDIR}
+ ${INSTALL_DATA} ${FBSDDIR}/certs/f73e89fd.0 ${CERTDIR}
+
+.include <bsd.port.post.mk>
diff --git a/finance/pfpro/distinfo b/finance/pfpro/distinfo
new file mode 100644
index 000000000000..742c9333b981
--- /dev/null
+++ b/finance/pfpro/distinfo
@@ -0,0 +1,3 @@
+MD5 (pfpro_freebsd.tar.gz) = 752f72c5b7c257a5e952057d76173f09
+SHA256 (pfpro_freebsd.tar.gz) = 396943299424066d23ef1307d02a044b2d7b45758a16e1dca5f47c907caa5606
+SIZE (pfpro_freebsd.tar.gz) = 322410
diff --git a/finance/pfpro/pkg-descr b/finance/pfpro/pkg-descr
new file mode 100644
index 000000000000..a58dec2989eb
--- /dev/null
+++ b/finance/pfpro/pkg-descr
@@ -0,0 +1,4 @@
+The PayFlow Pro SDK is a development kit that allows you to perform
+credit card transactions through VeriSign's PayFlow Pro system.
+
+WWW: http://www.verisign.com/products/payflow/index.html
diff --git a/finance/pfpro/pkg-message b/finance/pfpro/pkg-message
new file mode 100644
index 000000000000..38b6b1fb18dd
--- /dev/null
+++ b/finance/pfpro/pkg-message
@@ -0,0 +1,3 @@
+You must set the environment variable PFPRO_CERT_PATH to point to
+the directory that contains the file f73e89fd.0. The default location
+is: %%PREFIX%%/certs
diff --git a/finance/pfpro/pkg-plist b/finance/pfpro/pkg-plist
new file mode 100644
index 000000000000..fad2d0c045bf
--- /dev/null
+++ b/finance/pfpro/pkg-plist
@@ -0,0 +1,5 @@
+bin/pfpro
+bin/pfpro-file
+include/pfpro.h
+lib/libpfpro.so
+certs/f73e89fd.0