aboutsummaryrefslogtreecommitdiff
path: root/finance
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2020-03-18 02:20:03 +0000
committerMark Linimon <linimon@FreeBSD.org>2020-03-18 02:20:03 +0000
commit514b8af6970b239d4b8d7964fdaed0fa13d81c2a (patch)
treec73cd24132d23b908c2f8858a4d19a136547b07a /finance
parent8ba6fe575692431821ceaed6f1d656b6672756bb (diff)
downloadports-514b8af6970b239d4b8d7964fdaed0fa13d81c2a.tar.gz
ports-514b8af6970b239d4b8d7964fdaed0fa13d81c2a.zip
Unmark certain ports as broken on powerpc64 elfv2, after a trybroken run.
(Note that these have not yet been re-tested on elfv1.) While here, pet portlint (e.g. location of BROKEN_*, and, in one case, USES). Approved by: portmgr (tier-2 blanket)
Notes
Notes: svn path=/head/; revision=528623
Diffstat (limited to 'finance')
-rw-r--r--finance/ledger/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/finance/ledger/Makefile b/finance/ledger/Makefile
index ce31b59d22ce..a851867e8158 100644
--- a/finance/ledger/Makefile
+++ b/finance/ledger/Makefile
@@ -16,17 +16,17 @@ COMMENT= John Wiegley's command line accounting program
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE.md
+BROKEN_FreeBSD_11_powerpc64= fails to link on powerpc64 elfv1: ibledger.so.3: undefined reference to boost::match_results
+BROKEN_FreeBSD_12_powerpc64= fails to link on powerpc64 elfv1: ibledger.so.3: undefined reference to boost::match_results
+
BUILD_DEPENDS= ${LOCALBASE}/include/utf8.h:devel/utf8cpp
LIB_DEPENDS= libgmp.so:math/gmp \
libmpfr.so:math/mpfr \
libboost_system.so:devel/boost-libs
-BROKEN_powerpc64= fails to link: ibledger.so.3: undefined reference to boost::match_results
-
+USES= cmake compiler:c++11-lib libedit
USE_GITHUB= yes
-
USE_LDCONFIG= yes
-USES= cmake compiler:c++11-lib libedit
CMAKE_ARGS= -DCMAKE_INSTALL_MANDIR=${MANPREFIX}/man \
-DCMAKE_INCLUDE_PATH=${LOCALBASE}/include