aboutsummaryrefslogtreecommitdiff
path: root/finance
diff options
context:
space:
mode:
authorNiclas Zeising <zeising@FreeBSD.org>2019-11-05 15:56:41 +0000
committerNiclas Zeising <zeising@FreeBSD.org>2019-11-05 15:56:41 +0000
commita9bfea46abc4992233e12e8fabde724771586b6b (patch)
tree55da67fb4f344b41d35fd3bba6706cc1d3cca241 /finance
parentd52303ea80aa622b55c12627a49f1f1e99799338 (diff)
downloadports-a9bfea46abc4992233e12e8fabde724771586b6b.tar.gz
ports-a9bfea46abc4992233e12e8fabde724771586b6b.zip
Notes
Diffstat (limited to 'finance')
-rw-r--r--finance/gnucash/Makefile5
-rw-r--r--finance/wmstock/Makefile2
-rw-r--r--finance/xtrader/Makefile2
3 files changed, 5 insertions, 4 deletions
diff --git a/finance/gnucash/Makefile b/finance/gnucash/Makefile
index 22294d190c6b..21556156b958 100644
--- a/finance/gnucash/Makefile
+++ b/finance/gnucash/Makefile
@@ -27,8 +27,9 @@ RUN_DEPENDS= p5-libwww>=0:www/p5-libwww \
p5-Date-Manip>=0:devel/p5-Date-Manip \
p5-Finance-Quote>=0:finance/p5-Finance-Quote
-USES= cmake:insource compiler:c++11-lib desktop-file-utils gettext-tools gnome libtool \
- localbase perl5 pkgconfig shebangfix tar:bzip2
+USES= cmake:insource compiler:c++11-lib desktop-file-utils \
+ gettext-tools gnome libtool localbase perl5 pkgconfig \
+ shebangfix tar:bzip2 xorg
USE_XORG= x11
USE_CXXSTD= c++11
USE_GNOME= cairo gtk30 intltool libxml2 libxslt
diff --git a/finance/wmstock/Makefile b/finance/wmstock/Makefile
index c1b0a987bc67..39f0b8846b01 100644
--- a/finance/wmstock/Makefile
+++ b/finance/wmstock/Makefile
@@ -10,7 +10,7 @@ MASTER_SITES= http://www.mattfischer.com/wmstock/src/
MAINTAINER= ports@FreeBSD.org
COMMENT= Cool WindowMaker Dockapp that shows stock ticker(s)
-USES= gmake shebangfix
+USES= gmake shebangfix xorg
USE_XORG= xpm
SHEBANG_FILES= getquote
diff --git a/finance/xtrader/Makefile b/finance/xtrader/Makefile
index 2aa395e714dd..d4a23f963472 100644
--- a/finance/xtrader/Makefile
+++ b/finance/xtrader/Makefile
@@ -14,10 +14,10 @@ LIB_DEPENDS= libptypes.so:devel/ptypes \
libfltk.so.1:x11-toolkits/fltk
MAKEFILE= Makefile.linux
+USES= gmake xorg
USE_XORG= x11 xpm
BUILD_WRKSRC= ${WRKSRC}/${PORTNAME}
NO_WRKSUBDIR= yes
-USES= gmake
PLIST_FILES= bin/xtrader \
%%DATADIR%%/sample.xt