aboutsummaryrefslogtreecommitdiff
path: root/finance
diff options
context:
space:
mode:
authorSergey Matveychuk <sem@FreeBSD.org>2005-09-03 19:04:53 +0000
committerSergey Matveychuk <sem@FreeBSD.org>2005-09-03 19:04:53 +0000
commitaaa27853b42197751f7ef265b364802b39433615 (patch)
tree1e888d9198bbe850cbe6d045933fa77b04993f87 /finance
parent65677c952165e41c22edaac594b3b31085282fbd (diff)
downloadports-aaa27853b42197751f7ef265b364802b39433615.tar.gz
ports-aaa27853b42197751f7ef265b364802b39433615.zip
Notes
Diffstat (limited to 'finance')
-rw-r--r--finance/Makefile1
-rw-r--r--finance/ccard/Makefile30
-rw-r--r--finance/ccard/distinfo2
-rw-r--r--finance/ccard/pkg-descr17
4 files changed, 50 insertions, 0 deletions
diff --git a/finance/Makefile b/finance/Makefile
index 998b3fb95d0e..5e5af892ef7c 100644
--- a/finance/Makefile
+++ b/finance/Makefile
@@ -6,6 +6,7 @@
SUBDIR += aqbanking
SUBDIR += aqmoney
SUBDIR += cbb
+ SUBDIR += ccard
SUBDIR += emma
SUBDIR += gnofin
SUBDIR += gnomepm
diff --git a/finance/ccard/Makefile b/finance/ccard/Makefile
new file mode 100644
index 000000000000..be9e7c073a60
--- /dev/null
+++ b/finance/ccard/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: ccard
+# Date created: 12 Aug 2005
+# Whom: Emanuel Haupt <ehaupt@critical.ch>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ccard
+PORTVERSION= 1.1
+CATEGORIES= finance
+MASTER_SITES= http://www.canb.auug.org.au/~millerp/
+DISTNAME= ${PORTNAME}.${PORTVERSION}
+
+MAINTAINER= ehaupt@critical.ch
+COMMENT= A command line offline credit card validator/analyzer
+
+GNU_CONFIGURE= yes
+USE_REINPLACE= yes
+
+PLIST_FILES= bin/ccard
+MAN1= ccard.1
+
+post-configure:
+ ${REINPLACE_CMD} -e 's/^CFLAGS/CFLAGS?/' ${WRKSRC}/Makefile
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/man1/${PORTNAME}.1 ${MANPREFIX}/man/man1
+
+.include <bsd.port.mk>
diff --git a/finance/ccard/distinfo b/finance/ccard/distinfo
new file mode 100644
index 000000000000..a36861d694e0
--- /dev/null
+++ b/finance/ccard/distinfo
@@ -0,0 +1,2 @@
+MD5 (ccard.1.1.tar.gz) = d0532c30b42834c3c99cc8e94d0069a3
+SIZE (ccard.1.1.tar.gz) = 25077
diff --git a/finance/ccard/pkg-descr b/finance/ccard/pkg-descr
new file mode 100644
index 000000000000..4639d7dceaa2
--- /dev/null
+++ b/finance/ccard/pkg-descr
@@ -0,0 +1,17 @@
+The CCard program is a program to validate credit card numbers.
+
+It can also determine the following credit card types:
+
+ * Mastercard
+ * Visa
+ * American Express
+ * Diners Club/Carte Blanche
+ * Discover
+ * enRoute
+ * Japanese Credit Bureau
+ * Australian Bankcard
+
+WWW: http://www.canb.auug.org.au/~millerp/ccard.html
+
+- ehaupt
+ehaupt@critical.ch