aboutsummaryrefslogtreecommitdiff
path: root/finance
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2021-02-25 18:32:27 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2021-02-25 18:32:27 +0000
commit2c78b9754cd0638c4ba990970302077829c534b1 (patch)
tree5959688e073a6f80d1b08637f320c32e2551efad /finance
parentacefe46b40b398d8c35da5187f799fd739e1e27f (diff)
downloadports-2c78b9754cd0638c4ba990970302077829c534b1.tar.gz
ports-2c78b9754cd0638c4ba990970302077829c534b1.zip
MFH: r560298 r560302 r561371 r562151 r562559 r563142 r563143 r563149 r565356 r565465 r566011 r566182
finance/quickfix: fix build on non-x86 Code uses x86 assembly, but makes it possible to use Boost atomic. multimedia/zoneminder: enable on powerpc64 net/mpich: fix build on powerpc64 Neither __BYTE_ORDER nor __BIG_ENDIAN are defined: In file included from src/mpi/datatype/typerep/dataloop/looputil.c:10: ./src/mpi/datatype/typerep/dataloop/looputil.h:57:2: error: This code assumes that __BYTE_ORDER and __BIG_ENDIAN are defined #error This code assumes that __BYTE_ORDER and __BIG_ENDIAN are defined editors/libreoffice: fix build on powerpc64 elfv2 This set of patches is applied only on powerpc* architectures. Submitted by: afsilva Approved by: tier 2 blanket security/openconnect-gui: fix checksum emulators/riscv-isa-sim: enable on powerpc64 sysutils/linuxfdisk: enable on powerpc64 graphics/openfx-arena: enable on powerpc64 multimedia/arcan: enable LUAJIT on powerpc64 It builds fine with luajit-openresty. games/libretro-desmume2015: fix build on non-x86 / ARM JIT is only for x86 and ARM. astro/opencpn: fix build on powerpc64* Use GCC unconditionally on powerpc64*: In file included from /usr/lib/clang/11.0.1/include/xmmintrin.h:13: /usr/lib/clang/11.0.1/include/mmintrin.h:33:5: error: use of undeclared identifier '__builtin_ia32_emms'; did you mean '__builtin_isless'? __builtin_ia32_emms(); editors/libreoffice6: backport powerpc* patches to libreoffice6 Approved by: tier 2 blanket
Notes
Notes: svn path=/branches/2021Q1/; revision=566549
Diffstat (limited to 'finance')
-rw-r--r--finance/quickfix/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/finance/quickfix/Makefile b/finance/quickfix/Makefile
index f92ba6ae71dc..a8249e7aed8b 100644
--- a/finance/quickfix/Makefile
+++ b/finance/quickfix/Makefile
@@ -11,7 +11,6 @@ COMMENT= Free FIX Protocol Implementation
LICENSE= GPLv3+
-BROKEN_powerpc64= fails to configure: unable to find set_terminate in std or global namespace
BROKEN_i386= fails to build
BUILD_DEPENDS= bash:shells/bash
@@ -44,6 +43,14 @@ JAVA_CONFIGURE_WITH= java
INSTALL_TARGET=install-strip
+.include <bsd.port.options.mk>
+
+.if ${ARCH} != amd64 && ${ARCH} != i386
+CXXFLAGS+= -DENABLE_BOOST_ATOMIC_COUNT
+LIB_DEPENDS+= libboost_system.so:devel/boost-libs
+USES+= compiler:c++11-lang localbase
+.endif
+
post-extract:
@${REINPLACE_CMD} -e 's|^make|gmake|' \
${WRKSRC}/src/ruby/make_ruby.sh