aboutsummaryrefslogtreecommitdiff
path: root/finance
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2020-10-07 21:12:53 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2020-10-07 21:12:53 +0000
commit778fe103a67b47aa606e11021eca9bdc396aa9ca (patch)
treec63cbaf8b7764b4d13b4525d37fbeb141aea55c7 /finance
parent051046aec9e6a0706e13ad72fe1bbe684314d0c6 (diff)
downloadports-778fe103a67b47aa606e11021eca9bdc396aa9ca.tar.gz
ports-778fe103a67b47aa606e11021eca9bdc396aa9ca.zip
finance/beancount: fix build on GCC architectures
Use C11 compiler: beancount/parser/lexer.c:172: error: redefinition of typedef 'yyscan_t' beancount/parser/parser.h:11: error: previous declaration of 'yyscan_t' was here
Notes
Notes: svn path=/head/; revision=551664
Diffstat (limited to 'finance')
-rw-r--r--finance/beancount/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/finance/beancount/Makefile b/finance/beancount/Makefile
index ff5f96fa73f7..e9acb452680c 100644
--- a/finance/beancount/Makefile
+++ b/finance/beancount/Makefile
@@ -29,7 +29,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}beautifulsoup>=0:www/py-beautifulsoup@${PY_F
${PYTHON_PKGNAMEPREFIX}python-magic>=0:devel/py-python-magic@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}requests>=0:www/py-requests@${PY_FLAVOR}
-USES= python:3.5+
+USES= compiler:c11 python:3.5+
USE_GITHUB= yes
USE_PYTHON= autoplist distutils noflavors