aboutsummaryrefslogtreecommitdiff
path: root/finance
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2012-04-15 20:11:12 +0000
committerThierry Thomas <thierry@FreeBSD.org>2012-04-15 20:11:12 +0000
commit1cc25a15d4b95b0463f8fe07eeb5d6d990cc5586 (patch)
treef139802a23e133dc64b4d38aef2a0026720e427c /finance
parent9fa770836de6fa121719fcfd159e4b56c17fe10c (diff)
downloadports-1cc25a15d4b95b0463f8fe07eeb5d6d990cc5586.tar.gz
ports-1cc25a15d4b95b0463f8fe07eeb5d6d990cc5586.zip
Notes
Diffstat (limited to 'finance')
-rw-r--r--finance/grisbi/Makefile8
-rw-r--r--finance/grisbi/files/patch-pixmaps_flags_Makefile.in6
-rw-r--r--finance/grisbi/files/patch-src::Makefile.in6
3 files changed, 10 insertions, 10 deletions
diff --git a/finance/grisbi/Makefile b/finance/grisbi/Makefile
index 9181fe00dd48..06a20540f669 100644
--- a/finance/grisbi/Makefile
+++ b/finance/grisbi/Makefile
@@ -7,23 +7,23 @@
PORTNAME= grisbi
PORTVERSION= 0.8.6
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= finance
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}%20stable/${PORTVERSION:R}.x/
MAINTAINER= thierry@FreeBSD.org
COMMENT= A personnal accounting application
-LIB_DEPENDS= ofx.5:${PORTSDIR}/finance/libofx \
- ssl.7:${PORTSDIR}/security/openssl
-
LICENSE= GPLv2
+LIB_DEPENDS= ofx.5:${PORTSDIR}/finance/libofx
+
USE_BZIP2= yes
USE_ICONV= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
USE_GNOME= gtk20 glib20 libxml2
+USE_OPENSSL= yes
INSTALLS_ICONS= yes
MAN1= grisbi.1
diff --git a/finance/grisbi/files/patch-pixmaps_flags_Makefile.in b/finance/grisbi/files/patch-pixmaps_flags_Makefile.in
index 57cf1d73756b..e32072d6e2b7 100644
--- a/finance/grisbi/files/patch-pixmaps_flags_Makefile.in
+++ b/finance/grisbi/files/patch-pixmaps_flags_Makefile.in
@@ -1,6 +1,6 @@
---- pixmaps/flags/Makefile.in.orig 2010-05-04 20:15:57.000000000 +0200
-+++ pixmaps/flags/Makefile.in 2010-06-07 23:50:38.000000000 +0200
-@@ -246,7 +246,7 @@
+--- pixmaps/flags/Makefile.in.orig 2011-05-22 08:57:12.000000000 +0200
++++ pixmaps/flags/Makefile.in 2012-04-15 21:52:02.000000000 +0200
+@@ -237,7 +237,7 @@
top_build_prefix = @top_build_prefix@
top_builddir = @top_builddir@
top_srcdir = @top_srcdir@
diff --git a/finance/grisbi/files/patch-src::Makefile.in b/finance/grisbi/files/patch-src::Makefile.in
index 679b844e95c3..3d06685c1194 100644
--- a/finance/grisbi/files/patch-src::Makefile.in
+++ b/finance/grisbi/files/patch-src::Makefile.in
@@ -1,11 +1,11 @@
---- src/Makefile.in.orig 2011-02-19 07:18:29.000000000 +0100
-+++ src/Makefile.in 2011-02-20 23:14:42.000000000 +0100
+--- src/Makefile.in.orig 2011-05-22 08:57:12.000000000 +0200
++++ src/Makefile.in 2012-04-15 21:28:52.000000000 +0200
@@ -375,7 +375,7 @@
top_build_prefix = @top_build_prefix@
top_builddir = @top_builddir@
top_srcdir = @top_srcdir@
-AM_CPPFLAGS = -I$(top_srcdir) $(GRISBI_CFLAGS) $(IGE_MAC_CFLAGS) -DLOCALEDIR=\"$(localedir)\" -DPIXMAPS_DIR="\"$(datadir)/pixmaps/@PACKAGE@\"" -DPLUGINS_DIR="\"$(plugindir)\"" -DLOGO_PATH="\"$(datadir)/pixmaps/@PACKAGE@/grisbi-logo.png\"" -DDATA_PATH="\"$(datadir)/@PACKAGE@\"" -DHELP_PATH="\"$(docdir)\""
-+AM_CPPFLAGS = -I$(top_srcdir) $(GRISBI_CFLAGS) $(IGE_MAC_CFLAGS) -DLOCALEDIR=\"$(localedir)\" -DPIXMAPS_DIR="\"$(pkgdatadir)/pixmaps/@PACKAGE@\"" -DPLUGINS_DIR="\"$(plugindir)\"" -DLOGO_PATH="\"$(pkgdatadir)/pixmaps/@PACKAGE@/grisbi-logo.png\"" -DDATA_PATH="\"$(pkgdatadir)/@PACKAGE@\"" -DHELP_PATH="\"$(docdir)\""
++AM_CPPFLAGS = -I$(top_srcdir) $(GRISBI_CFLAGS) $(IGE_MAC_CFLAGS) -DLOCALEDIR=\"$(localedir)\" -DPIXMAPS_DIR="\"$(pkgdatadir)/pixmaps\"" -DPLUGINS_DIR="\"$(plugindir)\"" -DLOGO_PATH="\"$(pkgdatadir)/pixmaps/grisbi-logo.png\"" -DDATA_PATH="\"$(pkgdatadir)\"" -DHELP_PATH="\"$(docdir)\""
noinst_LTLIBRARIES = libgrisbi.la
grisbi_LDADD = $(GRISBI_LIBS) $(IGE_MAC_LIBS) libgrisbi.la
libgrisbi_la_LIBADD = $(am__append_1) $(GRISBI_LIBS) $(IGE_MAC_LIBS)