aboutsummaryrefslogtreecommitdiff
path: root/finance
diff options
context:
space:
mode:
authorRuslan Makhmatkhanov <rm@FreeBSD.org>2012-03-26 18:57:20 +0000
committerRuslan Makhmatkhanov <rm@FreeBSD.org>2012-03-26 18:57:20 +0000
commit58c0a39784d706b74a5fcbe6a44425b332381ea0 (patch)
treec205a716d17ad0e36c3e228fef003ca97bfca67b /finance
parent073ff55a17018b02c43d5273f0d14e59a14b7e37 (diff)
downloadports-58c0a39784d706b74a5fcbe6a44425b332381ea0.tar.gz
ports-58c0a39784d706b74a5fcbe6a44425b332381ea0.zip
Notes
Diffstat (limited to 'finance')
-rw-r--r--finance/Makefile1
-rw-r--r--finance/py-vatnumber/Makefile24
-rw-r--r--finance/py-vatnumber/distinfo2
-rw-r--r--finance/py-vatnumber/pkg-descr4
4 files changed, 31 insertions, 0 deletions
diff --git a/finance/Makefile b/finance/Makefile
index d3c7c74ff30b..9f1b9dac5b91 100644
--- a/finance/Makefile
+++ b/finance/Makefile
@@ -91,6 +91,7 @@
SUBDIR += php-tclink
SUBDIR += php4-pfpro
SUBDIR += prestashop
+ SUBDIR += py-vatnumber
SUBDIR += qhacc
SUBDIR += qtstalker
SUBDIR += quantlib
diff --git a/finance/py-vatnumber/Makefile b/finance/py-vatnumber/Makefile
new file mode 100644
index 000000000000..9835928098e3
--- /dev/null
+++ b/finance/py-vatnumber/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: py-vatnumber
+# Date created: 26 March 2012
+# Whom: Qian Jin <eric.siroh@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= vatnumber
+PORTVERSION= 1.0
+CATEGORIES= finance python
+MASTER_SITES= GOOGLE_CODE
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= eric.siroh@gmail.com
+COMMENT= Python module to validate VAT numbers
+
+LICENSE= GPLv3
+
+# Python3 ready
+USE_PYTHON= yes
+USE_PYDISTUTILS= easy_install
+PLIST_FILES= %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%
+
+.include <bsd.port.mk>
diff --git a/finance/py-vatnumber/distinfo b/finance/py-vatnumber/distinfo
new file mode 100644
index 000000000000..d4077fba9975
--- /dev/null
+++ b/finance/py-vatnumber/distinfo
@@ -0,0 +1,2 @@
+SHA256 (vatnumber-1.0.tar.gz) = 6ef6103f7ecf09cdf32b87bb1c87616b72b9546e4b364a3b66d2b0b4b340665a
+SIZE (vatnumber-1.0.tar.gz) = 21693
diff --git a/finance/py-vatnumber/pkg-descr b/finance/py-vatnumber/pkg-descr
new file mode 100644
index 000000000000..16dc00c92bcf
--- /dev/null
+++ b/finance/py-vatnumber/pkg-descr
@@ -0,0 +1,4 @@
+Python module to validate VAT numbers. VAT means "Value Added Tax".
+More infomations see http://en.wikipedia.org/wiki/VAT_number
+
+WWW: http://code.google.com/p/vatnumber/