aboutsummaryrefslogtreecommitdiff
path: root/finance
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2001-03-29 16:35:19 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2001-03-29 16:35:19 +0000
commit4ca0e60800b90ba4a6de31beabeee8ccce611649 (patch)
tree8324ab31f68eba587c532d238cd3f502d0a56322 /finance
parent7530f93a62fb8bcd686d08f2bfa5dc0f623f3c73 (diff)
Notes
Diffstat (limited to 'finance')
-rw-r--r--finance/emma/Makefile2
-rw-r--r--finance/gnofin/Makefile2
-rw-r--r--finance/gnomepm/Makefile2
-rw-r--r--finance/gnucash-devel/Makefile2
-rw-r--r--finance/gnucash/Makefile2
5 files changed, 5 insertions, 5 deletions
diff --git a/finance/emma/Makefile b/finance/emma/Makefile
index 44af09361aeb..69055e2c333d 100644
--- a/finance/emma/Makefile
+++ b/finance/emma/Makefile
@@ -27,7 +27,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
pre-patch:
- @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
diff --git a/finance/gnofin/Makefile b/finance/gnofin/Makefile
index 1fa7f102328e..d170faf3d953 100644
--- a/finance/gnofin/Makefile
+++ b/finance/gnofin/Makefile
@@ -23,7 +23,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
MAN1= gnofin.1
pre-patch:
- @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g ; \
s|USE_INCLUDED_LIBINTL=yes|#USE_INCLUDED_LIBINTL=yes|g ; \
s|\$$\(top_builddir\)/intl/libintl.a|-lintl|g' ${WRKSRC}/configure
diff --git a/finance/gnomepm/Makefile b/finance/gnomepm/Makefile
index d6bf14ce61c2..581379ff5acf 100644
--- a/finance/gnomepm/Makefile
+++ b/finance/gnomepm/Makefile
@@ -24,7 +24,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
pre-patch:
- @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
diff --git a/finance/gnucash-devel/Makefile b/finance/gnucash-devel/Makefile
index 591a4a4755eb..32d5fd6a4d9b 100644
--- a/finance/gnucash-devel/Makefile
+++ b/finance/gnucash-devel/Makefile
@@ -41,7 +41,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
MAN1= gnc-prices.1 gnucash.1
pre-patch:
- @${PERL} -pi -e 's^-l(pthread|c_r)^-pthread^g ; \
+ @${PERL} -pi -e 's^-l(pthread|c_r)^${PTHREAD_LIBS}^g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
's^\$\{datadir\}/gnome/^\$\(datadir\)/^g ; \
diff --git a/finance/gnucash/Makefile b/finance/gnucash/Makefile
index 591a4a4755eb..32d5fd6a4d9b 100644
--- a/finance/gnucash/Makefile
+++ b/finance/gnucash/Makefile
@@ -41,7 +41,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
MAN1= gnc-prices.1 gnucash.1
pre-patch:
- @${PERL} -pi -e 's^-l(pthread|c_r)^-pthread^g ; \
+ @${PERL} -pi -e 's^-l(pthread|c_r)^${PTHREAD_LIBS}^g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
's^\$\{datadir\}/gnome/^\$\(datadir\)/^g ; \