aboutsummaryrefslogtreecommitdiff
path: root/finance
diff options
context:
space:
mode:
authorAndrej Zverev <az@FreeBSD.org>2012-06-04 05:15:46 +0000
committerAndrej Zverev <az@FreeBSD.org>2012-06-04 05:15:46 +0000
commit5cfb05565510b710936122de4a8641cf9d6ee77e (patch)
treeaa0a891f08eee126dd82ac2ff6ee752d88e8fc75 /finance
parentc651b8ea1487ba21defe341c1818ec393c88db7c (diff)
downloadports-5cfb05565510b710936122de4a8641cf9d6ee77e.tar.gz
ports-5cfb05565510b710936122de4a8641cf9d6ee77e.zip
Notes
Diffstat (limited to 'finance')
-rw-r--r--finance/p5-Business-OnlinePayment-2CheckOut/Makefile6
-rw-r--r--finance/p5-Business-OnlinePayment-BankOfAmerica/Makefile4
-rw-r--r--finance/p5-Business-OnlinePayment-Cardstream/Makefile4
-rw-r--r--finance/p5-Business-OnlinePayment-Jettis/Makefile4
-rw-r--r--finance/p5-Business-OnlinePayment-LinkPoint/Makefile4
-rw-r--r--finance/p5-Business-OnlinePayment-Network1Financial/Makefile4
-rw-r--r--finance/p5-Business-OnlinePayment-PayConnect/Makefile4
-rw-r--r--finance/p5-Business-OnlinePayment-PaymentsGateway/Makefile4
-rw-r--r--finance/p5-Business-OnlinePayment-SurePay/Makefile4
-rw-r--r--finance/p5-Business-OnlinePayment-TCLink/Makefile6
-rw-r--r--finance/p5-Business-OnlinePayment-VirtualNet/Makefile12
-rw-r--r--finance/p5-Business-OnlinePayment-eSec/Makefile4
-rw-r--r--finance/p5-Business-OnlinePayment/Makefile10
-rw-r--r--finance/p5-Data-Currency/Makefile20
14 files changed, 45 insertions, 45 deletions
diff --git a/finance/p5-Business-OnlinePayment-2CheckOut/Makefile b/finance/p5-Business-OnlinePayment-2CheckOut/Makefile
index 84eaefb0ea89..d64ac49ba07b 100644
--- a/finance/p5-Business-OnlinePayment-2CheckOut/Makefile
+++ b/finance/p5-Business-OnlinePayment-2CheckOut/Makefile
@@ -15,9 +15,9 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= A Business::OnlinePayment backend module for 2CheckOut authorization service
-BUILD_DEPENDS= ${SITE_PERL}/Business/CreditCard.pm:${PORTSDIR}/finance/p5-Business-CreditCard \
- ${SITE_PERL}/Business/OnlinePayment.pm:${PORTSDIR}/finance/p5-Business-OnlinePayment \
- ${SITE_PERL}/${PERL_ARCH}/Text/CSV_XS.pm:${PORTSDIR}/textproc/p5-Text-CSV_XS
+BUILD_DEPENDS= p5-Business-CreditCard>=0:${PORTSDIR}/finance/p5-Business-CreditCard \
+ p5-Business-OnlinePayment>=0:${PORTSDIR}/finance/p5-Business-OnlinePayment \
+ p5-Text-CSV_XS>=0:${PORTSDIR}/textproc/p5-Text-CSV_XS
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/finance/p5-Business-OnlinePayment-BankOfAmerica/Makefile b/finance/p5-Business-OnlinePayment-BankOfAmerica/Makefile
index b568b2ca994c..ea625597d308 100644
--- a/finance/p5-Business-OnlinePayment-BankOfAmerica/Makefile
+++ b/finance/p5-Business-OnlinePayment-BankOfAmerica/Makefile
@@ -15,8 +15,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= A Business::OnlinePayment backend module for Bank of America eStores
-BUILD_DEPENDS= ${SITE_PERL}/Business/CreditCard.pm:${PORTSDIR}/finance/p5-Business-CreditCard \
- ${SITE_PERL}/Business/OnlinePayment.pm:${PORTSDIR}/finance/p5-Business-OnlinePayment
+BUILD_DEPENDS= p5-Business-CreditCard>=0:${PORTSDIR}/finance/p5-Business-CreditCard \
+ p5-Business-OnlinePayment>=0:${PORTSDIR}/finance/p5-Business-OnlinePayment
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/finance/p5-Business-OnlinePayment-Cardstream/Makefile b/finance/p5-Business-OnlinePayment-Cardstream/Makefile
index e42086e9190b..e670ae72eb69 100644
--- a/finance/p5-Business-OnlinePayment-Cardstream/Makefile
+++ b/finance/p5-Business-OnlinePayment-Cardstream/Makefile
@@ -15,8 +15,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= A Business::OnlinePayment backend module for Cardstream
-BUILD_DEPENDS= ${SITE_PERL}/Business/CreditCard.pm:${PORTSDIR}/finance/p5-Business-CreditCard \
- ${SITE_PERL}/Business/OnlinePayment.pm:${PORTSDIR}/finance/p5-Business-OnlinePayment
+BUILD_DEPENDS= p5-Business-CreditCard>=0:${PORTSDIR}/finance/p5-Business-CreditCard \
+ p5-Business-OnlinePayment>=0:${PORTSDIR}/finance/p5-Business-OnlinePayment
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/finance/p5-Business-OnlinePayment-Jettis/Makefile b/finance/p5-Business-OnlinePayment-Jettis/Makefile
index a646f9818e38..537028d26c2b 100644
--- a/finance/p5-Business-OnlinePayment-Jettis/Makefile
+++ b/finance/p5-Business-OnlinePayment-Jettis/Makefile
@@ -14,8 +14,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= A Business::OnlinePayment backend module for Jettis
-BUILD_DEPENDS= ${SITE_PERL}/Business/CreditCard.pm:${PORTSDIR}/finance/p5-Business-CreditCard \
- ${SITE_PERL}/Business/OnlinePayment.pm:${PORTSDIR}/finance/p5-Business-OnlinePayment
+BUILD_DEPENDS= p5-Business-CreditCard>=0:${PORTSDIR}/finance/p5-Business-CreditCard \
+ p5-Business-OnlinePayment>=0:${PORTSDIR}/finance/p5-Business-OnlinePayment
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/finance/p5-Business-OnlinePayment-LinkPoint/Makefile b/finance/p5-Business-OnlinePayment-LinkPoint/Makefile
index 83810fb7e69f..f7b974d3894e 100644
--- a/finance/p5-Business-OnlinePayment-LinkPoint/Makefile
+++ b/finance/p5-Business-OnlinePayment-LinkPoint/Makefile
@@ -14,8 +14,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= A Business::OnlinePayment backend module for LinkPoint
-BUILD_DEPENDS= ${SITE_PERL}/Business/CreditCard.pm:${PORTSDIR}/finance/p5-Business-CreditCard \
- ${SITE_PERL}/Business/OnlinePayment.pm:${PORTSDIR}/finance/p5-Business-OnlinePayment
+BUILD_DEPENDS= p5-Business-CreditCard>=0:${PORTSDIR}/finance/p5-Business-CreditCard \
+ p5-Business-OnlinePayment>=0:${PORTSDIR}/finance/p5-Business-OnlinePayment
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/finance/p5-Business-OnlinePayment-Network1Financial/Makefile b/finance/p5-Business-OnlinePayment-Network1Financial/Makefile
index c18876df4340..7afcf32f1221 100644
--- a/finance/p5-Business-OnlinePayment-Network1Financial/Makefile
+++ b/finance/p5-Business-OnlinePayment-Network1Financial/Makefile
@@ -15,8 +15,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= A Business::OnlinePayment backend module for Network1 Financial
-BUILD_DEPENDS= ${SITE_PERL}/Business/CreditCard.pm:${PORTSDIR}/finance/p5-Business-CreditCard \
- ${SITE_PERL}/Business/OnlinePayment.pm:${PORTSDIR}/finance/p5-Business-OnlinePayment
+BUILD_DEPENDS= p5-Business-CreditCard>=0:${PORTSDIR}/finance/p5-Business-CreditCard \
+ p5-Business-OnlinePayment>=0:${PORTSDIR}/finance/p5-Business-OnlinePayment
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/finance/p5-Business-OnlinePayment-PayConnect/Makefile b/finance/p5-Business-OnlinePayment-PayConnect/Makefile
index a803542bfa55..fb44ed6e2fb9 100644
--- a/finance/p5-Business-OnlinePayment-PayConnect/Makefile
+++ b/finance/p5-Business-OnlinePayment-PayConnect/Makefile
@@ -15,8 +15,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= A Business::OnlinePayment backend module for PaymentOne PayConnect
-BUILD_DEPENDS= ${SITE_PERL}/Business/CreditCard.pm:${PORTSDIR}/finance/p5-Business-CreditCard \
- ${SITE_PERL}/Business/OnlinePayment.pm:${PORTSDIR}/finance/p5-Business-OnlinePayment
+BUILD_DEPENDS= p5-Business-CreditCard>=0:${PORTSDIR}/finance/p5-Business-CreditCard \
+ p5-Business-OnlinePayment>=0:${PORTSDIR}/finance/p5-Business-OnlinePayment
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/finance/p5-Business-OnlinePayment-PaymentsGateway/Makefile b/finance/p5-Business-OnlinePayment-PaymentsGateway/Makefile
index 14efe02f7e84..0dff7cdb5750 100644
--- a/finance/p5-Business-OnlinePayment-PaymentsGateway/Makefile
+++ b/finance/p5-Business-OnlinePayment-PaymentsGateway/Makefile
@@ -15,8 +15,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= A Business::OnlinePayment backend module for PaymentsGateway.net ACH Direct
-BUILD_DEPENDS= ${SITE_PERL}/Business/CreditCard.pm:${PORTSDIR}/finance/p5-Business-CreditCard \
- ${SITE_PERL}/Business/OnlinePayment.pm:${PORTSDIR}/finance/p5-Business-OnlinePayment
+BUILD_DEPENDS= p5-Business-CreditCard>=0:${PORTSDIR}/finance/p5-Business-CreditCard \
+ p5-Business-OnlinePayment>=0:${PORTSDIR}/finance/p5-Business-OnlinePayment
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/finance/p5-Business-OnlinePayment-SurePay/Makefile b/finance/p5-Business-OnlinePayment-SurePay/Makefile
index c369959b492c..2c7b239adbb1 100644
--- a/finance/p5-Business-OnlinePayment-SurePay/Makefile
+++ b/finance/p5-Business-OnlinePayment-SurePay/Makefile
@@ -14,8 +14,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= A Business::OnlinePayment backend module for SurePay authorization service
-BUILD_DEPENDS= ${SITE_PERL}/Business/CreditCard.pm:${PORTSDIR}/finance/p5-Business-CreditCard \
- ${SITE_PERL}/Business/OnlinePayment.pm:${PORTSDIR}/finance/p5-Business-OnlinePayment
+BUILD_DEPENDS= p5-Business-CreditCard>=0:${PORTSDIR}/finance/p5-Business-CreditCard \
+ p5-Business-OnlinePayment>=0:${PORTSDIR}/finance/p5-Business-OnlinePayment
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/finance/p5-Business-OnlinePayment-TCLink/Makefile b/finance/p5-Business-OnlinePayment-TCLink/Makefile
index 5d2f17405895..801f4d994e9a 100644
--- a/finance/p5-Business-OnlinePayment-TCLink/Makefile
+++ b/finance/p5-Business-OnlinePayment-TCLink/Makefile
@@ -15,9 +15,9 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= A Business::OnlinePayment backend module for TrustCommerce
-BUILD_DEPENDS= ${SITE_PERL}/Business/CreditCard.pm:${PORTSDIR}/finance/p5-Business-CreditCard \
- ${SITE_PERL}/Business/OnlinePayment.pm:${PORTSDIR}/finance/p5-Business-OnlinePayment \
- ${SITE_PERL}/${PERL_ARCH}/Net/TCLink.pm:${PORTSDIR}/net/p5-Net-TCLink
+BUILD_DEPENDS= p5-Business-CreditCard>=0:${PORTSDIR}/finance/p5-Business-CreditCard \
+ p5-Business-OnlinePayment>=0:${PORTSDIR}/finance/p5-Business-OnlinePayment \
+ p5-Net-TCLink>=0:${PORTSDIR}/net/p5-Net-TCLink
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/finance/p5-Business-OnlinePayment-VirtualNet/Makefile b/finance/p5-Business-OnlinePayment-VirtualNet/Makefile
index 8cac741bb4a4..d9603cfd1e78 100644
--- a/finance/p5-Business-OnlinePayment-VirtualNet/Makefile
+++ b/finance/p5-Business-OnlinePayment-VirtualNet/Makefile
@@ -15,12 +15,12 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= A Business::OnlinePayment backend module for Vital VirtualNet
-BUILD_DEPENDS= ${SITE_PERL}/Business/CreditCard.pm:${PORTSDIR}/finance/p5-Business-CreditCard \
- ${SITE_PERL}/Business/OnlinePayment.pm:${PORTSDIR}/finance/p5-Business-OnlinePayment \
- ${SITE_PERL}/Date/Format.pm:${PORTSDIR}/devel/p5-TimeDate \
- ${SITE_PERL}/File/CounterFile.pm:${PORTSDIR}/misc/p5-File-CounterFile \
- ${SITE_PERL}/String/Parity.pm:${PORTSDIR}/devel/p5-String-Parity \
- ${SITE_PERL}/${PERL_ARCH}/String/LRC.pm:${PORTSDIR}/devel/p5-String-LRC
+BUILD_DEPENDS= p5-Business-CreditCard>=0:${PORTSDIR}/finance/p5-Business-CreditCard \
+ p5-Business-OnlinePayment>=0:${PORTSDIR}/finance/p5-Business-OnlinePayment \
+ p5-TimeDate>=0:${PORTSDIR}/devel/p5-TimeDate \
+ p5-File-CounterFile>=0:${PORTSDIR}/misc/p5-File-CounterFile \
+ p5-String-Parity>=0:${PORTSDIR}/devel/p5-String-Parity \
+ p5-String-LRC>=0:${PORTSDIR}/devel/p5-String-LRC
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/finance/p5-Business-OnlinePayment-eSec/Makefile b/finance/p5-Business-OnlinePayment-eSec/Makefile
index c22edc9944be..b4c5ecb85c14 100644
--- a/finance/p5-Business-OnlinePayment-eSec/Makefile
+++ b/finance/p5-Business-OnlinePayment-eSec/Makefile
@@ -15,8 +15,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= An Business::OnlinePayment backend module for eSec
-BUILD_DEPENDS= ${SITE_PERL}/Business/CreditCard.pm:${PORTSDIR}/finance/p5-Business-CreditCard \
- ${SITE_PERL}/Business/OnlinePayment.pm:${PORTSDIR}/finance/p5-Business-OnlinePayment
+BUILD_DEPENDS= p5-Business-CreditCard>=0:${PORTSDIR}/finance/p5-Business-CreditCard \
+ p5-Business-OnlinePayment>=0:${PORTSDIR}/finance/p5-Business-OnlinePayment
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/finance/p5-Business-OnlinePayment/Makefile b/finance/p5-Business-OnlinePayment/Makefile
index fe2d3b80bfed..d546e975cf36 100644
--- a/finance/p5-Business-OnlinePayment/Makefile
+++ b/finance/p5-Business-OnlinePayment/Makefile
@@ -17,11 +17,11 @@ DISTNAME= ${PORTNAME}-${PORTVERSION}_08
MAINTAINER= perl@FreeBSD.org
COMMENT= A generic interface for processing online credit card payments
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Net/SSLeay.pm:${PORTSDIR}/security/p5-Net-SSLeay \
- ${SITE_PERL}/URI/Escape.pm:${PORTSDIR}/net/p5-URI \
- ${SITE_PERL}/Tie/IxHash.pm:${PORTSDIR}/devel/p5-Tie-IxHash \
- ${SITE_PERL}/${PERL_ARCH}/Crypt/SSLeay.pm:${PORTSDIR}/security/p5-Crypt-SSLeay \
- ${SITE_PERL}/LWP/UserAgent.pm:${PORTSDIR}/www/p5-libwww
+BUILD_DEPENDS= p5-Net-SSLeay>=0:${PORTSDIR}/security/p5-Net-SSLeay \
+ p5-URI>=0:${PORTSDIR}/net/p5-URI \
+ p5-Tie-IxHash>=0:${PORTSDIR}/devel/p5-Tie-IxHash \
+ p5-Crypt-SSLeay>=0:${PORTSDIR}/security/p5-Crypt-SSLeay \
+ p5-libwww>=0:${PORTSDIR}/www/p5-libwww
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/finance/p5-Data-Currency/Makefile b/finance/p5-Data-Currency/Makefile
index 7315780d67d2..aef7322d37f6 100644
--- a/finance/p5-Data-Currency/Makefile
+++ b/finance/p5-Data-Currency/Makefile
@@ -16,16 +16,16 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Container class for currency conversion/formatting
-BUILD_DEPENDS= ${SITE_PERL}/Locale/Currency/Format.pm:${PORTSDIR}/finance/p5-Locale-Currency-Format \
- ${SITE_PERL}/Class/Accessor/Grouped.pm:${PORTSDIR}/devel/p5-Class-Accessor-Grouped \
- ${SITE_PERL}/Finance/Currency/Convert/WebserviceX.pm:${PORTSDIR}/finance/p5-Finance-Currency-Convert-WebserviceX \
- ${SITE_PERL}/Locale/Currency.pm:${PORTSDIR}/misc/p5-Locale-Codes \
- ${SITE_PERL}/Class/Inspector.pm:${PORTSDIR}/devel/p5-Class-Inspector
-RUN_DEPENDS= ${SITE_PERL}/Locale/Currency/Format.pm:${PORTSDIR}/finance/p5-Locale-Currency-Format \
- ${SITE_PERL}/Class/Accessor/Grouped.pm:${PORTSDIR}/devel/p5-Class-Accessor-Grouped \
- ${SITE_PERL}/Finance/Currency/Convert/WebserviceX.pm:${PORTSDIR}/finance/p5-Finance-Currency-Convert-WebserviceX \
- ${SITE_PERL}/Locale/Currency.pm:${PORTSDIR}/misc/p5-Locale-Codes \
- ${SITE_PERL}/Class/Inspector.pm:${PORTSDIR}/devel/p5-Class-Inspector
+BUILD_DEPENDS= p5-Locale-Currency-Format>=0:${PORTSDIR}/finance/p5-Locale-Currency-Format \
+ p5-Class-Accessor-Grouped>=0:${PORTSDIR}/devel/p5-Class-Accessor-Grouped \
+ p5-Finance-Currency-Convert-WebserviceX>=0:${PORTSDIR}/finance/p5-Finance-Currency-Convert-WebserviceX \
+ p5-Locale-Codes>=0:${PORTSDIR}/misc/p5-Locale-Codes \
+ p5-Class-Inspector>=0:${PORTSDIR}/devel/p5-Class-Inspector
+RUN_DEPENDS= p5-Locale-Currency-Format>=0:${PORTSDIR}/finance/p5-Locale-Currency-Format \
+ p5-Class-Accessor-Grouped>=0:${PORTSDIR}/devel/p5-Class-Accessor-Grouped \
+ p5-Finance-Currency-Convert-WebserviceX>=0:${PORTSDIR}/finance/p5-Finance-Currency-Convert-WebserviceX \
+ p5-Locale-Codes>=0:${PORTSDIR}/misc/p5-Locale-Codes \
+ p5-Class-Inspector>=0:${PORTSDIR}/devel/p5-Class-Inspector
PERL_CONFIGURE= yes