aboutsummaryrefslogtreecommitdiff
path: root/finance
diff options
context:
space:
mode:
authorMichael Reifenberger <mr@FreeBSD.org>2021-11-26 14:27:01 +0000
committerMichael Reifenberger <mr@FreeBSD.org>2021-11-26 14:27:01 +0000
commitf7f7bba9fdc1158e527515b70c147e87ee369149 (patch)
tree9377a3fe9db7cd9c91a006291389b39307913068 /finance
parent06baf79d045fb6ad23bf7e67e4327fc377f9bc3d (diff)
downloadports-f7f7bba9fdc1158e527515b70c147e87ee369149.tar.gz
ports-f7f7bba9fdc1158e527515b70c147e87ee369149.zip
finance/nextcloud-cospend: Add nextcloud app cospend
Add Nextcloud Cospend 💰 Nextcloud Cospend is a group/shared budget manager. It was inspired by the great IHateMoney. You can use it when you share a house, when you go on vacation with friends, whenever you share money with others. It lets you create projects with members and bills. Each member has a balance computed from the project bills. This way you can see who owes the group and who the group owes. Ultimately you can ask for a settlement plan telling you which payments to make to reset members balances. Project members are independent from Nextcloud users. Projects can be accessed and modified by people without a Nextcloud account. Each project has an ID and a password for guest access. MoneyBuster Android client is available in F-Droid and on the Play store. PayForMe iOS client is currently being developped!
Diffstat (limited to 'finance')
-rw-r--r--finance/Makefile1
-rw-r--r--finance/nextcloud-cospend/Makefile34
-rw-r--r--finance/nextcloud-cospend/distinfo3
-rw-r--r--finance/nextcloud-cospend/pkg-descr17
4 files changed, 55 insertions, 0 deletions
diff --git a/finance/Makefile b/finance/Makefile
index 963b62995e9c..70af90836a7c 100644
--- a/finance/Makefile
+++ b/finance/Makefile
@@ -45,6 +45,7 @@
SUBDIR += libstocks
SUBDIR += moneymanagerex
SUBDIR += myphpmoney
+ SUBDIR += nextcloud-cospend
SUBDIR += odoo
SUBDIR += p5-Business-CreditCard
SUBDIR += p5-Business-MaxMind-CreditCardFraudDetection
diff --git a/finance/nextcloud-cospend/Makefile b/finance/nextcloud-cospend/Makefile
new file mode 100644
index 000000000000..487e34544a9d
--- /dev/null
+++ b/finance/nextcloud-cospend/Makefile
@@ -0,0 +1,34 @@
+# Created by: Michael Reifenberger <mr@freebsd.org>
+
+PORTNAME= cospend
+PORTVERSION= 1.4.3
+DISTVERSIONPREFIX= v
+CATEGORIES= www editors
+MASTER_SITES= https://github.com/eneiluj/${PORTNAME}-nc/releases/download/${DISTVERSIONPREFIX}${PORTVERSION}/
+PKGNAMEPREFIX= nextcloud-
+PKGNAMESUFFIX= ${PHP_PKGNAMESUFFIX}
+DISTNAME= ${PORTNAME}-${PORTVERSION}
+DIST_SUBDIR= nextcloud/${PORTNAME}-${DISTVERSION}
+
+MAINTAINER= mr@FreeBSD.org
+COMMENT= cospend app for Nextcloud
+
+LICENSE= AGPLv3
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+RUN_DEPENDS= nextcloud${PHP_PKGNAMESUFFIX}>=20:www/nextcloud@${PHP_FLAVOR}
+
+USES= php:flavors
+NO_BUILD= yes
+NO_ARCH= yes
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+WWWDIR= ${PREFIX}/www/nextcloud/apps-pkg/${PORTNAME}
+
+do-install:
+ @${MKDIR} ${STAGEDIR}${WWWDIR}
+ @(cd ${WRKSRC} && ${COPYTREE_SHARE} . ${STAGEDIR}${WWWDIR})
+ @(cd ${WRKSRC}; ${FIND} . -not -type d) | ${SORT} | \
+ ${SED} -e 's,^\.,${WWWDIR_REL},' >> ${TMPPLIST}
+
+.include <bsd.port.mk>
diff --git a/finance/nextcloud-cospend/distinfo b/finance/nextcloud-cospend/distinfo
new file mode 100644
index 000000000000..005aa2c1515a
--- /dev/null
+++ b/finance/nextcloud-cospend/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1637864222
+SHA256 (nextcloud/cospend-1.4.3/cospend-1.4.3.tar.gz) = 251ca1cd9f68d6a427f6ab75b92019c4c2e7d65d9d5e643619ff1e628611df4d
+SIZE (nextcloud/cospend-1.4.3/cospend-1.4.3.tar.gz) = 5736631
diff --git a/finance/nextcloud-cospend/pkg-descr b/finance/nextcloud-cospend/pkg-descr
new file mode 100644
index 000000000000..9dedfcdf0c8c
--- /dev/null
+++ b/finance/nextcloud-cospend/pkg-descr
@@ -0,0 +1,17 @@
+
+Nextcloud Cospend is a group/shared budget manager.
+It was inspired by the great IHateMoney.
+You can use it when you share a house, when you go on vacation with friends,
+whenever you share money with others.
+It lets you create projects with members and bills.
+Each member has a balance computed from the project bills.
+This way you can see who owes the group and who the group owes.
+Ultimately you can ask for a settlement plan telling you
+which payments to make to reset members balances.
+Project members are independent from Nextcloud users.
+Projects can be accessed and modified by people without a Nextcloud account.
+Each project has an ID and a password for guest access.
+MoneyBuster Android client is available in F-Droid and on the Play store.
+PayForMe iOS client is currently being developped!
+
+WWW: https://apps.nextcloud.com/apps/cospend