aboutsummaryrefslogtreecommitdiff
path: root/finance
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2011-09-23 22:26:39 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2011-09-23 22:26:39 +0000
commit6f6fbe4bdf9851de1eb6ebef5287e3007846045e (patch)
tree3b556699991305af672fba96e0e8b6bb88bcc7da /finance
parent86f8cde1da39aadc3efbc11e60998d886c86c36e (diff)
downloadports-6f6fbe4bdf9851de1eb6ebef5287e3007846045e.tar.gz
ports-6f6fbe4bdf9851de1eb6ebef5287e3007846045e.zip
Notes
Diffstat (limited to 'finance')
-rw-r--r--finance/aqbanking/Makefile1
-rw-r--r--finance/gnofin/Makefile4
-rw-r--r--finance/gnucash-docs/Makefile2
-rw-r--r--finance/gnucash/Makefile2
-rw-r--r--finance/grisbi/Makefile4
-rw-r--r--finance/homebank/Makefile5
-rw-r--r--finance/ledger/Makefile1
-rw-r--r--finance/libofx/Makefile5
-rw-r--r--finance/quantlib/Makefile5
-rw-r--r--finance/quantlib/pkg-plist1
10 files changed, 13 insertions, 17 deletions
diff --git a/finance/aqbanking/Makefile b/finance/aqbanking/Makefile
index 4b8af49b5aa7..ceeb7271128d 100644
--- a/finance/aqbanking/Makefile
+++ b/finance/aqbanking/Makefile
@@ -30,7 +30,6 @@ OPTIONS= APIDOC "Full API documentation (requires Doxygen)" off \
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-release="yes"
-CONFIGURE_ENV= LDFLAGS="${LDFLAGS}"
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
MAKE_JOBS_UNSAFE= yes
diff --git a/finance/gnofin/Makefile b/finance/gnofin/Makefile
index 354ab482debc..ac22c38b0e58 100644
--- a/finance/gnofin/Makefile
+++ b/finance/gnofin/Makefile
@@ -19,8 +19,8 @@ USE_GNOME= gnomehack gnomelibs gnomeprefix
USE_GMAKE= yes
USE_AUTOTOOLS= libtool
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
.if !defined(WITHOUT_NLS)
USE_GETTEXT=yes
diff --git a/finance/gnucash-docs/Makefile b/finance/gnucash-docs/Makefile
index 55d348f27400..ce13df912542 100644
--- a/finance/gnucash-docs/Makefile
+++ b/finance/gnucash-docs/Makefile
@@ -24,6 +24,6 @@ INSTALLS_OMF= yes
USE_GMAKE= yes
USE_GNOME= libxml2 gnomehier
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include"
+CPPFLAGS+= -I${LOCALBASE}/include
.include <bsd.port.mk>
diff --git a/finance/gnucash/Makefile b/finance/gnucash/Makefile
index b7da8a7f96bb..ad6eca69d013 100644
--- a/finance/gnucash/Makefile
+++ b/finance/gnucash/Makefile
@@ -45,7 +45,7 @@ USE_GNOME= gnomeprefix libglade2 libgnomeui
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
CPPFLAGS+= -I${LOCALBASE}/include
-CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib"
+LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ARGS= --disable-error-on-warning \
--disable-doxygen
diff --git a/finance/grisbi/Makefile b/finance/grisbi/Makefile
index 90981ceee6af..3c5bdece257f 100644
--- a/finance/grisbi/Makefile
+++ b/finance/grisbi/Makefile
@@ -27,8 +27,8 @@ INSTALLS_ICONS= yes
MAN1= grisbi.1
-CPPFLAGS= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
-CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
+CPPFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
+LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
.if defined(WITHOUT_NLS)
CONFIGURE_ARGS+=--disable-nls
diff --git a/finance/homebank/Makefile b/finance/homebank/Makefile
index f01e4134a321..9449e7b7fb7a 100644
--- a/finance/homebank/Makefile
+++ b/finance/homebank/Makefile
@@ -22,11 +22,10 @@ USE_GNOME= desktopfileutils gnomehier gtk20
USE_GETTEXT= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
INSTALLS_ICONS= yes
-CPPFLAGS= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
-LDFLAGS= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
+CPPFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
+LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
.include <bsd.port.pre.mk>
diff --git a/finance/ledger/Makefile b/finance/ledger/Makefile
index 81851c22a6ed..a03c03f80eb7 100644
--- a/finance/ledger/Makefile
+++ b/finance/ledger/Makefile
@@ -25,7 +25,6 @@ USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/w3c-libwww
LDFLAGS+= -L${LOCALBASE}/lib
-CONFIGURE_ENV+= LDFLAGS="${LDFLAGS}"
NO_INSTALL_MANPAGES= yes
INFO= ledger
diff --git a/finance/libofx/Makefile b/finance/libofx/Makefile
index 163b03c52611..ba180048661c 100644
--- a/finance/libofx/Makefile
+++ b/finance/libofx/Makefile
@@ -21,15 +21,14 @@ USE_ICONV= yes
USE_GMAKE= yes
USE_AUTOTOOLS= aclocal autoheader automake autoconf libtool
ACLOCAL_ARGS= -I m4
-CONFIGURE_ENV= LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS= --disable-doxygen --disable-dot --disable-gengetopt \
--with-opensp-includes=${LOCALBASE}/include/OpenSP \
--with-opensp-libs=${LOCALBASE}/lib
MAKE_JOBS_SAFE= yes
USE_LDCONFIG= yes
-CPPFLAGS= -I${LOCALBASE}/include
-LDFLAGS= -L${LOCALBASE}/lib
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
diff --git a/finance/quantlib/Makefile b/finance/quantlib/Makefile
index 5d121194debb..b8b492fdb32a 100644
--- a/finance/quantlib/Makefile
+++ b/finance/quantlib/Makefile
@@ -21,9 +21,8 @@ WRKSRC= ${WRKDIR}/QuantLib-${PORTVERSION}
USE_AUTOTOOLS= libtool
GNU_CONFIGURE= yes
-CPPFLAGS= ${PTHREAD_CFLAGS} -I${LOCALBASE}/include
-LDFLAGS= ${PTHREAD_LIBS} -L${LOCALBASE}/lib
-MAKE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+CPPFLAGS+= ${PTHREAD_CFLAGS} -I${LOCALBASE}/include
+LDFLAGS+= ${PTHREAD_LIBS} -L${LOCALBASE}/lib
USE_LDCONFIG= yes
MAN1= quantlib-config.1 quantlib-test-suite.1
diff --git a/finance/quantlib/pkg-plist b/finance/quantlib/pkg-plist
index b3b55ea37540..aa7dce96f059 100644
--- a/finance/quantlib/pkg-plist
+++ b/finance/quantlib/pkg-plist
@@ -1,4 +1,5 @@
bin/quantlib-config
+bin/quantlib-test-suite
include/ql/auto_link.hpp
include/ql/cashflow.hpp
include/ql/cashflows/all.hpp