aboutsummaryrefslogtreecommitdiff
path: root/finance
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2013-08-02 18:52:07 +0000
committerMathieu Arnold <mat@FreeBSD.org>2013-08-02 18:52:07 +0000
commit4819ca343bfee8a3b54e7ff3ac26d280d1c1696f (patch)
treea4a613f80a0e443c044c2319e43ce75e14c50813 /finance
parent49b7a7d4a4e27031eeb48b2c26d102a7f8527de9 (diff)
downloadports-4819ca343bfee8a3b54e7ff3ac26d280d1c1696f.tar.gz
ports-4819ca343bfee8a3b54e7ff3ac26d280d1c1696f.zip
Notes
Diffstat (limited to 'finance')
-rw-r--r--finance/p5-Business-OCV/Makefile3
-rw-r--r--finance/p5-Business-OnlinePayment-AuthorizeNet/Makefile3
-rw-r--r--finance/p5-Business-OnlinePayment-BankOfAmerica/Makefile3
-rw-r--r--finance/p5-Business-OnlinePayment-Beanstream/Makefile3
-rw-r--r--finance/p5-Business-OnlinePayment-Cardstream/Makefile3
-rw-r--r--finance/p5-Business-OnlinePayment-Jettis/Makefile3
-rw-r--r--finance/p5-Business-OnlinePayment-LinkPoint/Makefile3
-rw-r--r--finance/p5-Business-OnlinePayment-MerchantCommerce/Makefile3
-rw-r--r--finance/p5-Business-OnlinePayment-Network1Financial/Makefile3
-rw-r--r--finance/p5-Business-OnlinePayment-PayConnect/Makefile3
-rw-r--r--finance/p5-Business-OnlinePayment-PaymenTech/Makefile3
-rw-r--r--finance/p5-Business-OnlinePayment-PaymentsGateway/Makefile3
-rw-r--r--finance/p5-Business-OnlinePayment-TCLink/Makefile3
-rw-r--r--finance/p5-Business-OnlinePayment-VirtualNet/Makefile3
-rw-r--r--finance/p5-Business-OnlinePayment-eSec/Makefile3
-rw-r--r--finance/p5-Business-OnlinePayment/Makefile3
-rw-r--r--finance/p5-Business-TW-Invoice-U420/Makefile9
-rw-r--r--finance/p5-Business-TW-TSIB-CStorePayment/Makefile9
-rw-r--r--finance/p5-Business-TW-TSIB-VirtualAccount/Makefile9
-rw-r--r--finance/p5-Data-Currency/Makefile9
-rw-r--r--finance/p5-Finance-Currency-Convert-WebserviceX/Makefile9
-rw-r--r--finance/p5-Finance-Currency-Convert-XE/Makefile3
-rw-r--r--finance/p5-Finance-Currency-Convert/Makefile9
-rw-r--r--finance/p5-Finance-QuoteHist/Makefile9
-rw-r--r--finance/p5-Finance-QuoteTW/Makefile8
-rw-r--r--finance/p5-Finance-TW-EmergingQuote/Makefile8
-rw-r--r--finance/p5-Finance-TW-TSEQuote/Makefile8
-rw-r--r--finance/p5-Locale-Currency-Format/Makefile9
28 files changed, 67 insertions, 80 deletions
diff --git a/finance/p5-Business-OCV/Makefile b/finance/p5-Business-OCV/Makefile
index 1bb22e32eed0..67224c0fcaf3 100644
--- a/finance/p5-Business-OCV/Makefile
+++ b/finance/p5-Business-OCV/Makefile
@@ -11,6 +11,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Interface to the Ingenico OCV Server
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
.include <bsd.port.mk>
diff --git a/finance/p5-Business-OnlinePayment-AuthorizeNet/Makefile b/finance/p5-Business-OnlinePayment-AuthorizeNet/Makefile
index bee77bfd7f37..e1e10bb629d2 100644
--- a/finance/p5-Business-OnlinePayment-AuthorizeNet/Makefile
+++ b/finance/p5-Business-OnlinePayment-AuthorizeNet/Makefile
@@ -17,7 +17,8 @@ RUN_DEPENDS= p5-Business-OnlinePayment>=3:${PORTSDIR}/finance/p5-Business-Online
p5-XML-Simple>=0:${PORTSDIR}/textproc/p5-XML-Simple \
p5-XML-Writer>=0:${PORTSDIR}/textproc/p5-XML-Writer
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Business::OnlinePayment::AuthorizeNet.3 \
Business::OnlinePayment::AuthorizeNet::AIM.3 \
diff --git a/finance/p5-Business-OnlinePayment-BankOfAmerica/Makefile b/finance/p5-Business-OnlinePayment-BankOfAmerica/Makefile
index 2f3d6be95871..6007d5bfed1c 100644
--- a/finance/p5-Business-OnlinePayment-BankOfAmerica/Makefile
+++ b/finance/p5-Business-OnlinePayment-BankOfAmerica/Makefile
@@ -15,7 +15,8 @@ BUILD_DEPENDS= p5-Business-CreditCard>=0:${PORTSDIR}/finance/p5-Business-CreditC
p5-Business-OnlinePayment>=0:${PORTSDIR}/finance/p5-Business-OnlinePayment
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Business::OnlinePayment::BankOfAmerica.3
diff --git a/finance/p5-Business-OnlinePayment-Beanstream/Makefile b/finance/p5-Business-OnlinePayment-Beanstream/Makefile
index 505f190dd2a7..69ea0a236c75 100644
--- a/finance/p5-Business-OnlinePayment-Beanstream/Makefile
+++ b/finance/p5-Business-OnlinePayment-Beanstream/Makefile
@@ -15,7 +15,8 @@ RUN_DEPENDS= p5-Business-OnlinePayment>=0:${PORTSDIR}/finance/p5-Business-Online
p5-URI>=0:${PORTSDIR}/net/p5-URI
BUILD_DEPENDS:= ${RUN_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Business::OnlinePayment::Beanstream.3
diff --git a/finance/p5-Business-OnlinePayment-Cardstream/Makefile b/finance/p5-Business-OnlinePayment-Cardstream/Makefile
index 355d2d13f848..4713fc07976d 100644
--- a/finance/p5-Business-OnlinePayment-Cardstream/Makefile
+++ b/finance/p5-Business-OnlinePayment-Cardstream/Makefile
@@ -15,7 +15,8 @@ BUILD_DEPENDS= p5-Business-CreditCard>=0:${PORTSDIR}/finance/p5-Business-CreditC
p5-Business-OnlinePayment>=0:${PORTSDIR}/finance/p5-Business-OnlinePayment
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Business::OnlinePayment::Cardstream.3
diff --git a/finance/p5-Business-OnlinePayment-Jettis/Makefile b/finance/p5-Business-OnlinePayment-Jettis/Makefile
index 39d079dfbdcd..f72882b89e75 100644
--- a/finance/p5-Business-OnlinePayment-Jettis/Makefile
+++ b/finance/p5-Business-OnlinePayment-Jettis/Makefile
@@ -14,7 +14,8 @@ BUILD_DEPENDS= p5-Business-CreditCard>=0:${PORTSDIR}/finance/p5-Business-CreditC
p5-Business-OnlinePayment>=0:${PORTSDIR}/finance/p5-Business-OnlinePayment
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Business::OnlinePayment::Jettis.3
diff --git a/finance/p5-Business-OnlinePayment-LinkPoint/Makefile b/finance/p5-Business-OnlinePayment-LinkPoint/Makefile
index d863fe4f7189..6d761406af40 100644
--- a/finance/p5-Business-OnlinePayment-LinkPoint/Makefile
+++ b/finance/p5-Business-OnlinePayment-LinkPoint/Makefile
@@ -14,7 +14,8 @@ BUILD_DEPENDS= p5-Business-CreditCard>=0:${PORTSDIR}/finance/p5-Business-CreditC
p5-Business-OnlinePayment>=0:${PORTSDIR}/finance/p5-Business-OnlinePayment
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Business::OnlinePayment::LinkPoint.3
diff --git a/finance/p5-Business-OnlinePayment-MerchantCommerce/Makefile b/finance/p5-Business-OnlinePayment-MerchantCommerce/Makefile
index f482f4e89038..d9389d43c275 100644
--- a/finance/p5-Business-OnlinePayment-MerchantCommerce/Makefile
+++ b/finance/p5-Business-OnlinePayment-MerchantCommerce/Makefile
@@ -14,7 +14,8 @@ COMMENT= Business::OnlinePayment backend module for MerchantCommerce authorizati
BUILD_DEPENDS= p5-Business-OnlinePayment>=0:${PORTSDIR}/finance/p5-Business-OnlinePayment
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Business::OnlinePayment::MerchantCommerce.3
diff --git a/finance/p5-Business-OnlinePayment-Network1Financial/Makefile b/finance/p5-Business-OnlinePayment-Network1Financial/Makefile
index 613e3ef55121..cf60e984d1d1 100644
--- a/finance/p5-Business-OnlinePayment-Network1Financial/Makefile
+++ b/finance/p5-Business-OnlinePayment-Network1Financial/Makefile
@@ -15,7 +15,8 @@ BUILD_DEPENDS= p5-Business-CreditCard>=0:${PORTSDIR}/finance/p5-Business-CreditC
p5-Business-OnlinePayment>=0:${PORTSDIR}/finance/p5-Business-OnlinePayment
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Business::OnlinePayment::Network1Financial.3
diff --git a/finance/p5-Business-OnlinePayment-PayConnect/Makefile b/finance/p5-Business-OnlinePayment-PayConnect/Makefile
index 86910754110c..3113f4d55df2 100644
--- a/finance/p5-Business-OnlinePayment-PayConnect/Makefile
+++ b/finance/p5-Business-OnlinePayment-PayConnect/Makefile
@@ -15,7 +15,8 @@ BUILD_DEPENDS= p5-Business-CreditCard>=0:${PORTSDIR}/finance/p5-Business-CreditC
p5-Business-OnlinePayment>=0:${PORTSDIR}/finance/p5-Business-OnlinePayment
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Business::OnlinePayment::PayConnect.3
diff --git a/finance/p5-Business-OnlinePayment-PaymenTech/Makefile b/finance/p5-Business-OnlinePayment-PaymenTech/Makefile
index 619d7cbd04bd..f537160b6b6f 100644
--- a/finance/p5-Business-OnlinePayment-PaymenTech/Makefile
+++ b/finance/p5-Business-OnlinePayment-PaymenTech/Makefile
@@ -16,7 +16,8 @@ BUILD_DEPENDS= p5-Business-OnlinePayment>=0:${PORTSDIR}/finance/p5-Business-Onli
p5-Net-HTTPS-Any>=0.10:${PORTSDIR}/net/p5-Net-HTTPS-Any
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Business::OnlinePayment::PaymenTech.3
diff --git a/finance/p5-Business-OnlinePayment-PaymentsGateway/Makefile b/finance/p5-Business-OnlinePayment-PaymentsGateway/Makefile
index f893dfda2f12..fc2e1c442c5a 100644
--- a/finance/p5-Business-OnlinePayment-PaymentsGateway/Makefile
+++ b/finance/p5-Business-OnlinePayment-PaymentsGateway/Makefile
@@ -15,7 +15,8 @@ BUILD_DEPENDS= p5-Business-CreditCard>=0:${PORTSDIR}/finance/p5-Business-CreditC
p5-Business-OnlinePayment>=0:${PORTSDIR}/finance/p5-Business-OnlinePayment
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Business::OnlinePayment::PaymentsGateway.3
diff --git a/finance/p5-Business-OnlinePayment-TCLink/Makefile b/finance/p5-Business-OnlinePayment-TCLink/Makefile
index 20b17bb5ccbc..b106845992e6 100644
--- a/finance/p5-Business-OnlinePayment-TCLink/Makefile
+++ b/finance/p5-Business-OnlinePayment-TCLink/Makefile
@@ -16,7 +16,8 @@ BUILD_DEPENDS= p5-Business-CreditCard>=0:${PORTSDIR}/finance/p5-Business-CreditC
p5-Net-TCLink>=0:${PORTSDIR}/net/p5-Net-TCLink
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Business::OnlinePayment::TCLink.3
diff --git a/finance/p5-Business-OnlinePayment-VirtualNet/Makefile b/finance/p5-Business-OnlinePayment-VirtualNet/Makefile
index 82233a52d0cd..10dcfd8b0d45 100644
--- a/finance/p5-Business-OnlinePayment-VirtualNet/Makefile
+++ b/finance/p5-Business-OnlinePayment-VirtualNet/Makefile
@@ -19,7 +19,8 @@ BUILD_DEPENDS= p5-Business-CreditCard>=0:${PORTSDIR}/finance/p5-Business-CreditC
p5-String-LRC>=0:${PORTSDIR}/devel/p5-String-LRC
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Business::OnlinePayment::VirtualNet.3
diff --git a/finance/p5-Business-OnlinePayment-eSec/Makefile b/finance/p5-Business-OnlinePayment-eSec/Makefile
index fed8cc5bcb80..474299f838ce 100644
--- a/finance/p5-Business-OnlinePayment-eSec/Makefile
+++ b/finance/p5-Business-OnlinePayment-eSec/Makefile
@@ -15,7 +15,8 @@ BUILD_DEPENDS= p5-Business-CreditCard>=0:${PORTSDIR}/finance/p5-Business-CreditC
p5-Business-OnlinePayment>=0:${PORTSDIR}/finance/p5-Business-OnlinePayment
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Business::OnlinePayment::eSec.3
diff --git a/finance/p5-Business-OnlinePayment/Makefile b/finance/p5-Business-OnlinePayment/Makefile
index 80c537463485..f73014c72fe1 100644
--- a/finance/p5-Business-OnlinePayment/Makefile
+++ b/finance/p5-Business-OnlinePayment/Makefile
@@ -18,7 +18,8 @@ BUILD_DEPENDS= p5-Net-SSLeay>=0:${PORTSDIR}/security/p5-Net-SSLeay \
p5-libwww>=0:${PORTSDIR}/www/p5-libwww
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Business::OnlinePayment.3 \
Business::FraudDetect.3 \
diff --git a/finance/p5-Business-TW-Invoice-U420/Makefile b/finance/p5-Business-TW-Invoice-U420/Makefile
index fe099bf7aa8b..19c55c6d243c 100644
--- a/finance/p5-Business-TW-Invoice-U420/Makefile
+++ b/finance/p5-Business-TW-Invoice-U420/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Business-TW-Invoice-U420
-# Date created: 2007/10/04
-# Whom: chinsan
-#
+# Created by: chinsan
# $FreeBSD$
-#
PORTNAME= Business-TW-Invoice-U420
PORTVERSION= 0.01
@@ -17,7 +13,8 @@ COMMENT= Print Taiwan Unified Invoice with U420 printer
BUILD_DEPENDS= p5-Class-Accessor>=0:${PORTSDIR}/devel/p5-Class-Accessor
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Business::TW::Invoice::U420.3
diff --git a/finance/p5-Business-TW-TSIB-CStorePayment/Makefile b/finance/p5-Business-TW-TSIB-CStorePayment/Makefile
index a3ae976db52f..16c684e735fe 100644
--- a/finance/p5-Business-TW-TSIB-CStorePayment/Makefile
+++ b/finance/p5-Business-TW-TSIB-CStorePayment/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Business-TW-TSIB-CStorePayment
-# Date created: 2007/10/04
-# Whom: chinsan
-#
+# Created by: chinsan
# $FreeBSD$
-#
PORTNAME= Business-TW-TSIB-CStorePayment
PORTVERSION= 0.04
@@ -19,7 +15,8 @@ BUILD_DEPENDS= p5-Class-Accessor>=0:${PORTSDIR}/devel/p5-Class-Accessor \
p5-List-MoreUtils>=0:${PORTSDIR}/lang/p5-List-MoreUtils
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Business::TW::TSIB::CStorePayment.3
diff --git a/finance/p5-Business-TW-TSIB-VirtualAccount/Makefile b/finance/p5-Business-TW-TSIB-VirtualAccount/Makefile
index a6deaa184836..51edbeebefe3 100644
--- a/finance/p5-Business-TW-TSIB-VirtualAccount/Makefile
+++ b/finance/p5-Business-TW-TSIB-VirtualAccount/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Business-TW-TSIB-VirtualAccount
-# Date created: 2007/10/04
-# Whom: chinsan
-#
+# Created by: chinsan
# $FreeBSD$
-#
PORTNAME= Business-TW-TSIB-VirtualAccount
PORTVERSION= 0.04b
@@ -19,7 +15,8 @@ BUILD_DEPENDS= p5-Class-Accessor>=0:${PORTSDIR}/devel/p5-Class-Accessor \
p5-DateTime>=0:${PORTSDIR}/devel/p5-DateTime
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Business::TW::TSIB::VirtualAccount.3
diff --git a/finance/p5-Data-Currency/Makefile b/finance/p5-Data-Currency/Makefile
index aef7322d37f6..08cd0d4b22ee 100644
--- a/finance/p5-Data-Currency/Makefile
+++ b/finance/p5-Data-Currency/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: finance/p5-Data-Currency
-# Date created: 01 November 2007
-# Whom: Zach Thompson <hideo@lastamericanempire.com>
-#
+# Created by: Zach Thompson <hideo@lastamericanempire.com>
# $FreeBSD$
-#
PORTNAME= Data-Currency
PORTVERSION= 0.04002
@@ -27,7 +23,8 @@ RUN_DEPENDS= p5-Locale-Currency-Format>=0:${PORTSDIR}/finance/p5-Locale-Currency
p5-Locale-Codes>=0:${PORTSDIR}/misc/p5-Locale-Codes \
p5-Class-Inspector>=0:${PORTSDIR}/devel/p5-Class-Inspector
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Data::Currency.3
diff --git a/finance/p5-Finance-Currency-Convert-WebserviceX/Makefile b/finance/p5-Finance-Currency-Convert-WebserviceX/Makefile
index 640f4309a203..acbad3b54860 100644
--- a/finance/p5-Finance-Currency-Convert-WebserviceX/Makefile
+++ b/finance/p5-Finance-Currency-Convert-WebserviceX/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Finance-Currency-Convert-WebserviceX
-# Date Created: 27 Dec 2005
-# Whom: Zach Thompson <hideo@lastamericanempire.com>
-#
+# Created by: Zach Thompson <hideo@lastamericanempire.com>
# $FreeBSD$
-#
PORTNAME= Finance-Currency-Convert-WebserviceX
PORTVERSION= 0.07001
@@ -18,7 +14,8 @@ BUILD_DEPENDS= p5-libwww>=0:${PORTSDIR}/www/p5-libwww \
p5-Module-Install>=0.65:${PORTSDIR}/devel/p5-Module-Install
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Finance::Currency::Convert::WebserviceX.3
diff --git a/finance/p5-Finance-Currency-Convert-XE/Makefile b/finance/p5-Finance-Currency-Convert-XE/Makefile
index 485e69d33f50..df30183adb16 100644
--- a/finance/p5-Finance-Currency-Convert-XE/Makefile
+++ b/finance/p5-Finance-Currency-Convert-XE/Makefile
@@ -18,7 +18,8 @@ BUILD_DEPENDS:= ${RUN_DEPENDS}
OPTIONS_DEFINE= DOCS
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Finance::Currency::Convert::XE.3
PORTDOCS= Changes README
diff --git a/finance/p5-Finance-Currency-Convert/Makefile b/finance/p5-Finance-Currency-Convert/Makefile
index 976f4b0546f8..5fcf09d9494c 100644
--- a/finance/p5-Finance-Currency-Convert/Makefile
+++ b/finance/p5-Finance-Currency-Convert/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: Finance::Currency::Convert
-# Date created: 25 Jan 2002
-# Whom: Seamus Venasse <svenasse@polaris.ca>
-#
+# Created by: Seamus Venasse <svenasse@polaris.ca>
# $FreeBSD$
-#
PORTNAME= Finance-Currency-Convert
PORTVERSION= 1.08
@@ -18,7 +14,8 @@ COMMENT= Convert currencies and fetch their exchange rates
LICENSE= ART10 GPLv1
LICENSE_COMB= dual
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Finance::Currency::Convert.3
diff --git a/finance/p5-Finance-QuoteHist/Makefile b/finance/p5-Finance-QuoteHist/Makefile
index 198c993b7e99..9f5637bb6cb2 100644
--- a/finance/p5-Finance-QuoteHist/Makefile
+++ b/finance/p5-Finance-QuoteHist/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: Finance::QuoteHist
-# Date created: 25 Jan 2002
-# Whom: Seamus Venasse <svenasse@polaris.ca>
-#
+# Created by: Seamus Venasse <svenasse@polaris.ca>
# $FreeBSD$
-#
PORTNAME= Finance-QuoteHist
PORTVERSION= 1.19
@@ -27,7 +23,8 @@ RUN_DEPENDS= p5-Date-Manip>=0:${PORTSDIR}/devel/p5-Date-Manip \
p5-Text-CSV>=0:${PORTSDIR}/textproc/p5-Text-CSV \
p5-libwww>=0:${PORTSDIR}/www/p5-libwww
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Finance::QuoteHist.3 \
Finance::QuoteHist::BusinessWeek.3 \
diff --git a/finance/p5-Finance-QuoteTW/Makefile b/finance/p5-Finance-QuoteTW/Makefile
index 31a2b20337ea..8e5b5673c680 100644
--- a/finance/p5-Finance-QuoteTW/Makefile
+++ b/finance/p5-Finance-QuoteTW/Makefile
@@ -1,9 +1,6 @@
# Ports collection makefile for: p5-Finance-QuoteTW
-# Date created: 2008/08/31
-# Whom: chinsan
-#
+# Created by: chinsan
# $FreeBSD$
-#
PORTNAME= Finance-QuoteTW
PORTVERSION= 0.09
@@ -24,7 +21,8 @@ RUN_DEPENDS= p5-Data-TreeDumper>=0:${PORTSDIR}/devel/p5-Data-TreeDumper \
p5-version>=0.76:${PORTSDIR}/devel/p5-version
BUILD_DEPENDS:= ${RUN_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Finance::QuoteTW.3 \
Finance::QuoteTW::Allianz.3 \
diff --git a/finance/p5-Finance-TW-EmergingQuote/Makefile b/finance/p5-Finance-TW-EmergingQuote/Makefile
index c0b9c890920c..4f5ac949af47 100644
--- a/finance/p5-Finance-TW-EmergingQuote/Makefile
+++ b/finance/p5-Finance-TW-EmergingQuote/Makefile
@@ -1,10 +1,7 @@
# ex:ts=8
# Ports collection makefile for: Finance::TW::EmergingQuote
-# Date created: Feb 16, 2007
-# Whom: ijliao
-#
+# Created by: ijliao
# $FreeBSD$
-#
PORTNAME= Finance-TW-EmergingQuote
PORTVERSION= 0.26
@@ -18,7 +15,8 @@ COMMENT= Check stock quotes from Taiwan Emerging Stock
BUILD_DEPENDS= p5-libwww>=0:${PORTSDIR}/www/p5-libwww
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Finance::TW::EmergingQuote.3
diff --git a/finance/p5-Finance-TW-TSEQuote/Makefile b/finance/p5-Finance-TW-TSEQuote/Makefile
index 86ee6d4e715e..f1aa54ad8160 100644
--- a/finance/p5-Finance-TW-TSEQuote/Makefile
+++ b/finance/p5-Finance-TW-TSEQuote/Makefile
@@ -1,10 +1,7 @@
# ex:ts=8
# Ports collection makefile for: Finance::TW::TSEQuote
-# Date created: Apr 28, 2006
-# Whom: ijliao
-#
+# Created by: ijliao
# $FreeBSD$
-#
PORTNAME= Finance-TW-TSEQuote
PORTVERSION= 0.2.8
@@ -25,7 +22,8 @@ BUILD_DEPENDS= p5-App-Cache>=0:${PORTSDIR}/devel/p5-App-Cache \
p5-libwww>=0:${PORTSDIR}/www/p5-libwww
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN1= pfq.1
MAN3= Finance::TW::TSEQuote.3
diff --git a/finance/p5-Locale-Currency-Format/Makefile b/finance/p5-Locale-Currency-Format/Makefile
index e49ce98b3f0c..737b83dfcd70 100644
--- a/finance/p5-Locale-Currency-Format/Makefile
+++ b/finance/p5-Locale-Currency-Format/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Locale-Currency-Format
-# Date Created: 27 Dec 2005
-# Whom: Zach Thompson <hideo@lastamericanempire.com>
-#
+# Created by: Zach Thompson <hideo@lastamericanempire.com>
# $FreeBSD$
-#
PORTNAME= Locale-Currency-Format
PORTVERSION= 1.30
@@ -14,7 +10,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Perl functions for formatting monetary values
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
LICENSE_COMB= dual
LICENSE= ART20 GPLv1