aboutsummaryrefslogtreecommitdiff
path: root/finance
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2006-08-28 21:05:20 +0000
committerPav Lucistnik <pav@FreeBSD.org>2006-08-28 21:05:20 +0000
commit8ca878d00f894de746f8fc4aae1634960596bbdb (patch)
tree269ae99c051c4614e4cf43581e61be3054b8bd1b /finance
parent55ae413eca29e228d1868963eff2aa8134cae3f6 (diff)
downloadports-8ca878d00f894de746f8fc4aae1634960596bbdb.tar.gz
ports-8ca878d00f894de746f8fc4aae1634960596bbdb.zip
Notes
Diffstat (limited to 'finance')
-rw-r--r--finance/Makefile1
-rw-r--r--finance/opentaxsolver/Makefile53
-rw-r--r--finance/opentaxsolver/distinfo3
-rw-r--r--finance/opentaxsolver/files/patch-src-GUI-otk_lib-otk_lib.c13
-rw-r--r--finance/opentaxsolver/files/patch-src-GUI-ots_gui.c31
-rw-r--r--finance/opentaxsolver/pkg-descr19
-rw-r--r--finance/opentaxsolver/pkg-plist53
7 files changed, 173 insertions, 0 deletions
diff --git a/finance/Makefile b/finance/Makefile
index 2f214f9af358..284268269836 100644
--- a/finance/Makefile
+++ b/finance/Makefile
@@ -23,6 +23,7 @@
SUBDIR += mybudget
SUBDIR += myphpmoney
SUBDIR += openhbci
+ SUBDIR += opentaxsolver
SUBDIR += p5-Business-CreditCard
SUBDIR += p5-Business-OCV
SUBDIR += p5-Business-OnlinePayment
diff --git a/finance/opentaxsolver/Makefile b/finance/opentaxsolver/Makefile
new file mode 100644
index 000000000000..357fa4bc38a6
--- /dev/null
+++ b/finance/opentaxsolver/Makefile
@@ -0,0 +1,53 @@
+# Ports collection makefile for: opentaxsolver
+# Date created: Sat Apr 08, 2006
+# Whom: John Hein (jhein@timing.com)
+#
+# $FreeBSD$
+#
+
+PORTNAME= ${UPPORTNAME:L}
+PORTVERSION= 3.07
+CATEGORIES= finance
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= opentaxsolver
+DISTNAME= ${UPPORTNAME}2005_3.07
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= jhein@timing.com
+COMMENT= US tax prep software
+
+USE_XLIB= yes
+UPPORTNAME= OpenTaxSolver
+
+post-patch:
+ @${REINPLACE_CMD} -e 's/%%PREFIX%%/${PREFIX:C,/,\/,g}/' \
+ ${WRKSRC}/src/GUI/ots_gui.c
+
+do-build:
+ @(cd ${BUILD_WRKSRC}; ${SETENV} ${MAKE_ENV} \
+ ./Build_taxsolve_packages_LINUX.sh)
+
+BUILDPROGLISTCMD= ${FIND} bin -type f
+BUILDEXAMPLELISTCMD= ${FIND} examples_and_templates -type f
+NEWPLIST= ${WRKDIR}/plist.new
+
+do-install:
+ @(cd ${WRKSRC} && \
+ for prog in $$(${BUILDPROGLISTCMD}); do \
+ ${INSTALL_PROGRAM} $${prog} ${PREFIX}/bin/. ; \
+ done && \
+ ${MKDIR} ${PREFIX}/share/ots && \
+ ${INSTALL_DATA} src/GUI/otslogo.ppm ${PREFIX}/share/ots/. && \
+ for example in $$(${BUILDEXAMPLELISTCMD}); do \
+ ${MKDIR} ${PREFIX}/share/ots/$$(dirname $${example}) && \
+ ${INSTALL_DATA} $${example} \
+ ${PREFIX}/share/ots/$$(dirname $${example})/. ; \
+ done)
+
+new-plist:
+ @(cd ${WRKSRC} && \
+ ${BUILDPROGLISTCMD} > ${NEWPLIST} && \
+ ${ECHO_CMD} share/ots/otslogo.ppm >> ${NEWPLIST} && \
+ ${BUILDEXAMPLELISTCMD} | ${SED} 's,^,share/ots/,' >> ${NEWPLIST})
+
+.include <bsd.port.mk>
diff --git a/finance/opentaxsolver/distinfo b/finance/opentaxsolver/distinfo
new file mode 100644
index 000000000000..6f00c99c18d7
--- /dev/null
+++ b/finance/opentaxsolver/distinfo
@@ -0,0 +1,3 @@
+MD5 (OpenTaxSolver2005_3.07.tgz) = 7601b50059b55588104591de9e7a8cac
+SHA256 (OpenTaxSolver2005_3.07.tgz) = acf281b2c62405808f453a4c3c926c950501a2700a621aad80ff35b7d0b5d823
+SIZE (OpenTaxSolver2005_3.07.tgz) = 224382
diff --git a/finance/opentaxsolver/files/patch-src-GUI-otk_lib-otk_lib.c b/finance/opentaxsolver/files/patch-src-GUI-otk_lib-otk_lib.c
new file mode 100644
index 000000000000..4a959c35ed88
--- /dev/null
+++ b/finance/opentaxsolver/files/patch-src-GUI-otk_lib-otk_lib.c
@@ -0,0 +1,13 @@
+--- src/GUI/otk_lib/otk_lib.c.orig Fri Mar 31 21:42:34 2006
++++ src/GUI/otk_lib/otk_lib.c Sat Apr 8 11:50:21 2006
+@@ -38,6 +38,10 @@
+ /* Set debug switch. 1=verbose. 0=quiet. */
+ #define DEBUG if (0)
+
++#ifdef __FreeBSD__
++#include <sys/time.h>
++#endif
++
+ #include "otk_lib.h"
+
+ int Otk_verbose=0;
diff --git a/finance/opentaxsolver/files/patch-src-GUI-ots_gui.c b/finance/opentaxsolver/files/patch-src-GUI-ots_gui.c
new file mode 100644
index 000000000000..f8962ba58068
--- /dev/null
+++ b/finance/opentaxsolver/files/patch-src-GUI-ots_gui.c
@@ -0,0 +1,31 @@
+--- src/GUI/ots_gui.c.orig Sun Apr 2 22:56:24 2006
++++ src/GUI/ots_gui.c Sat Apr 8 19:46:40 2006
+@@ -1026,7 +1026,7 @@
+ }
+ else
+ {
+- sprintf(tmpstr,"%s%s", invocation_path, strg);
++ snprintf(tmpstr, sizeof(tmpstr), "%s%s", invocation_path, strg);
+ printf("Setting Tax Program to be: '%s'\n", tmpstr);
+ taxsolvecmd = strdup(tmpstr);
+ strcpy(taxsolvestrng,tmpstr);
+@@ -1037,8 +1037,8 @@
+ if (k>0) k--;
+ while ((k>0) && (tmpstr[k]!=slashchr)) k--;
+ if (tmpstr[k]==slashchr) tmpstr[k+1] = '\0';
+- else {sprintf(tmpstr,".%c", slashchr);}
+- sprintf(directory_dat,"%sexamples_and_templates%c", tmpstr, slashchr);
++ else {snprintf(tmpstr, sizeof(tmpstr), ".%c", slashchr);}
++ snprintf(directory_dat, sizeof(directory_dat), "%sexamples_and_templates%c", "%%PREFIX%%/share/ots/", slashchr);
+ /* CA_540 MA_1 NC_400 NJ_1040 NY_IT201 OH_1040 PA_40 US_1040 US_1040_Sched_C VA_760 */
+ if (strstr(strg,"CA_540")) strcat(directory_dat,"CA_540"); else
+ if (strstr(strg,"MA_1")) strcat(directory_dat,"MA_1"); else
+@@ -1118,7 +1118,7 @@
+ main_panel =
+ OtkMakePanel( OtkOuterWindow, Otk_Raised, Otk_LightGray, 1, 7.5, 98, 87 ); /* Main Panel. */
+ Otk_SetBorderThickness( main_panel, 0.25 );
+- sprintf(tmpstr,"%s..%csrc%cGUI%cotslogo.ppm", invocation_path, slashchr, slashchr, slashchr );
++ snprintf(tmpstr, sizeof(tmpstr), "%%PREFIX%%/share/ots/otslogo.ppm");
+ subpanel = OtkMakePanel( main_panel, Otk_Raised, Otk_LightGray, 20, 2, 60, 20 );
+ testfile = fopen(tmpstr,"r");
+ if (testfile!=0)
diff --git a/finance/opentaxsolver/pkg-descr b/finance/opentaxsolver/pkg-descr
new file mode 100644
index 000000000000..425a7cc51f7a
--- /dev/null
+++ b/finance/opentaxsolver/pkg-descr
@@ -0,0 +1,19 @@
+OpenTaxSolver (OTS) is a free program for calculating Tax Form
+entries and tax-owed or refund-due, such as US Federal or State
+personal income taxes. An optional graphical front-end, OTS_GUI,
+has been added. Preliminary versions for Canada and the United
+Kingdom were posted in previous years and may be updated with help
+from volunteers.
+
+Motivations include:
+
+ * To make tax preparation software available for all platforms.
+ * To provide insight into how our taxes are calculated in clear
+ unambiguous equations/code.
+ * To avoid invasive, bloated commercial software packages.
+ * To avoid rewriting our own individual programs each year by
+ combining efforts.
+ * To provide a simple reliable tax-package requiring only
+ rudimentary knowledge to maintain.
+
+WWW: http://opentaxsolver.sourceforge.net/
diff --git a/finance/opentaxsolver/pkg-plist b/finance/opentaxsolver/pkg-plist
new file mode 100644
index 000000000000..35b5ffbf63c9
--- /dev/null
+++ b/finance/opentaxsolver/pkg-plist
@@ -0,0 +1,53 @@
+bin/ots_gui
+bin/taxsolve_US_1040_2005
+bin/taxsolve_US_1040_Sched_C_2005
+bin/taxsolve_CA_540_2005
+bin/taxsolve_MA_1_2005
+bin/taxsolve_NJ_1040_2005
+bin/taxsolve_PA_40_2005
+bin/taxsolve_VA_760_2005
+bin/taxsolve_OH_IT1040_2005
+bin/taxsolve_NY_IT201_2005
+share/ots/otslogo.ppm
+share/ots/examples_and_templates/CA_540/CA_540_2005_template.dat
+share/ots/examples_and_templates/CA_540/README_CA_540.txt
+share/ots/examples_and_templates/CA_540/CA_540_2005_example.dat
+share/ots/examples_and_templates/VA_760/VA_760_example.dat
+share/ots/examples_and_templates/VA_760/README_VA_760.txt
+share/ots/examples_and_templates/VA_760/VA_760_template.dat
+share/ots/examples_and_templates/MA_1/MA_1_2005_example.dat
+share/ots/examples_and_templates/MA_1/README_MA_1.txt
+share/ots/examples_and_templates/MA_1/MA_1_2005_template.dat
+share/ots/examples_and_templates/US_1040_Sched_C/README_US_1040_Sched_C.txt
+share/ots/examples_and_templates/US_1040_Sched_C/US_1040Sched_C_2005_example.dat
+share/ots/examples_and_templates/US_1040_Sched_C/US_1040Sched_C_2005_template.dat
+share/ots/examples_and_templates/OH_1040/README_OH_IT1040.txt
+share/ots/examples_and_templates/OH_1040/OH_IT1040_2005_template.dat
+share/ots/examples_and_templates/OH_1040/OH_IT1040_2005_example.dat
+share/ots/examples_and_templates/US_1040/US_1040_template.dat
+share/ots/examples_and_templates/US_1040/README_US_1040.txt
+share/ots/examples_and_templates/US_1040/US_1040_example.dat
+share/ots/examples_and_templates/NC_400/README_NC_400.txt
+share/ots/examples_and_templates/NC_400/NC_400_2005_example.dat
+share/ots/examples_and_templates/NC_400/NC_400_2005_template.dat
+share/ots/examples_and_templates/NJ_1040/NJ_1040_2005_template.dat
+share/ots/examples_and_templates/NJ_1040/NJ_1040_2005_example.dat
+share/ots/examples_and_templates/NJ_1040/README_NJ_1040.txt
+share/ots/examples_and_templates/PA_40/README_PA_40.txt
+share/ots/examples_and_templates/PA_40/PA_40_2005_template.dat
+share/ots/examples_and_templates/PA_40/PA_40_2005_example.dat
+share/ots/examples_and_templates/NY_IT201/NY_IT201_2004_example.dat
+share/ots/examples_and_templates/NY_IT201/README_NY_IT201.txt
+share/ots/examples_and_templates/NY_IT201/NY_IT201_2004_template.dat
+@dirrm share/ots/examples_and_templates/CA_540
+@dirrm share/ots/examples_and_templates/VA_760
+@dirrm share/ots/examples_and_templates/MA_1
+@dirrm share/ots/examples_and_templates/US_1040_Sched_C
+@dirrm share/ots/examples_and_templates/OH_1040
+@dirrm share/ots/examples_and_templates/US_1040
+@dirrm share/ots/examples_and_templates/NC_400
+@dirrm share/ots/examples_and_templates/NJ_1040
+@dirrm share/ots/examples_and_templates/PA_40
+@dirrm share/ots/examples_and_templates/NY_IT201
+@dirrm share/ots/examples_and_templates
+@dirrm share/ots