aboutsummaryrefslogtreecommitdiff
path: root/finance
diff options
context:
space:
mode:
authorMichael Scheidell <scheidell@FreeBSD.org>2012-01-19 10:09:36 +0000
committerMichael Scheidell <scheidell@FreeBSD.org>2012-01-19 10:09:36 +0000
commitb482184adb379b0429c7ac0acc3dc3ec182daff5 (patch)
tree6cf51b9b8e05a606a766ce83802853c6a8858582 /finance
parent70891f498b7c2a98d2639c829dcb44aeb0781449 (diff)
downloadports-b482184adb379b0429c7ac0acc3dc3ec182daff5.tar.gz
ports-b482184adb379b0429c7ac0acc3dc3ec182daff5.zip
Notes
Diffstat (limited to 'finance')
-rw-r--r--finance/kmymoney-kde4/Makefile1
-rw-r--r--finance/kmymoney-kde4/files/patch-kmymoney__converter__mymoneygncreader.cpp32
2 files changed, 33 insertions, 0 deletions
diff --git a/finance/kmymoney-kde4/Makefile b/finance/kmymoney-kde4/Makefile
index ca461fddcb02..4006bd219f23 100644
--- a/finance/kmymoney-kde4/Makefile
+++ b/finance/kmymoney-kde4/Makefile
@@ -7,6 +7,7 @@
PORTNAME= kmymoney
PORTVERSION= 4.6.1
+PORTREVISION= 1
CATEGORIES= finance kde
MASTER_SITES= SF/${PORTNAME}2/KMyMoney-KDE4/${PORTVERSION}
diff --git a/finance/kmymoney-kde4/files/patch-kmymoney__converter__mymoneygncreader.cpp b/finance/kmymoney-kde4/files/patch-kmymoney__converter__mymoneygncreader.cpp
new file mode 100644
index 000000000000..ee55ddd9791d
--- /dev/null
+++ b/finance/kmymoney-kde4/files/patch-kmymoney__converter__mymoneygncreader.cpp
@@ -0,0 +1,32 @@
+--- ./kmymoney/converter/mymoneygncreader.cpp.orig 2011-11-05 05:20:14.000000000 -0400
++++ ./kmymoney/converter/mymoneygncreader.cpp 2012-01-17 04:21:49.000000000 -0500
+@@ -1256,7 +1256,6 @@
+ #ifndef _GNCFILEANON
+ void MyMoneyGncReader::readFile(QIODevice* pDevice, IMyMoneySerialize* storage)
+ {
+-
+ Q_CHECK_PTR(pDevice);
+ Q_CHECK_PTR(storage);
+
+@@ -1270,6 +1269,8 @@
+ MyMoneyFile::instance()->attachStorage(m_storage);
+ MyMoneyFileTransaction ft;
+ m_xr = new XmlReader(this);
++ bool blocked = MyMoneyFile::instance()->signalsBlocked();
++ MyMoneyFile::instance()->blockSignals(true);
+ try {
+ m_xr->processFile(pDevice);
+ terminate(); // do all the wind-up things
+@@ -1278,11 +1279,11 @@
+ KMessageBox::error(0, i18n("Import failed:\n\n%1", e->what()), PACKAGE);
+ qWarning("%s", qPrintable(e->what()));
+ } // end catch
++ MyMoneyFile::instance()->blockSignals(blocked);
+ MyMoneyFile::instance()->detachStorage(m_storage);
+ signalProgress(0, 1, i18n("Import complete")); // switch off progress bar
+ delete m_xr;
+ qDebug("Exiting gnucash importer");
+- return;
+ }
+ #else
+ // Control code for the file anonymizer \ No newline at end of file