aboutsummaryrefslogtreecommitdiff
path: root/finance
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2021-05-24 16:14:40 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2021-05-24 16:14:40 +0000
commit16625453b9300feee0eb5b46a251ea7c9da5782d (patch)
treeb28e60f76f70a200a8a6ec1f2f03a3a9773d3769 /finance
parentca7135c85974b8e5b2688ddf26894b79d9b4098b (diff)
downloadports-16625453b9300feee0eb5b46a251ea7c9da5782d.tar.gz
ports-16625453b9300feee0eb5b46a251ea7c9da5782d.zip
finance/electrum: Loosen version restriction on dependency
electrum runs just fine in dark mode with the latest version of textproc/py-QDarkStyle. This unblocks long overdue update of textproc/py-QDarkStyle which is anticipated by other ports.
Diffstat (limited to 'finance')
-rw-r--r--finance/electrum/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/finance/electrum/Makefile b/finance/electrum/Makefile
index 399fdb7f9a75..b714771ed31a 100644
--- a/finance/electrum/Makefile
+++ b/finance/electrum/Makefile
@@ -2,6 +2,7 @@
PORTNAME= electrum
PORTVERSION= 4.1.2
+PORTREVISION= 1
CATEGORIES= finance python
MASTER_SITES= https://download.electrum.org/${PORTVERSION}/ \
http://download.electrum.org/${PORTVERSION}/
@@ -26,13 +27,13 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}aiohttp-socks>=0.3:net/py-aiohttp-socks@${PY
${PYTHON_PKGNAMEPREFIX}jsonrpclib-pelix>0:devel/py-jsonrpclib-pelix@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pbkdf2>=1.3:security/py-pbkdf2@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}protobuf>=3.12:devel/py-protobuf@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}QDarkStyle==2.8.1:textproc/py-QDarkStyle@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}QDarkStyle>=2.8.1:textproc/py-QDarkStyle@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}qrcode>0:textproc/py-qrcode@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}requests>=2.4.3:www/py-requests@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}secp256k1>0:math/py-secp256k1@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}sqlite3>=3.7.9:databases/py-sqlite3@${PY_FLAVOR}
-USES= python:3.7+ shebangfix
+USES= python:3.8+ shebangfix
USE_PYTHON= autoplist concurrent distutils
PYDISTUTILS_PKGNAME= Electrum