aboutsummaryrefslogtreecommitdiff
path: root/finance
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-06-14 17:32:33 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-06-14 17:32:33 +0000
commit5fe672cb886e85503f3c98db1f3bedaae7031d09 (patch)
tree0069da40f5e3d718edb72d98a964a9defbfb64ba /finance
parent9ff6a0ecc059e6a27b4a589795a77eb76469183d (diff)
downloadports-5fe672cb886e85503f3c98db1f3bedaae7031d09.tar.gz
ports-5fe672cb886e85503f3c98db1f3bedaae7031d09.zip
finance/py-yfinance: Add py-yfinance 0.1.59
Ever since Yahoo! finance decommissioned their historical data API, many programs that relied on it to stop working. yfinance aimes to solve this problem by offering a reliable, threaded, and Pythonic way to download historical market data from Yahoo! finance. WWW: https://github.com/ranaroussi/yfinance
Diffstat (limited to 'finance')
-rw-r--r--finance/Makefile1
-rw-r--r--finance/py-yfinance/Makefile26
-rw-r--r--finance/py-yfinance/distinfo3
-rw-r--r--finance/py-yfinance/pkg-descr6
4 files changed, 36 insertions, 0 deletions
diff --git a/finance/Makefile b/finance/Makefile
index 1e74de75b6fc..e1e690de2c2d 100644
--- a/finance/Makefile
+++ b/finance/Makefile
@@ -102,6 +102,7 @@
SUBDIR += py-stripe
SUBDIR += py-ta-lib
SUBDIR += py-vatnumber
+ SUBDIR += py-yfinance
SUBDIR += py-ystockquote
SUBDIR += qtbitcointrader
SUBDIR += quantlib
diff --git a/finance/py-yfinance/Makefile b/finance/py-yfinance/Makefile
new file mode 100644
index 000000000000..9336a90ec680
--- /dev/null
+++ b/finance/py-yfinance/Makefile
@@ -0,0 +1,26 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+
+PORTNAME= yfinance
+PORTVERSION= 0.1.59
+CATEGORIES= finance python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Yahoo! Finance market data downloader
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}lxml>=4.5.1:devel/py-lxml@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}multitasking>=0.0.7:devel/py-multitasking@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}numpy>=1.15,1:math/py-numpy@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pandas>=0.24,1:math/py-pandas@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}requests>=2.20:www/py-requests@${PY_FLAVOR}
+
+USES= python:3.6+
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/finance/py-yfinance/distinfo b/finance/py-yfinance/distinfo
new file mode 100644
index 000000000000..c51b5986c0d1
--- /dev/null
+++ b/finance/py-yfinance/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1622213968
+SHA256 (yfinance-0.1.59.tar.gz) = fe4dc46807eceadc6604bf51ece7297b752dc5402a38a87385094fbfc7565fa0
+SIZE (yfinance-0.1.59.tar.gz) = 25783
diff --git a/finance/py-yfinance/pkg-descr b/finance/py-yfinance/pkg-descr
new file mode 100644
index 000000000000..4295afb48ed7
--- /dev/null
+++ b/finance/py-yfinance/pkg-descr
@@ -0,0 +1,6 @@
+Ever since Yahoo! finance decommissioned their historical data API, many
+programs that relied on it to stop working. yfinance aimes to solve this problem
+by offering a reliable, threaded, and Pythonic way to download historical market
+data from Yahoo! finance.
+
+WWW: https://github.com/ranaroussi/yfinance