aboutsummaryrefslogtreecommitdiff
path: root/finance
diff options
context:
space:
mode:
authorGreg Larkin <glarkin@FreeBSD.org>2008-11-11 21:20:09 +0000
committerGreg Larkin <glarkin@FreeBSD.org>2008-11-11 21:20:09 +0000
commit13f2f46944cf3658725655b40b6ba09c4d0f36aa (patch)
tree2f7deef4607648e440cc2b85a46bda00ca9a1248 /finance
parent12ddb34ac66f02fb2a10347614ef4689d9371f9e (diff)
downloadports-13f2f46944cf3658725655b40b6ba09c4d0f36aa.tar.gz
ports-13f2f46944cf3658725655b40b6ba09c4d0f36aa.zip
Notes
Diffstat (limited to 'finance')
-rw-r--r--finance/kmymoney-kde4/Makefile32
-rw-r--r--finance/kmymoney-kde4/files/extra-patch-Makefile.in11
-rw-r--r--finance/kmymoney-kde4/files/extra-patch-doc__en__Makefile.in32
-rw-r--r--finance/kmymoney2/Makefile32
-rw-r--r--finance/kmymoney2/files/extra-patch-Makefile.in11
-rw-r--r--finance/kmymoney2/files/extra-patch-doc__en__Makefile.in32
6 files changed, 122 insertions, 28 deletions
diff --git a/finance/kmymoney-kde4/Makefile b/finance/kmymoney-kde4/Makefile
index 0d520ee004a8..731e3442a46a 100644
--- a/finance/kmymoney-kde4/Makefile
+++ b/finance/kmymoney-kde4/Makefile
@@ -7,7 +7,7 @@
PORTNAME= kmymoney2
PORTVERSION= 0.8.9
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= finance
MASTER_SITES= SF
@@ -19,18 +19,6 @@ BUILD_DEPENDS= bash:${PORTSDIR}/shells/bash
LIB_DEPENDS+= ofx.4:${PORTSDIR}/finance/libofx
-.if defined(NOPORTDOCS)
-CONFIGURE_ARGS= --enable-ofxplugin --enable-ofxbanking
-.else
-CONFIGURE_ARGS= --enable-ofxplugin --enable-ofxbanking --enable-pdf-docs
-
-# Add more build-time dependencies to generate the PDF docs
-BUILD_DEPENDS+= jade:${PORTSDIR}/textproc/jade \
- pdfjadetex:${PORTSDIR}/print/jadetex \
- html2ps:${PORTSDIR}/print/html2ps-letter \
- dsssl-docbook-modular>=0:${PORTSDIR}/textproc/dsssl-docbook-modular
-.endif
-
USE_KDELIBS_VER=3
USE_GMAKE= yes
GNU_CONFIGURE= yes
@@ -48,4 +36,20 @@ MANCOMPRESSED= yes
DATADIR= ${PREFIX}/share/apps/${PORTNAME}
DOCSDIR= ${PREFIX}/share/doc/HTML/en/${PORTNAME}
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if defined(NOPORTDOCS)
+CONFIGURE_ARGS= --enable-ofxplugin --enable-ofxbanking
+EXTRA_PATCHES= ${FILESDIR}/extra-patch-Makefile.in \
+ ${FILESDIR}/extra-patch-doc__en__Makefile.in
+.else
+CONFIGURE_ARGS= --enable-ofxplugin --enable-ofxbanking --enable-pdf-docs
+
+# Add more build-time dependencies to generate the PDF docs
+BUILD_DEPENDS+= jade:${PORTSDIR}/textproc/jade \
+ pdfjadetex:${PORTSDIR}/print/jadetex \
+ html2ps:${PORTSDIR}/print/html2ps-letter \
+ dsssl-docbook-modular>=0:${PORTSDIR}/textproc/dsssl-docbook-modular
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/finance/kmymoney-kde4/files/extra-patch-Makefile.in b/finance/kmymoney-kde4/files/extra-patch-Makefile.in
new file mode 100644
index 000000000000..2433428f2acc
--- /dev/null
+++ b/finance/kmymoney-kde4/files/extra-patch-Makefile.in
@@ -0,0 +1,11 @@
+--- ./Makefile.in.orig 2008-11-10 13:28:25.000000000 -0500
++++ ./Makefile.in 2008-11-10 13:28:33.000000000 -0500
+@@ -347,7 +347,7 @@
+ xdg_appsdir = @xdg_appsdir@
+ xdg_directorydir = @xdg_directorydir@
+ xdg_menudir = @xdg_menudir@
+-SUBDIRS = libkgpgfile kmymoney2 po doc developer-doc
++SUBDIRS = libkgpgfile kmymoney2 po doc
+
+ # The following line adds the required admin files
+ EXTRA_DIST = kmymoney2.kdevprj AUTHORS COPYING ChangeLog INSTALL \
diff --git a/finance/kmymoney-kde4/files/extra-patch-doc__en__Makefile.in b/finance/kmymoney-kde4/files/extra-patch-doc__en__Makefile.in
new file mode 100644
index 000000000000..03821e0d447a
--- /dev/null
+++ b/finance/kmymoney-kde4/files/extra-patch-doc__en__Makefile.in
@@ -0,0 +1,32 @@
+--- ./doc/en/Makefile.in.orig 2008-11-11 12:54:15.000000000 -0500
++++ ./doc/en/Makefile.in 2008-11-11 13:03:11.000000000 -0500
+@@ -340,9 +340,9 @@
+ qifimport-qifprofiledate.png qifimport-qifprofileeditor.png \
+ report_configuration-reporttab.png \
+ report_configuration-rowscolumns.png reports_view-all.png
+-EXTRA_DIST = kmymoney2.1 $(DOCBOOK_FILES)
++EXTRA_DIST = kmymoney2.1
+ MOSTLYCLEANFILES = index.cache.bz2 kmymoney2.1.gz index.xml *.aux *.tex *.log **.out *.pdf errorlog *.ps *.html online-manual.tar.bz2
+-BUILT_SOURCES = index.cache.bz2 kmymoney2.1.gz $(PDF_TARGET)
++BUILT_SOURCES = kmymoney2.1.gz
+ KDE_LANG = en
+ KDE_DOCS = kmymoney2 - $(DOCBOOK_FILES) $(SCREENSHOT_FILES)
+ @HAVE_DSSSLCONVERSIONTOOLS_FALSE@@HAVE_HTMLCONVERSIONTOOLS_TRUE@PDF_TARGET = kmymoney-user.pdf
+@@ -495,7 +495,7 @@
+
+ #>- install-data-am:
+ #>+ 1
+-install-data-am: install-nls
++install-data-am:
+ @$(NORMAL_INSTALL)
+ $(MAKE) $(AM_MAKEFLAGS) install-data-hook
+
+@@ -638,7 +638,7 @@
+ # Also install the man pages on this system
+ .PHONY: install-docs uninstall-docs
+
+-install-data-hook: kmymoney2.1.gz install-docs
++install-data-hook: kmymoney2.1.gz
+ -rm -f $(DESTDIR)$(kde_htmldir)/$(KDE_LANG)/kmymoney2/kmymoney2.1
+ $(mkinstalldirs) $(DESTDIR)$(mandir)/man1/
+ $(INSTALL_DATA) kmymoney2.1.gz $(DESTDIR)$(mandir)/man1/kmymoney2.1.gz
diff --git a/finance/kmymoney2/Makefile b/finance/kmymoney2/Makefile
index 0d520ee004a8..731e3442a46a 100644
--- a/finance/kmymoney2/Makefile
+++ b/finance/kmymoney2/Makefile
@@ -7,7 +7,7 @@
PORTNAME= kmymoney2
PORTVERSION= 0.8.9
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= finance
MASTER_SITES= SF
@@ -19,18 +19,6 @@ BUILD_DEPENDS= bash:${PORTSDIR}/shells/bash
LIB_DEPENDS+= ofx.4:${PORTSDIR}/finance/libofx
-.if defined(NOPORTDOCS)
-CONFIGURE_ARGS= --enable-ofxplugin --enable-ofxbanking
-.else
-CONFIGURE_ARGS= --enable-ofxplugin --enable-ofxbanking --enable-pdf-docs
-
-# Add more build-time dependencies to generate the PDF docs
-BUILD_DEPENDS+= jade:${PORTSDIR}/textproc/jade \
- pdfjadetex:${PORTSDIR}/print/jadetex \
- html2ps:${PORTSDIR}/print/html2ps-letter \
- dsssl-docbook-modular>=0:${PORTSDIR}/textproc/dsssl-docbook-modular
-.endif
-
USE_KDELIBS_VER=3
USE_GMAKE= yes
GNU_CONFIGURE= yes
@@ -48,4 +36,20 @@ MANCOMPRESSED= yes
DATADIR= ${PREFIX}/share/apps/${PORTNAME}
DOCSDIR= ${PREFIX}/share/doc/HTML/en/${PORTNAME}
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if defined(NOPORTDOCS)
+CONFIGURE_ARGS= --enable-ofxplugin --enable-ofxbanking
+EXTRA_PATCHES= ${FILESDIR}/extra-patch-Makefile.in \
+ ${FILESDIR}/extra-patch-doc__en__Makefile.in
+.else
+CONFIGURE_ARGS= --enable-ofxplugin --enable-ofxbanking --enable-pdf-docs
+
+# Add more build-time dependencies to generate the PDF docs
+BUILD_DEPENDS+= jade:${PORTSDIR}/textproc/jade \
+ pdfjadetex:${PORTSDIR}/print/jadetex \
+ html2ps:${PORTSDIR}/print/html2ps-letter \
+ dsssl-docbook-modular>=0:${PORTSDIR}/textproc/dsssl-docbook-modular
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/finance/kmymoney2/files/extra-patch-Makefile.in b/finance/kmymoney2/files/extra-patch-Makefile.in
new file mode 100644
index 000000000000..2433428f2acc
--- /dev/null
+++ b/finance/kmymoney2/files/extra-patch-Makefile.in
@@ -0,0 +1,11 @@
+--- ./Makefile.in.orig 2008-11-10 13:28:25.000000000 -0500
++++ ./Makefile.in 2008-11-10 13:28:33.000000000 -0500
+@@ -347,7 +347,7 @@
+ xdg_appsdir = @xdg_appsdir@
+ xdg_directorydir = @xdg_directorydir@
+ xdg_menudir = @xdg_menudir@
+-SUBDIRS = libkgpgfile kmymoney2 po doc developer-doc
++SUBDIRS = libkgpgfile kmymoney2 po doc
+
+ # The following line adds the required admin files
+ EXTRA_DIST = kmymoney2.kdevprj AUTHORS COPYING ChangeLog INSTALL \
diff --git a/finance/kmymoney2/files/extra-patch-doc__en__Makefile.in b/finance/kmymoney2/files/extra-patch-doc__en__Makefile.in
new file mode 100644
index 000000000000..03821e0d447a
--- /dev/null
+++ b/finance/kmymoney2/files/extra-patch-doc__en__Makefile.in
@@ -0,0 +1,32 @@
+--- ./doc/en/Makefile.in.orig 2008-11-11 12:54:15.000000000 -0500
++++ ./doc/en/Makefile.in 2008-11-11 13:03:11.000000000 -0500
+@@ -340,9 +340,9 @@
+ qifimport-qifprofiledate.png qifimport-qifprofileeditor.png \
+ report_configuration-reporttab.png \
+ report_configuration-rowscolumns.png reports_view-all.png
+-EXTRA_DIST = kmymoney2.1 $(DOCBOOK_FILES)
++EXTRA_DIST = kmymoney2.1
+ MOSTLYCLEANFILES = index.cache.bz2 kmymoney2.1.gz index.xml *.aux *.tex *.log **.out *.pdf errorlog *.ps *.html online-manual.tar.bz2
+-BUILT_SOURCES = index.cache.bz2 kmymoney2.1.gz $(PDF_TARGET)
++BUILT_SOURCES = kmymoney2.1.gz
+ KDE_LANG = en
+ KDE_DOCS = kmymoney2 - $(DOCBOOK_FILES) $(SCREENSHOT_FILES)
+ @HAVE_DSSSLCONVERSIONTOOLS_FALSE@@HAVE_HTMLCONVERSIONTOOLS_TRUE@PDF_TARGET = kmymoney-user.pdf
+@@ -495,7 +495,7 @@
+
+ #>- install-data-am:
+ #>+ 1
+-install-data-am: install-nls
++install-data-am:
+ @$(NORMAL_INSTALL)
+ $(MAKE) $(AM_MAKEFLAGS) install-data-hook
+
+@@ -638,7 +638,7 @@
+ # Also install the man pages on this system
+ .PHONY: install-docs uninstall-docs
+
+-install-data-hook: kmymoney2.1.gz install-docs
++install-data-hook: kmymoney2.1.gz
+ -rm -f $(DESTDIR)$(kde_htmldir)/$(KDE_LANG)/kmymoney2/kmymoney2.1
+ $(mkinstalldirs) $(DESTDIR)$(mandir)/man1/
+ $(INSTALL_DATA) kmymoney2.1.gz $(DESTDIR)$(mandir)/man1/kmymoney2.1.gz