aboutsummaryrefslogtreecommitdiff
path: root/french/aster/files
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2008-07-13 07:43:00 +0000
committerThierry Thomas <thierry@FreeBSD.org>2008-07-13 07:43:00 +0000
commit94f3a1983ead5efb5c3739e0e5095b5aa8ccf8ed (patch)
tree1203276e50113f6323dffaee185de0993f5122cf /french/aster/files
parentf96fc34dec104b95a96418e748db60030e77ca33 (diff)
Notes
Diffstat (limited to 'french/aster/files')
-rw-r--r--french/aster/files/patch-check_compilers.py34
-rw-r--r--french/aster/files/patch-products.py54
-rw-r--r--french/aster/files/patch-setup.cfg31
-rw-r--r--french/aster/files/patch-setup.py25
4 files changed, 102 insertions, 42 deletions
diff --git a/french/aster/files/patch-check_compilers.py b/french/aster/files/patch-check_compilers.py
new file mode 100644
index 000000000000..b2917d0314a3
--- /dev/null
+++ b/french/aster/files/patch-check_compilers.py
@@ -0,0 +1,34 @@
+--- check_compilers.py.orig 2008-07-03 18:50:57.000000000 +0200
++++ check_compilers.py 2008-07-08 00:01:13.000000000 +0200
+@@ -290,7 +290,7 @@
+ if self.platform == 'LINUX64':
+ self.F77 = 'gfortran'
+
+- self.libs.extend([('math', 'lapack'), ('math', 'blas'), ('math', 'g2c'),
++ self.libs.extend([('math', 'lapack'), ('math', 'blas'), ('math', 'f2c'),
+ ('cxx', ['libstdc++.so', 'libstdc++.a']),])
+
+ #-------------------------------------------------------------------------------
+@@ -332,7 +332,7 @@
+ if self.platform == 'LINUX64':
+ self.F77 = 'gfortran'
+
+- self.libs.extend([('math', 'g2c'),
++ self.libs.extend([('math', 'f2c'),
+ ('cxx', ['libstdc++.so', 'libstdc++.a']),])
+
+ #-------------------------------------------------------------------------------
+@@ -356,6 +356,13 @@
+ self.profiles.append('mklvars64.sh')
+ else: # x86_64
+ self.profiles.append('mklvarsem64t.sh')
++ elif self.platform == 'FREEBSD': # Not yet tested with icc!
++ if self.arch == 'ia64': # ia64
++ self.profiles.append('mklvars64.sh')
++ elif self.arch == 'x86_64': # x86_64
++ self.profiles.append('mklvarsem64t.sh')
++ else: # 32 bits
++ self.profiles.append('mklvars32.sh')
+ else:
+ raise CheckCompilerError, _('Unsupported platform : %s') % self.platform
+
diff --git a/french/aster/files/patch-products.py b/french/aster/files/patch-products.py
index bce46bd277ef..9fdf773aaea0 100644
--- a/french/aster/files/patch-products.py
+++ b/french/aster/files/patch-products.py
@@ -1,19 +1,18 @@
---- products.py.orig 2007-12-21 17:08:17.000000000 +0100
-+++ products.py 2008-01-08 14:20:12.000000000 +0100
-@@ -863,16 +863,18 @@
+--- products.py.orig 2008-07-03 18:50:57.000000000 +0200
++++ products.py 2008-07-10 21:13:03.000000000 +0200
+@@ -936,16 +936,18 @@
'HOME_PYTHON', 'PYTHON_EXE', 'PYTHONLIB', 'PYMODULES_PREFIX',
- 'HOME_MUMPS', 'HOME_ZMAT', 'HOME_MPI',
+ 'HOME_MUMPS', 'HOME_ZMAT', 'HOME_MPI', 'INCLUDE_MUMPS',
'HOME_MED', 'HOME_HDF', 'HOME_CRPCRS',
-- 'LD', 'CC', 'F77', 'F90',],
-+ 'LD', 'CC', 'F77', 'F90','LDFLAGS', 'SYSLIB',
+- 'LD', 'CC', 'F77', 'F90', 'CXXLIB', 'OTHERLIB',],
++ 'LD', 'CC', 'F77', 'F90', 'LDFLAGS', 'SYSLIB',
+ 'CFLAGS', 'CFLAGS_DBG',
+ 'FFLAGS', 'FFLAGS_DBG',
-+ 'F90FLAGS', 'F90FLAGS_DBG'],
++ 'F90FLAGS', 'F90FLAGS_DBG', 'CXXLIB', 'OTHERLIB',],
reqobj=['file:?HOME_ASTK?/ASTK_SERV/bin/as_run',
'file:?HOME_ASTK?/ASTK_SERV/conf/aster_profile.sh'],
-- set=['SYSLIB', 'OTHERLIB',
-+ set=['OTHERLIB',
- 'MEDLIB', 'HDFLIB', 'LAPACKLIB',
+ set=['SYSLIB',
+ 'MEDLIB', 'HDFLIB', 'LAPACKLIB', 'MATHLIB',
'MUMPSLIB', 'ZMATLIB', 'SCOTCHLIB',
- 'LDFLAGS',
- 'CFLAGS', 'CFLAGS_DBG', 'CINCLUDE',
@@ -25,12 +24,13 @@
'NOBUILD', ],
)
cfg['ENV_SH'] = cfg.get('ENV_SH', '')
-@@ -911,6 +913,18 @@
- cxxlibs.extend(['stdc++', 'supc++'])
+@@ -981,6 +983,19 @@
+ opt['FINCLUDE'] = ''
zmat_platform='Linux'
mpilibs.extend(['mpich'])
+ elif cfg['IFDEF']=='FREEBSD':
-+ opt['MATH_LIST'] = [cfg['LAPACKLIB'], cfg['BLASLIB'], 'gfortran']
++ # Don't check gfortran, already part of SYSLIB
++ opt['MATH_LIST'] = [cfg['LAPACKLIB'], cfg['BLASLIB']]
+ opt['SYSLIB'] = cfg['SYSLIB']
+ opt['LDFLAGS'] = cfg['LDFLAGS']
+ opt['CFLAGS_DBG'] = cfg['CFLAGS_DBG']
@@ -42,9 +42,9 @@
+ zmat_platform=''
+ mpilibs.extend(['mpich'])
elif cfg['IFDEF'] == 'LINUX64':
- opt['MATH_LIST'] = ['lapack', 'blas', 'g2c']
- opt['SYSLIB'] = '-Wl,--allow-multiple-definition -Wl,--export-dynamic -lieee -ldl -lpthread -lutil -lm'
-@@ -965,8 +979,8 @@
+ opt['SYSLIB'] = '-Wl,--allow-multiple-definition -Wl,--export-dynamic -lieee -ldl -lutil -lm'
+ opt['LDFLAGS'] = '-v'
+@@ -1033,8 +1048,8 @@
opt['FINCLUDE'] = ''
# ----- F90
@@ -55,15 +55,16 @@
opt['F90INCLUDE']=''
# ----- check for MED and HDF5 libraries, and HDF5 includes
-@@ -999,11 +1013,14 @@
-
+@@ -1071,12 +1086,15 @@
# ----- MUMPS
if cfg['HOME_MUMPS'] != '':
+ cfg['DEFINED'] += ' _HAVE_MUMPS'
- for lib in ('dmumps', 'zmumps', 'pord', 'mpiseq'):
- ftools.findlib_and_set(cfg, 'MUMPSLIB', lib,
- kargs['libdirs'], cfg['HOME_MUMPS'],
- err=False, append=True)
-- ftools.CheckFromLastFound(cfg, 'HOME_MUMPS', 'lib')
+- if lib == 'dmumps':
+- ftools.CheckFromLastFound(cfg, 'HOME_MUMPS', 'lib')
+ if cfg['MUMPSLIB'] != '':
+ opt['MUMPSLIB'] = cfg['MUMPSLIB']
+ else:
@@ -71,16 +72,17 @@
+ ftools.findlib_and_set(cfg, 'MUMPSLIB', lib,
+ kargs['libdirs'], cfg['HOME_MUMPS'],
+ err=False, append=True)
-+ ftools.CheckFromLastFound(cfg, 'HOME_MUMPS', 'lib')
++ if lib == 'dmumps':
++ ftools.CheckFromLastFound(cfg, 'HOME_MUMPS', 'lib')
opt['F90INCLUDE'] += ' -I%s' % os.path.join(cfg['ASTER_ROOT'],cfg['ASTER_VERSION'],'bibf90',cfg['INCLUDE_MUMPS'])
- else:
- opt['MUMPSLIB'] = ''
-@@ -1059,7 +1076,7 @@
- ftools.findlib_and_set(cfg, 'SCOTCHLIB', lib,
+ if cfg['HOME_MPI'] != '':
+ cfg['DEFINED'] += ' _USE_MPI_MUMPS'
+@@ -1132,7 +1150,7 @@
kargs['libdirs'], cfg['HOME_SCOTCH'],
err=True, append=True)
-- ftools.CheckFromLastFound(cfg, 'HOME_SCOTCH', 'bin')
-+ ftools.CheckFromLastFound(cfg, 'HOME_SCOTCH', 'lib')
+ if lib == 'common':
+- ftools.CheckFromLastFound(cfg, 'HOME_SCOTCH', 'bin')
++ ftools.CheckFromLastFound(cfg, 'HOME_SCOTCH', 'lib')
ftools.find_and_set(cfg, 'CINCLUDE', 'scotchf.h',
kargs['incdirs'], cfg['HOME_SCOTCH'],
typ='inc', err=True, append=True)
diff --git a/french/aster/files/patch-setup.cfg b/french/aster/files/patch-setup.cfg
index cfdc9fa7213b..d32fdc11ea2e 100644
--- a/french/aster/files/patch-setup.cfg
+++ b/french/aster/files/patch-setup.cfg
@@ -1,15 +1,24 @@
---- setup.cfg.orig 2007-12-21 17:08:17.000000000 +0100
-+++ setup.cfg 2008-01-08 14:30:05.000000000 +0100
-@@ -28,7 +28,7 @@
- # classical values for GNU compilers
- CC='/usr/bin/gcc'
- F77='/usr/bin/g77'
--LD=F77
-+LD='/usr/bin/gcc'
+--- setup.cfg.orig 2008-07-03 18:50:57.000000000 +0200
++++ setup.cfg 2008-07-06 23:13:45.000000000 +0200
+@@ -33,7 +33,7 @@
+ # If you choose XXXX_without_MATH you must name your mathematical
+ # libraries in MATH_LIST.
+ # Example : PREFER_COMPILER='Intel_without_MATH' and MATH_LIST = ['acml']
+-PREFER_COMPILER = 'Intel'
++PREFER_COMPILER = 'GNU'
+ # You may want to specify the values yourself by defining
+ # these variables : CC, F77, F90, CXX, LD, DEFINED,
+ # CFLAGS, FFLAGS, F90FLAGS, CXXFLAGS, LDFLAGS,
+@@ -97,7 +97,7 @@
+ MAXDEPTH=3 # 0: not recursive (this may be long with a high depth value)
- # not use by Code_Aster but by med for example...
- CXX='/usr/bin/g++'
-@@ -136,9 +136,9 @@
+ # To search for shared libraries first
+-PREFER_SHARED_LIBS=False # False/True
++PREFER_SHARED_LIBS=True # False/True
+
+ # Switch to False if you prefer use 32 bits libraries on 64 bits platforms
+ PREFER_64BITS_LIBS=True # False/True
+@@ -154,9 +154,9 @@
#-------------------------------------------------------------------------------
# Future packages : not yet used by Code_Aster !
diff --git a/french/aster/files/patch-setup.py b/french/aster/files/patch-setup.py
index 3990bea609c1..daf29201d422 100644
--- a/french/aster/files/patch-setup.py
+++ b/french/aster/files/patch-setup.py
@@ -1,15 +1,30 @@
---- setup.py.orig 2007-12-21 17:08:17.000000000 +0100
-+++ setup.py 2008-01-08 14:56:44.000000000 +0100
-@@ -286,6 +286,8 @@
- cfg['IFDEF'] = 'LINUX64'
+--- setup.py.orig 2008-07-03 18:50:57.000000000 +0200
++++ setup.py 2008-07-08 00:05:35.000000000 +0200
+@@ -296,6 +296,14 @@
+ cfg['ARCH'] = 'x86_64'
else:
cfg['IFDEF'] = 'LINUX'
+ elif sys.platform[:7] == 'freebsd':
+ cfg['IFDEF']='FREEBSD'
++ cfg['ARCH'] = 'x86'
++ if machine.endswith('64'):
++ if machine in ('x86_64', 'ia64'):
++ cfg['ARCH'] = machine
++ else: # force to x86_64
++ cfg['ARCH'] = 'x86_64'
elif sys.platform[:4] == 'osf1':
cfg['IFDEF']='TRU64'
elif sys.platform == 'sunos5':
-@@ -397,6 +399,7 @@
+@@ -406,7 +414,7 @@
+ if not type(math_lib) in (list, tuple):
+ math_lib = [math_lib,]
+ sys_lib = []
+- for glob_lib in ('pthread', 'g2c', 'z',):
++ for glob_lib in ('pthread', 'f2c', 'z',):
+ cfg['__tmp__'] = ''
+ del cfg['__tmp__']
+ ftools.findlib_and_set(cfg, '__tmp__', glob_lib, libdirs, [], prefshared=True,
+@@ -502,6 +510,7 @@
# and modify command line of those which don't have a --display= option
ListEdit=[
['nedit' , 'nedit',],