aboutsummaryrefslogtreecommitdiff
path: root/french/aster
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2006-09-24 12:36:11 +0000
committerThierry Thomas <thierry@FreeBSD.org>2006-09-24 12:36:11 +0000
commit622e7b61609046bc5171fcaed3b83f0c9e8fce7a (patch)
treef4b08e3e243165d0c0c4b71882e060715b6a93c7 /french/aster
parent9385619205a61824aca854084bab36c2714c9653 (diff)
downloadports-622e7b61609046bc5171fcaed3b83f0c9e8fce7a.tar.gz
ports-622e7b61609046bc5171fcaed3b83f0c9e8fce7a.zip
Notes
Diffstat (limited to 'french/aster')
-rw-r--r--french/aster/Makefile9
-rw-r--r--french/aster/files/patch-as_setup.py14
2 files changed, 16 insertions, 7 deletions
diff --git a/french/aster/Makefile b/french/aster/Makefile
index 510ab77d46c5..9e3984ee03bd 100644
--- a/french/aster/Makefile
+++ b/french/aster/Makefile
@@ -11,7 +11,7 @@ CATEGORIES= french cad python
MASTER_SITES= http://www.code-aster.org/FICHIERS/
DISTNAME= ${PORTNAME}-full-src-${DISTVERSION}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= thierry@FreeBSD.org
COMMENT= Code_Aster finite element method solver
#-----------------------------------------------------------------------
@@ -71,9 +71,7 @@ FLAGARCH= TRU64 # 64 bits
.endif
.if ${OSVERSION} < 500000
-IGNORE= Does not compile on FreeBSD-4.x, and cannot be patched easily.
-.else
-BROKEN= Does not install
+BROKEN= Does not compile on FreeBSD-4.x, and cannot be patched easily.
.endif
.if ${ARCH} == "amd64"
BROKEN= Seg. fault on ${ARCH} during compilation of elements.
@@ -83,9 +81,6 @@ BROKEN= Seg. fault on ${ARCH} during compilation of elements.
BROKEN= Does not build on sparc64
.endif
-DEPRECATED= Does not install
-EXPIRATION_DATE= 2006-11-24
-
.if exists(${LOCALBASE}/lib/libatlas_r.so) && !defined(WITH_BLAS)
WITH_ATLAS= yes
.endif
diff --git a/french/aster/files/patch-as_setup.py b/french/aster/files/patch-as_setup.py
new file mode 100644
index 000000000000..43e3a50eace2
--- /dev/null
+++ b/french/aster/files/patch-as_setup.py
@@ -0,0 +1,14 @@
+--- as_setup.py.orig Wed Jun 28 18:04:25 2006
++++ as_setup.py Sun Sep 24 12:23:18 2006
+@@ -1170,7 +1170,10 @@
+ from socket import gethostname, gethostbyaddr
+ if host==None:
+ host = gethostname()
+- fqn, alias, ip = gethostbyaddr(host)
++ try:
++ fqn, alias, ip = gethostbyaddr(host)
++ except:
++ fqn='put-your-host-name.here'
+ if fqn.find('localhost')>-1:
+ alias=[a for a in alias if a.find('localhost')<0]
+ if len(alias)>0: