aboutsummaryrefslogtreecommitdiff
path: root/french/med/Makefile
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2006-12-12 18:24:23 +0000
committerThierry Thomas <thierry@FreeBSD.org>2006-12-12 18:24:23 +0000
commit7bbc1fc7e64450159a5083403e7e494fb48eae4b (patch)
tree4126c3c1ed5ec0b75170c7403fb5019aecc4bbd4 /french/med/Makefile
parente5c6be44d9eb8c8bb9094282240e9b27fd671a3f (diff)
Notes
Diffstat (limited to 'french/med/Makefile')
-rw-r--r--french/med/Makefile17
1 files changed, 12 insertions, 5 deletions
diff --git a/french/med/Makefile b/french/med/Makefile
index b72ff7741369..28c1754766eb 100644
--- a/french/med/Makefile
+++ b/french/med/Makefile
@@ -6,11 +6,9 @@
#
PORTNAME= med
-PORTVERSION= 2.2.3
-PORTREVISION= 2
-CATEGORIES= french cad converters
+PORTVERSION= 2.3.1
+CATEGORIES= french science
MASTER_SITES= http://www.code-aster.org/FICHIERS/
-DISTNAME= ${PORTNAME}_fichier${PORTVERSION}.src
MAINTAINER= ports@FreeBSD.org
COMMENT= Modelisation et Echanges de Donnees
@@ -22,7 +20,6 @@ RUN_DEPENDS= wish${TK_VER}:${PORTSDIR}/x11-toolkits/tk${SHORT_TK_VER}
TK_VER?= 8.4
SHORT_TK_VER= ${TK_VER:S/.//}
-#CONFIGURE_ARGS= --disable-shared
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= HDF5HOME=${LOCALBASE} CPPFLAGS="${PTHREAD_CFLAGS}" \
LDFLAGS="${PTHREAD_LIBS}" WISH=${LOCALBASE}/bin/wish${TK_VER}
@@ -30,6 +27,12 @@ GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_LDCONFIG= yes
+.if !defined(WITHOUT_F90)
+F90= gfortran41
+BUILD_DEPENDS+= ${F90}:${PORTSDIR}/lang/gfortran
+CONFIGURE_ARGS+= --with-f90=${F90}
+.endif
+
DOC2FIX= . gif html jpg png tests
TST2FIX= c f
@@ -59,4 +62,8 @@ post-install:
@${ECHO_MSG} "===> Documentation installed in ${DOCSDIR}."
.endif
+regression-test:
+ @(cd ${BUILD_WRKSRC}; \
+ ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} check)
+
.include <bsd.port.post.mk>