aboutsummaryrefslogtreecommitdiff
path: root/french/med
diff options
context:
space:
mode:
authorOliver Lehmann <oliver@FreeBSD.org>2003-07-23 14:35:27 +0000
committerOliver Lehmann <oliver@FreeBSD.org>2003-07-23 14:35:27 +0000
commit98ad40ed215b7640f01a17188028db1b72f7720f (patch)
tree94b89830005c0c16cd784ad52c3c76add953da79 /french/med
parent7eedd70266711acd9f3de8d038eda656c58247ff (diff)
downloadports-98ad40ed215b7640f01a17188028db1b72f7720f.tar.gz
ports-98ad40ed215b7640f01a17188028db1b72f7720f.zip
Notes
Diffstat (limited to 'french/med')
-rw-r--r--french/med/Makefile46
-rw-r--r--french/med/distinfo1
-rw-r--r--french/med/files/patch-Makefile.in26
-rw-r--r--french/med/files/patch-config::commence.in19
-rw-r--r--french/med/files/patch-configure12
-rw-r--r--french/med/files/patch-include::med_outils.h11
-rw-r--r--french/med/files/patch-src::api::ci::MEDunvCr.c27
-rw-r--r--french/med/pkg-descr18
-rw-r--r--french/med/pkg-plist20
9 files changed, 180 insertions, 0 deletions
diff --git a/french/med/Makefile b/french/med/Makefile
new file mode 100644
index 000000000000..890abbf286c1
--- /dev/null
+++ b/french/med/Makefile
@@ -0,0 +1,46 @@
+# New ports collection makefile for: med
+# Date created: Thu Jun 26 2003
+# Whom: thierry@pompo.net
+#
+# $FreeBSD$
+#
+
+PORTNAME= med
+PORTVERSION= 2.1.5
+CATEGORIES= french cad converters
+MASTER_SITES= http://www.code-aster.org/FICHIERS/med/
+DISTNAME= ${PORTNAME}${PORTVERSION}_hdf5-1_src
+EXTRACT_SUFX= .tar
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Modélisation et Échanges de Données
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/libhdf5.a:${PORTSDIR}/graphics/hdf5
+
+EXTRACT_CMD= ${TAR}
+EXTRACT_BEFORE_ARGS= -xf
+EXTRACT_AFTER_ARGS= # empty
+CONFIGURE_ARGS= --prefix=${PREFIX} --disable-shared
+CONFIGURE_ENV= HDF5HOME=${LOCALBASE}
+USE_LIBTOOL= yes
+USE_GMAKE= yes
+USE_REINPLACE= yes
+
+WRKSRC= ${WRKDIR}/${PORTNAME}${PORTVERSION}.src
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|%%PTHREAD_LIBS%%|${PTHREAD_LIBS}|g' \
+ ${WRKSRC}/config/commence.in
+
+post-extract:
+ @(cd ${WRKDIR} && \
+ ${TAR} xfz ${WRKDIR}/${PORTNAME}${PORTVERSION}.src.tar.gz)
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @${CP} -R ${WRKSRC}/doc/html ${DOCSDIR}
+ @${ECHO_MSG} "===> Documentation installed in ${DOCSDIR}."
+.endif
+
+.include <bsd.port.mk>
diff --git a/french/med/distinfo b/french/med/distinfo
new file mode 100644
index 000000000000..ef9f028264c7
--- /dev/null
+++ b/french/med/distinfo
@@ -0,0 +1 @@
+MD5 (med2.1.5_hdf5-1_src.tar) = a19a5f481fbf48b1a2934517dfb717c5
diff --git a/french/med/files/patch-Makefile.in b/french/med/files/patch-Makefile.in
new file mode 100644
index 000000000000..440a5b8dcfb4
--- /dev/null
+++ b/french/med/files/patch-Makefile.in
@@ -0,0 +1,26 @@
+--- Makefile.in.orig Wed Nov 20 17:21:36 2002
++++ Makefile.in Fri Jun 27 23:01:55 2003
+@@ -8,7 +8,7 @@
+
+ @COMMENCE@
+
+-SUBDIRS=src tests tools doc
++SUBDIRS=src tools doc
+
+ lib:
+ @@SETX@; for d in $(SUBDIRS); do \
+@@ -30,12 +30,12 @@
+ (cd $$d && $(MAKE) $@) || exit 1; \
+ done
+
+-install: lib bin tests
++install: lib bin
+ @@SETX@; for d in $(SUBDIRS); do \
+ (cd $$d && $(MAKE) $@) || exit 1; \
+ done
+ @$(LT) --mode=finish $(libdir);
+- $(INSTALL_PROGRAM) $(top_builddir)/bin/xmdump $(bindir)/.
++ $(INSTALL_SCRIPT) $(top_builddir)/bin/xmdump $(bindir)/.
+ $(INSTALL_DATA) $(top_srcdir)/include/med.h $(includedir)/.
+ $(INSTALL_DATA) $(top_srcdir)/include/med.hf $(includedir)/.
+ $(INSTALL_DATA) $(top_srcdir)/include/med_proto.h $(includedir)/.
diff --git a/french/med/files/patch-config::commence.in b/french/med/files/patch-config::commence.in
new file mode 100644
index 000000000000..863a815218ee
--- /dev/null
+++ b/french/med/files/patch-config::commence.in
@@ -0,0 +1,19 @@
+--- config/commence.in.orig Wed Sep 18 18:09:44 2002
++++ config/commence.in Wed Jul 23 11:49:48 2003
+@@ -28,7 +28,7 @@
+ CFLAGS=@CFLAGS@
+ CPPFLAGS= -I$(top_srcdir)/include -I$(HDF5INC) -D$(MACHINE) @CPPFLAGS@
+ LIBS=@LIBS@
+-FLIBS=@FLIBS@
++FLIBS=%%PTHREAD_LIBS%% -lhdf5 @FLIBS@
+ LDFLAGS=@LDFLAGS@ $(LIBS)
+ AR=@AR@
+ RANLIB=@RANLIB@
+@@ -36,6 +36,7 @@
+ CP=cp
+ INSTALL=@INSTALL@
+ INSTALL_PROGRAM=@INSTALL_PROGRAM@
++INSTALL_SCRIPT=@INSTALL_SCRIPT@
+ INSTALL_DATA=@INSTALL_DATA@
+ RUNSERIAL=@RUNSERIAL@
+ RUNPARALLEL=@RUNPARALLEL@
diff --git a/french/med/files/patch-configure b/french/med/files/patch-configure
new file mode 100644
index 000000000000..f579070d0fb4
--- /dev/null
+++ b/french/med/files/patch-configure
@@ -0,0 +1,12 @@
+--- configure.orig Wed Sep 18 18:09:45 2002
++++ configure Wed Jul 9 21:19:27 2003
+@@ -667,6 +667,9 @@
+ linux*)
+ machine=PCLINUX
+ ;;
++ freebsd*)
++ machine=PCLINUX
++ ;;
+ hpux*)
+ machine=HP9000
+ ;;
diff --git a/french/med/files/patch-include::med_outils.h b/french/med/files/patch-include::med_outils.h
new file mode 100644
index 000000000000..813f0539d243
--- /dev/null
+++ b/french/med/files/patch-include::med_outils.h
@@ -0,0 +1,11 @@
+--- include/med_outils.h.orig Tue Dec 10 19:05:22 2002
++++ include/med_outils.h Wed Jul 23 11:37:29 2003
+@@ -111,7 +111,7 @@
+ #define MED_TAILLE_PROFILS 9
+
+ /*Pour eviter le bug solaris*/
+-#include <malloc.h>
++#include <stdlib.h>
+
+ /* Interface des routines du composant tools */
+ #include <med_misc.h>
diff --git a/french/med/files/patch-src::api::ci::MEDunvCr.c b/french/med/files/patch-src::api::ci::MEDunvCr.c
new file mode 100644
index 000000000000..1eef65ca7b67
--- /dev/null
+++ b/french/med/files/patch-src::api::ci::MEDunvCr.c
@@ -0,0 +1,27 @@
+--- src/api/ci/MEDunvCr.c.orig Tue Dec 10 16:48:14 2002
++++ src/api/ci/MEDunvCr.c Fri Jun 27 16:10:48 2003
+@@ -34,6 +34,12 @@
+ #include <sys/time.h>
+ #endif
+
++#ifdef __FreeBSD__
++#include <sys/types.h>
++#include <unistd.h>
++#include <pwd.h>
++#endif
++
+ med_err
+ MEDunvCr(med_idt fid, char *maa)
+ {
+@@ -78,7 +84,11 @@
+ nSize = strlen(nomu)-1;
+ if ( sprintf(&nomu[nSize]," %hu",tp.millitm) < 0 ) return -1;
+ #else
++# ifdef __FreeBSD__
++ if (getpwuid(geteuid()) == NULL) return -1;
++# else
+ if (cuserid(nomu) == (void*) NULL) return -1;
++# endif
+ strcat(nomu," ");
+ temps=time(&temps);
+ strcat(nomu,ctime(&temps));
diff --git a/french/med/pkg-descr b/french/med/pkg-descr
new file mode 100644
index 000000000000..695da4d9e279
--- /dev/null
+++ b/french/med/pkg-descr
@@ -0,0 +1,18 @@
+MED stands for "Modélisation et Échanges de Données", i.e. Data Modelization
+and Exchanges.
+
+MED « fichier », c'est :
+
+ * Un modèle d'échange de données commun centré sur les notions de
+ maillage et de résultat. Ce modèle décrit quelles sont les données
+ exportées et échangées entre les codes.
+
+ * Une API (Application Programming Interface) d'accès aux données
+ qui se présente sous la forme d'une bibliothèque informatique écrite
+ en C et FORTRAN 77. Cette bibliothèque est distribuée sous licence
+ GNU LGPL.
+
+ * Des données échangées et stockées dans des fichiers au format HDF
+ (Hierarchical Data Format).
+
+WWW: http://www.code-aster.org/outils/med/
diff --git a/french/med/pkg-plist b/french/med/pkg-plist
new file mode 100644
index 000000000000..1f24e759ec05
--- /dev/null
+++ b/french/med/pkg-plist
@@ -0,0 +1,20 @@
+bin/medconforme
+bin/mdump
+bin/xmdump
+include/med.h
+include/med.hf
+include/med_proto.h
+include/med_outils.h
+include/med_utils.h
+include/med_hdfi.h
+include/med_misc.h
+lib/libmed.a
+%%PORTDOCS%%%%DOCSDIR%%/html/menu.html
+%%PORTDOCS%%%%DOCSDIR%%/html/index.html
+%%PORTDOCS%%%%DOCSDIR%%/html/introduction.html
+%%PORTDOCS%%%%DOCSDIR%%/html/external_links.html
+%%PORTDOCS%%%%DOCSDIR%%/html/reference_guide.html
+%%PORTDOCS%%%%DOCSDIR%%/html/root.html
+%%PORTDOCS%%%%DOCSDIR%%/html/user_guide.html
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/html
+%%PORTDOCS%%@dirrm %%DOCSDIR%%