aboutsummaryrefslogtreecommitdiff
path: root/french/mythes
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-07-29 13:13:17 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-07-29 13:13:17 +0000
commit72c08ec487edbe98662f3278bee17f8726ee4ce4 (patch)
treea3c6d7d2a4a492c3e55a418f3fa370e951b5ccc7 /french/mythes
parenta600d4522cadfa512ce465f98566cee7b9bec843 (diff)
Notes
Diffstat (limited to 'french/mythes')
-rw-r--r--french/mythes/Makefile31
1 files changed, 15 insertions, 16 deletions
diff --git a/french/mythes/Makefile b/french/mythes/Makefile
index 297211e54e54..3101c5ed697e 100644
--- a/french/mythes/Makefile
+++ b/french/mythes/Makefile
@@ -7,6 +7,7 @@
PORTNAME= mythes
PORTVERSION= 2.2.2
+PORTREVISION= 1
CATEGORIES= french textproc
MASTER_SITES= http://www.dicollecte.org/download/fr/
DISTNAME= thesaurus-v${PORTVERSION}
@@ -18,27 +19,25 @@ LICENSE= LGPL21
USE_ZIP= yes
NO_BUILD= yes
+NO_WRKSUBDIR= yes
-FRALIASES= fr_BE fr_CA fr_CH fr_LU
-
-PLIST_FILES= share/mythes/th_fr_FR_v2.dat \
- share/mythes/th_fr_FR_v2.idx
+PLIST_FILES= %%DATADIR%%/th_fr_FR_v2.dat \
+ %%DATADIR%%/th_fr_FR_v2.idx
+PLIST_DIRSTRY= %%DATADIR%%
+FRALIASES= fr_BE fr_CA fr_CH fr_LU
.for ALIAS in ${FRALIASES}
-PLIST_FILES+= share/mythes/th_${ALIAS}_v2.dat \
- share/mythes/th_${ALIAS}_v2.idx
+PLIST_FILES+= %%DATADIR%%/th_${ALIAS}_v2.dat \
+ %%DATADIR%%/th_${ALIAS}_v2.idx
.endfor
-PLIST_DIRS= share/mythes
-
do-install:
- @${MKDIR} ${PREFIX}/share/mythes
- @${INSTALL_DATA} ${WRKDIR}/thes_fr.dat ${PREFIX}/share/mythes/th_fr_FR_v2.dat
- @${INSTALL_DATA} ${WRKDIR}/thes_fr.idx ${PREFIX}/share/mythes/th_fr_FR_v2.idx
- @cd ${PREFIX}/share/mythes; \
- for alias in ${FRALIASES}; do \
- ${LN} -s th_fr_FR_v2.idx th_$${alias}_v2.idx ; \
- ${LN} -s th_fr_FR_v2.dat th_$${alias}_v2.dat ; \
- done
+ ${MKDIR} ${DATADIR}/
+ ${INSTALL_DATA} ${WRKSRC}/thes_fr.dat ${DATADIR}/th_fr_FR_v2.dat
+ ${INSTALL_DATA} ${WRKSRC}/thes_fr.idx ${DATADIR}/th_fr_FR_v2.idx
+.for ALIAS in ${FRALIASES}
+ ${LN} -s th_fr_FR_v2.dat ${DATADIR}/th_${ALIAS}_v2.dat
+ ${LN} -s th_fr_FR_v2.idx ${DATADIR}/th_${ALIAS}_v2.idx
+.endfor
.include <bsd.port.mk>