aboutsummaryrefslogtreecommitdiff
path: root/french/verbiste/Makefile
diff options
context:
space:
mode:
authorJean-Yves Lefort <jylefort@FreeBSD.org>2005-11-29 18:40:51 +0000
committerJean-Yves Lefort <jylefort@FreeBSD.org>2005-11-29 18:40:51 +0000
commita6ecbdcfbdc93d32d7277c90cde11ec8483884d1 (patch)
tree88b271c0386c2fb893ebe970a2c87a332f4ff64d /french/verbiste/Makefile
parent0d5f060d265d95298a5113bf9d82e496d9c3b6ca (diff)
Notes
Diffstat (limited to 'french/verbiste/Makefile')
-rw-r--r--french/verbiste/Makefile46
1 files changed, 46 insertions, 0 deletions
diff --git a/french/verbiste/Makefile b/french/verbiste/Makefile
new file mode 100644
index 000000000000..00ff965a95c8
--- /dev/null
+++ b/french/verbiste/Makefile
@@ -0,0 +1,46 @@
+# New ports collection makefile for: verbiste
+# Date created: 16 November 2005
+# Whom: Dan Phillips <dan-ports@dp.id.au>
+#
+# $FreeBSD$
+#
+
+PORTNAME= verbiste
+PORTVERSION= 0.1.13
+CATEGORIES= french textproc
+MASTER_SITES= http://www3.sympatico.ca/sarrazip/dev/
+
+MAINTAINER= dan-ports@dp.id.au
+COMMENT?= French verb conjugator/deconjugator
+
+USE_GETTEXT= yes
+USE_GNOME+= gnomehack ltverhack libxml2
+USE_GMAKE= yes
+USE_AUTOTOOLS= libtool:15
+
+CPPFLAGS= -I${LOCALBASE}/include
+LDFLAGS= -L${LOCALBASE}/lib
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+
+.if !defined(PKGNAMEPREFIX)
+
+USE_GETOPT_LONG=yes
+USE_ICONV= yes
+INSTALLS_SHLIB= yes
+
+MAN1= french-conjugator.1 french-deconjugator.1
+MAN3= verbiste.3
+MANLANG= "" fr
+
+EXTRA_PATCHES= ${FILESDIR}/lib-patch-*
+
+post-install:
+ ${MKDIR} ${EXAMPLESDIR}
+.for f in README *.java *.c
+ ${INSTALL_DATA} ${WRKSRC}/examples/${f} ${EXAMPLESDIR}
+.endfor
+ ${INSTALL_SCRIPT} ${WRKSRC}/examples/*.pl ${EXAMPLESDIR}
+
+.endif
+
+.include <bsd.port.mk>