aboutsummaryrefslogtreecommitdiff
path: root/french/verbiste/Makefile
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-05-07 22:02:40 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-05-07 22:02:40 +0000
commit9b7561f6afe2d036f4a20da98396bd231c50dc1f (patch)
tree0de7d4558ff5ddcb45d7624421d8007cd2b94bd1 /french/verbiste/Makefile
parent08a99ad2cb74055f818559a41d342fe7ad46151c (diff)
downloadports-9b7561f6afe2d036f4a20da98396bd231c50dc1f.tar.gz
ports-9b7561f6afe2d036f4a20da98396bd231c50dc1f.zip
Notes
Diffstat (limited to 'french/verbiste/Makefile')
-rw-r--r--french/verbiste/Makefile21
1 files changed, 9 insertions, 12 deletions
diff --git a/french/verbiste/Makefile b/french/verbiste/Makefile
index 7b827ece28a1..309f6e0c23c1 100644
--- a/french/verbiste/Makefile
+++ b/french/verbiste/Makefile
@@ -3,7 +3,7 @@
PORTNAME= verbiste
PORTVERSION= 0.1.33
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= french textproc
MASTER_SITES= http://perso.b2b2c.ca/sarrazip/dev/
@@ -14,19 +14,16 @@ OPTIONS_DEFINE= GTK2 GNOME
LICENSE= GPLv2
-USES= pathfix pkgconfig iconv
-USE_AUTOTOOLS= libtool
-USE_GNOME= ltverhack libxml2
+USES= pathfix pkgconfig iconv libtool shebangfix
+SHEBANG_FILES= ${WRKSRC}/examples/*.pl
+GNU_CONFIGURE= yes
+USE_GNOME= libxml2
USE_LDCONFIG= yes
+INSTALL_TARGET= install-strip
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-MAN1= french-conjugator.1 french-deconjugator.1
-MAN3= verbiste.3
-MANLANG= "" fr
-
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MGTK2}
@@ -53,10 +50,10 @@ PLIST_SUB+= HASGUI="@comment "
.endif
post-install:
- ${MKDIR} ${EXAMPLESDIR}
+ ${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
.for f in README *.java *.c
- ${INSTALL_DATA} ${WRKSRC}/examples/${f} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/examples/${f} ${STAGEDIR}${EXAMPLESDIR}
.endfor
- ${INSTALL_SCRIPT} ${WRKSRC}/examples/*.pl ${EXAMPLESDIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/examples/*.pl ${STAGEDIR}${EXAMPLESDIR}
.include <bsd.port.mk>