aboutsummaryrefslogtreecommitdiff
path: root/french
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2016-04-01 14:00:51 +0000
committerMathieu Arnold <mat@FreeBSD.org>2016-04-01 14:00:51 +0000
commit4e1b79a0a61f4973df8b4b0864d22086c769e219 (patch)
tree78ceaf1b099c56a40c240ab46278cdf4ae9e7c01 /french
parent7f4572eae4327c4403d9ef714cb6de917650662a (diff)
Remove ${PORTSDIR}/ from dependencies, categories d, e, f, and g.
With hat: portmgr Sponsored by: Absolight
Notes
Notes: svn path=/head/; revision=412346
Diffstat (limited to 'french')
-rw-r--r--french/aster/Makefile48
-rw-r--r--french/eficas/Makefile10
-rw-r--r--french/geonext/Makefile2
-rw-r--r--french/homard/Makefile4
-rw-r--r--french/med/Makefile2
-rw-r--r--french/trytond28_account_fr/Makefile2
-rw-r--r--french/tvdownloader/Makefile10
7 files changed, 39 insertions, 39 deletions
diff --git a/french/aster/Makefile b/french/aster/Makefile
index f39a1370601c..bc600ba17bb9 100644
--- a/french/aster/Makefile
+++ b/french/aster/Makefile
@@ -31,18 +31,18 @@ LICENSE= GPLv2
#
#-----------------------------------------------------------------------
-BUILD_DEPENDS+= astk-serveur>0:${PORTSDIR}/cad/astk-serveur \
- ${SHELL_INSTALL_ASTER}:${PORTSDIR}/shells/${SHIADEP} \
- ${LOCALBASE}/lib/libscotch.a:${PORTSDIR}/cad/scotch \
- python:${PORTSDIR}/lang/python \
+BUILD_DEPENDS+= astk-serveur>0:cad/astk-serveur \
+ ${SHELL_INSTALL_ASTER}:shells/${SHIADEP} \
+ ${LOCALBASE}/lib/libscotch.a:cad/scotch \
+ python:lang/python \
${PYNUMPY}
-LIB_DEPENDS+= libhdf5.so:${PORTSDIR}/science/hdf5 \
- libmed.so:${PORTSDIR}/french/med \
- libmetis.so.0:${PORTSDIR}/math/metis-edf
-RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}gnuplot>0:${PORTSDIR}/math/py-gnuplot \
- ${LOCALBASE}/bin/onmetis:${PORTSDIR}/math/metis-edf \
- ${SHELL_INSTALL_ASTER}:${PORTSDIR}/shells/${SHIADEP} \
- astk-serveur>0:${PORTSDIR}/cad/astk-serveur
+LIB_DEPENDS+= libhdf5.so:science/hdf5 \
+ libmed.so:french/med \
+ libmetis.so.0:math/metis-edf
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}gnuplot>0:math/py-gnuplot \
+ ${LOCALBASE}/bin/onmetis:math/metis-edf \
+ ${SHELL_INSTALL_ASTER}:shells/${SHIADEP} \
+ astk-serveur>0:cad/astk-serveur
USES= bison fortran tk python:2
USE_BINUTILS= yes
@@ -81,25 +81,25 @@ FLAGARCH= -DLINUX64
.endif
.if !defined(WITHOUT_ASTK_CLI)
-RUN_DEPENDS+= astk-client>0:${PORTSDIR}/cad/astk-client
+RUN_DEPENDS+= astk-client>0:cad/astk-client
PLIST_SUB+= ASTK_CLIENT="" ASTKDIR=${ASTKDIR}
.else
PLIST_SUB+= ASTK_CLIENT="@comment " ASTKDIR=""
.endif
.if !defined(WITHOUT_EFICAS)
-RUN_DEPENDS+= fr-eficas>0:${PORTSDIR}/french/eficas
+RUN_DEPENDS+= fr-eficas>0:french/eficas
PLIST_SUB+= EFICAS=""
.else
PLIST_SUB+= EFICAS="@comment "
.endif
.if !defined(WITHOUT_GMSH)
-RUN_DEPENDS+= ${LOCALBASE}/bin/gmsh:${PORTSDIR}/cad/gmsh
+RUN_DEPENDS+= ${LOCALBASE}/bin/gmsh:cad/gmsh
PLIST_SUB+= GMSH=""
.else
PLIST_SUB+= GMSH="@comment "
.endif
.if !defined(WITHOUT_GRACE)
-RUN_DEPENDS+= xmgrace:${PORTSDIR}/math/grace
+RUN_DEPENDS+= xmgrace:math/grace
PLIST_SUB+= GRACE=""
.else
PLIST_SUB+= GRACE="@comment "
@@ -111,15 +111,15 @@ RUN_DEPENDS+= ${PYNUMPY}
.if !defined(WITH_MPI)
MUMPS_PORT= mumps
.else
-BUILD_DEPENDS+= ${LOCALBASE}/lib/libblacs.a:${PORTSDIR}/math/blacs \
- ${LOCALBASE}/lib/libscalapack.a:${PORTSDIR}/math/scalapack
+BUILD_DEPENDS+= ${LOCALBASE}/lib/libblacs.a:math/blacs \
+ ${LOCALBASE}/lib/libscalapack.a:math/scalapack
MUMPS_PORT= mumps-mpich
MUMPSLIB= -L${LOCALBASE}/lib -ldmumps -lzmumps -lmumps_common -lpord -lscalapack -lblacs -lblacsc -lblacs -L${LOCALBASE}/lib -lmpich -lmpl
.endif
-BUILD_DEPENDS+= ${LOCALBASE}/lib/libcmumps.a:${PORTSDIR}/math/${MUMPS_PORT}
+BUILD_DEPENDS+= ${LOCALBASE}/lib/libcmumps.a:math/${MUMPS_PORT}
.if defined(WITH_MPI)
-LIB_DEPENDS+= libmpich.so:${PORTSDIR}/net/mpich2
+LIB_DEPENDS+= libmpich.so:net/mpich2
HOME_MPI= ${LOCALBASE}
.endif
@@ -143,19 +143,19 @@ SHIADEP= ${SHIA}
.if !defined(WITH_ED)
. if exists(${LOCALBASE}/bin/nedit)
WITH_ED= nedit
-RUN_DEPENDS+= ${LOCALBASE}/bin/nedit:${PORTSDIR}/editors/nedit
+RUN_DEPENDS+= ${LOCALBASE}/bin/nedit:editors/nedit
. elif exists(${LOCALBASE}/bin/gvim)
WITH_ED= gvim
-RUN_DEPENDS+= ${LOCALBASE}/bin/gvim:${PORTSDIR}/editors/vim
+RUN_DEPENDS+= ${LOCALBASE}/bin/gvim:editors/vim
. elif exists(${LOCALBASE}/bin/emacs)
WITH_ED= emacs
-RUN_DEPENDS+= ${LOCALBASE}/bin/emacs:${PORTSDIR}/editors/emacs
+RUN_DEPENDS+= ${LOCALBASE}/bin/emacs:editors/emacs
. elif exists(${LOCALBASE}/bin/gedit)
WITH_ED= gedit
-RUN_DEPENDS+= ${LOCALBASE}/bin/gedit:${PORTSDIR}/editors/gedit
+RUN_DEPENDS+= ${LOCALBASE}/bin/gedit:editors/gedit
. elif exists(${LOCALBASE}/bin/xedit)
WITH_ED= xedit
-RUN_DEPENDS+= ${LOCALBASE}/bin/xedit:${PORTSDIR}/x11/xedit
+RUN_DEPENDS+= ${LOCALBASE}/bin/xedit:x11/xedit
. else
WITH_ED= vi
. endif
diff --git a/french/eficas/Makefile b/french/eficas/Makefile
index c788430b260c..9bb2ab06c510 100644
--- a/french/eficas/Makefile
+++ b/french/eficas/Makefile
@@ -10,9 +10,9 @@ COMMENT= ASter Command FIle Editor
LICENSE= GPLv2
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}Pmw>0:${PORTSDIR}/x11-toolkits/py-Pmw \
- ${PYTHON_PKGNAMEPREFIX}mx-base>0:${PORTSDIR}/lang/py-mx-base \
- bash:${PORTSDIR}/shells/bash \
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}Pmw>0:x11-toolkits/py-Pmw \
+ ${PYTHON_PKGNAMEPREFIX}mx-base>0:lang/py-mx-base \
+ bash:shells/bash \
${PYNUMPY}
USES= shebangfix python
@@ -34,8 +34,8 @@ EF_LANG= fr
EF_LANG= ang
.endif
-RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/PyQt4/QtGui.so:${PORTSDIR}/x11-toolkits/py-qt4-gui \
- xdg-open:${PORTSDIR}/devel/xdg-utils
+RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/PyQt4/QtGui.so:x11-toolkits/py-qt4-gui \
+ xdg-open:devel/xdg-utils
FIXUBIN= Openturns_Study/prefs_OPENTURNS_STUDY.py \
Openturns_Wrapper/prefs_OPENTURNS_WRAPPER.py \
diff --git a/french/geonext/Makefile b/french/geonext/Makefile
index 7ce62bd82827..512a3bdb2df4 100644
--- a/french/geonext/Makefile
+++ b/french/geonext/Makefile
@@ -6,7 +6,7 @@ CATEGORIES= french
MAINTAINER= ports@FreeBSD.org
COMMENT= Interactive (dynamic) elementary Geometry Software
-RUN_DEPENDS= geonext>=0:${PORTSDIR}/math/geonext
+RUN_DEPENDS= geonext>=0:math/geonext
WITH_LANG= fr
MASTERDIR= ${.CURDIR}/../../math/geonext
diff --git a/french/homard/Makefile b/french/homard/Makefile
index 24195858c4c5..9ff64b3fa6cf 100644
--- a/french/homard/Makefile
+++ b/french/homard/Makefile
@@ -8,8 +8,8 @@ CATEGORIES= french cad linux
MAINTAINER= thierry@FreeBSD.org
COMMENT= Refinement and de-refinement mesh tool
-BUILD_DEPENDS= ${LOCALBASE}/aster/${VER}/bin/aster:${PORTSDIR}/french/aster
-RUN_DEPENDS= ${LOCALBASE}/aster/${VER}/bin/aster:${PORTSDIR}/french/aster
+BUILD_DEPENDS= ${LOCALBASE}/aster/${VER}/bin/aster:french/aster
+RUN_DEPENDS= ${LOCALBASE}/aster/${VER}/bin/aster:french/aster
RESTRICTED= The free downloading of HOMARD software is only allowed for coupling\
with Code_Aster. For any other use, a license agreement is requested.\
diff --git a/french/med/Makefile b/french/med/Makefile
index e3bcd99760cb..0dcf08841eb2 100644
--- a/french/med/Makefile
+++ b/french/med/Makefile
@@ -11,7 +11,7 @@ COMMENT= Modelisation et Echanges de Donnees
LICENSE= GPLv3
-LIB_DEPENDS= libhdf5.so:${PORTSDIR}/science/hdf5
+LIB_DEPENDS= libhdf5.so:science/hdf5
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
diff --git a/french/trytond28_account_fr/Makefile b/french/trytond28_account_fr/Makefile
index 4f0bf4199f16..0713f3701a2e 100644
--- a/french/trytond28_account_fr/Makefile
+++ b/french/trytond28_account_fr/Makefile
@@ -14,7 +14,7 @@ COMMENT= Tryton Application Platform (French Account Chart)
LICENSE= GPLv3
-RUN_DEPENDS= trytond28_account>=2.8.1:${PORTSDIR}/finance/trytond28_account
+RUN_DEPENDS= trytond28_account>=2.8.1:finance/trytond28_account
CONFLICTS= trytond_account_fr-2.[46].*
diff --git a/french/tvdownloader/Makefile b/french/tvdownloader/Makefile
index d8a64d6a057e..57893a64ab7d 100644
--- a/french/tvdownloader/Makefile
+++ b/french/tvdownloader/Makefile
@@ -12,11 +12,11 @@ COMMENT= Download podcasts and videos from French websites
LICENSE= GPLv2
-RUN_DEPENDS= msdl:${PORTSDIR}/multimedia/msdl \
- rtmpdump:${PORTSDIR}/multimedia/rtmpdump \
- ${PYTHON_SITELIBDIR}/PyQt4/QtGui.so:${PORTSDIR}/x11-toolkits/py-qt4-gui \
- ${PYTHON_SITELIBDIR}/Crypto/__init__.py:${PORTSDIR}/security/py-pycrypto\
- ${PYTHON_SITELIBDIR}/mechanize/_mechanize.py:${PORTSDIR}/www/py-mechanize
+RUN_DEPENDS= msdl:multimedia/msdl \
+ rtmpdump:multimedia/rtmpdump \
+ ${PYTHON_SITELIBDIR}/PyQt4/QtGui.so:x11-toolkits/py-qt4-gui \
+ ${PYTHON_SITELIBDIR}/Crypto/__init__.py:security/py-pycrypto\
+ ${PYTHON_SITELIBDIR}/mechanize/_mechanize.py:www/py-mechanize
DEPRECATED= Many channels have modified their protocols and cannot be DL anymore
EXPIRATION_DATE= 2016-04-14