aboutsummaryrefslogtreecommitdiff
path: root/french
diff options
context:
space:
mode:
authorClement Laforet <clement@FreeBSD.org>2004-04-06 08:51:40 +0000
committerClement Laforet <clement@FreeBSD.org>2004-04-06 08:51:40 +0000
commit7c97f84ff5c50561b78c59b1bafea9cdd9eabbbd (patch)
tree4d66db535e5c580e29e86308147a269e4b03eef0 /french
parentfb36db76e6d31ae1d577efdb11b44357278c08ae (diff)
downloadports-7c97f84ff5c50561b78c59b1bafea9cdd9eabbbd.tar.gz
ports-7c97f84ff5c50561b78c59b1bafea9cdd9eabbbd.zip
Notes
Diffstat (limited to 'french')
-rw-r--r--french/gfaim/Makefile6
-rw-r--r--french/gfaim/files/patch-Makefile23
2 files changed, 17 insertions, 12 deletions
diff --git a/french/gfaim/Makefile b/french/gfaim/Makefile
index 05f5b1d70599..55161b070a34 100644
--- a/french/gfaim/Makefile
+++ b/french/gfaim/Makefile
@@ -25,8 +25,8 @@ PLIST_FILES= bin/gfaim bin/imprec lib/gfaim/cuisine.dat \
lib/gfaim/cuisine.idx
PLIST_DIRS= lib/gfaim
PORTDOCS= legal.txt lisezmoi.txt
-
-post-install:
- ${STRIP_CMD} ${PREFIX}/bin/gfaim
+.if defined(NOPORTDOCS)
+MAKE_ENV+= NOPORTDOCS=yes
+.endif
.include <bsd.port.mk>
diff --git a/french/gfaim/files/patch-Makefile b/french/gfaim/files/patch-Makefile
index 20d22cb4cfef..1dd19474cf1d 100644
--- a/french/gfaim/files/patch-Makefile
+++ b/french/gfaim/files/patch-Makefile
@@ -1,13 +1,16 @@
---- Makefile.orig Tue Nov 21 03:35:22 2000
-+++ Makefile Fri Jan 17 03:26:00 2003
-@@ -1,18 +1,15 @@
+--- Makefile.orig Tue Nov 21 11:35:22 2000
++++ Makefile Tue Apr 6 08:48:34 2004
+@@ -1,18 +1,19 @@
-CC=gcc
-DATADIR=/usr/lib/gfaim
-gfaim: gfaim.c
- $(CC) -DDATADIR="\"$(DATADIR)\"" `gtk-config --cflags` gfaim.c -o gfaim `gtk-config --libs`
++CFLGS= ${CFLAGS} `${GTK_CONFIG} --cflags`
++LIBS= `${GTK_CONFIG} --libs` ${LDFLAGS}
++
+all: gfaim.c
-+ $(CC) -DDATADIR="\"$(DATADIR)\"" `gtk12-config --cflags` gfaim.c -o gfaim `gtk12-config --libs`
++ $(CC) -DDATADIR="\"$(DATADIR)\"" ${CFLGS} gfaim.c -o gfaim ${LIBS}
clean:
rm -f *.o gfaim
@@ -20,10 +23,12 @@
- install *.txt /usr/doc/gfaim
-
-
-+ install -g bin -m 755 gfaim $(PREFIX)/bin
-+ install -g bin -m 755 imprec $(PREFIX)/bin
+-
++ ${BSD_INSTALL_PROGRAM} gfaim $(PREFIX)/bin
++ ${BSD_INSTALL_SCRIPT} imprec $(PREFIX)/bin
+ install -d $(PREFIX)/lib/gfaim
-+ install -m 644 *.dat *.idx $(PREFIX)/lib/gfaim
++ ${BSD_INSTALL_DATA} *.dat *.idx $(PREFIX)/lib/gfaim
++.if !defined(NOPORTDOCS)
+ install -d $(PREFIX)/share/doc/gfaim
-+ install *.txt $(PREFIX)/share/doc/gfaim
-
++ ${BSD_INSTALL_DATA} *.txt $(PREFIX)/share/doc/gfaim
++.endif