aboutsummaryrefslogtreecommitdiff
path: root/ftp/atftp
diff options
context:
space:
mode:
authorKevin Lo <kevlo@FreeBSD.org>2013-10-30 05:45:42 +0000
committerKevin Lo <kevlo@FreeBSD.org>2013-10-30 05:45:42 +0000
commit47d2fb89b9a63e86b1a736470f50916b0b8b573c (patch)
treeee1129b761561ba0ce73ce42550170de75a0f445 /ftp/atftp
parentc0ec00a06c62dd28a4aab29c212b6c8ba31d0d3e (diff)
downloadports-47d2fb89b9a63e86b1a736470f50916b0b8b573c.tar.gz
ports-47d2fb89b9a63e86b1a736470f50916b0b8b573c.zip
Notes
Diffstat (limited to 'ftp/atftp')
-rw-r--r--ftp/atftp/Makefile7
-rw-r--r--ftp/atftp/files/patch-tftp_def.c20
-rw-r--r--ftp/atftp/files/patch-tftp_def.h4
-rw-r--r--ftp/atftp/files/patch-tftpd.h4
-rw-r--r--ftp/atftp/files/patch-tftpd_list.c13
5 files changed, 32 insertions, 16 deletions
diff --git a/ftp/atftp/Makefile b/ftp/atftp/Makefile
index ab1123610320..d2a058274d6c 100644
--- a/ftp/atftp/Makefile
+++ b/ftp/atftp/Makefile
@@ -16,11 +16,6 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}.dfsg
USE_RC_SUBR= atftpd
GNU_CONFIGURE= yes
-PLIST_FILES= bin/atftp \
- sbin/atftpd
+PLIST_FILES= bin/atftp sbin/atftpd man/man1/atftp.1.gz man/man8/atftpd.8.gz
-MAN1= atftp.1
-MAN8= atftpd.8
-
-NO_STAGE= yes
.include <bsd.port.mk>
diff --git a/ftp/atftp/files/patch-tftp_def.c b/ftp/atftp/files/patch-tftp_def.c
index f1e0eb61379d..3f10760dd94d 100644
--- a/ftp/atftp/files/patch-tftp_def.c
+++ b/ftp/atftp/files/patch-tftp_def.c
@@ -1,8 +1,20 @@
---- tftp_def.c.orig 2010-10-11 11:20:48.000000000 +0800
-+++ tftp_def.c 2010-10-11 11:20:40.000000000 +0800
-@@ -140,11 +140,14 @@
+--- tftp_def.c.orig 2004-02-13 11:16:09.000000000 +0800
++++ tftp_def.c 2013-10-30 13:34:05.000000000 +0800
+@@ -88,7 +88,7 @@
+ res->tv_usec -= 1000000;
+ return -1;
+ }
+- else if (res->tv_usec <= 0);
++ else
+ {
+ return -1;
+ }
+@@ -138,13 +138,16 @@
+ /*
+ * This is a strncpy function that take care of string NULL termination
*/
- inline char *Strncpy(char *to, const char *from, size_t size)
+-inline char *Strncpy(char *to, const char *from, size_t size)
++char *Strncpy(char *to, const char *from, size_t size)
{
- to[size-1] = '\000';
- return strncpy(to, from, size - 1);
diff --git a/ftp/atftp/files/patch-tftp_def.h b/ftp/atftp/files/patch-tftp_def.h
index 9e15a047673f..c6165b089afe 100644
--- a/ftp/atftp/files/patch-tftp_def.h
+++ b/ftp/atftp/files/patch-tftp_def.h
@@ -1,5 +1,5 @@
--- tftp_def.h.orig 2004-02-13 11:16:09.000000000 +0800
-+++ tftp_def.h 2012-11-21 13:21:56.000000000 +0800
++++ tftp_def.h 2013-10-30 13:23:22.000000000 +0800
@@ -19,6 +19,7 @@
#include <sys/time.h>
@@ -13,7 +13,7 @@
int timeval_diff(struct timeval *res, struct timeval *t1, struct timeval *t0);
int print_eng(double value, char *string, int size, char *format);
-inline char *Strncpy(char *to, const char *from, size_t size);
-+extern inline char *Strncpy(char *to, const char *from, size_t size);
++char *Strncpy(char *to, const char *from, size_t size);
int Gethostbyname(char *addr, struct hostent *host);
#endif
diff --git a/ftp/atftp/files/patch-tftpd.h b/ftp/atftp/files/patch-tftpd.h
index 5e2789a1dc33..214a7d43fc49 100644
--- a/ftp/atftp/files/patch-tftpd.h
+++ b/ftp/atftp/files/patch-tftpd.h
@@ -1,5 +1,5 @@
--- tftpd.h.orig 2004-02-27 10:05:26.000000000 +0800
-+++ tftpd.h 2012-11-21 13:07:15.000000000 +0800
++++ tftpd.h 2013-10-30 13:25:35.000000000 +0800
@@ -71,6 +71,11 @@
struct client_info {
struct sockaddr_in client;
@@ -17,7 +17,7 @@
* Defined in tftpd_list.c, operation on client structure list.
*/
-inline void tftpd_clientlist_ready(struct thread_data *thread);
-+extern inline void tftpd_clientlist_ready(struct thread_data *thread);
++void tftpd_clientlist_ready(struct thread_data *thread);
void tftpd_clientlist_remove(struct thread_data *thread,
struct client_info *client);
void tftpd_clientlist_free(struct thread_data *thread);
diff --git a/ftp/atftp/files/patch-tftpd_list.c b/ftp/atftp/files/patch-tftpd_list.c
index 42ffd38fe0c5..aa729f8b8407 100644
--- a/ftp/atftp/files/patch-tftpd_list.c
+++ b/ftp/atftp/files/patch-tftpd_list.c
@@ -1,5 +1,5 @@
---- tftpd_list.c.orig 2010-10-11 12:44:39.000000000 +0800
-+++ tftpd_list.c 2010-10-11 12:44:34.000000000 +0800
+--- tftpd_list.c.orig 2004-02-27 10:05:26.000000000 +0800
++++ tftpd_list.c 2013-10-30 13:25:57.000000000 +0800
@@ -137,23 +137,17 @@
struct thread_data *data,
struct client_info *client)
@@ -40,3 +40,12 @@
{
*thread = current;
/* insert the new client at the end. If the client is already
+@@ -202,7 +196,7 @@
+ return 0;
+ }
+
+-inline void tftpd_clientlist_ready(struct thread_data *thread)
++void tftpd_clientlist_ready(struct thread_data *thread)
+ {
+ pthread_mutex_lock(&thread->client_mutex);
+ thread->client_ready = 1;