aboutsummaryrefslogtreecommitdiff
path: root/ftp/axel/Makefile
diff options
context:
space:
mode:
authorXin LI <delphij@FreeBSD.org>2008-04-16 03:24:59 +0000
committerXin LI <delphij@FreeBSD.org>2008-04-16 03:24:59 +0000
commit1bbe062d731c5684c2d65f84e9b1fa88128ed939 (patch)
treeba01c752bd53558479b6878abe47bc4ad118a251 /ftp/axel/Makefile
parent58865651043455c0d013e700e48f1b6f23e10dea (diff)
Notes
Diffstat (limited to 'ftp/axel/Makefile')
-rw-r--r--ftp/axel/Makefile29
1 files changed, 24 insertions, 5 deletions
diff --git a/ftp/axel/Makefile b/ftp/axel/Makefile
index 6cbc7a7460b8..ae31bf716289 100644
--- a/ftp/axel/Makefile
+++ b/ftp/axel/Makefile
@@ -7,23 +7,42 @@
#
PORTNAME= axel
-PORTVERSION= 1.0b
-PORTREVISION= 0
+PORTVERSION= 1.1
CATEGORIES= ftp
-MASTER_SITES= http://wilmer.gaast.net/downloads/
+MASTER_SITES= ${MASTER_SITE_GENTOO} \
+ http://alioth.debian.org/frs/download.php/2287/
+MASTER_SITE_SUBDIR= distfiles
MAINTAINER= prudhvikrishna@gmail.com
COMMENT= A download accelerator
-USE_GETTEXT= yes
USE_GMAKE= yes
HAS_CONFIGURE= yes
CONFIGURE_ARGS= --prefix=${PREFIX} --mandir=${MANPREFIX}/man --i18n=1
+OPTIONS= NLS "I18N support" on \
+ DEBUG "Debugging support" off
+
+.include <bsd.port.pre.mk>
+
+.if !defined(WITHOUT_NLS)
+USE_GETTEXT= yes
+USE_ICONV= yes
+PLIST_SUB+= NLS=""
+CONFIGURE_ARGS+=--i18n=1
+.else
+PLIST_SUB+= NLS="@comment "
+CONFIGURE_ARGS+=--i18n=0
+.endif
+
+.if defined(WITH_DEBUG)
+CONFIGURE_ARGS+=--debug=1 --strip=0
+.endif
+
MAN1= axel.1
post-configure:
@${REINPLACE_CMD} -e 's,-O3,${CFLAGS},; s|gcc|${CC}|; \
s|-pthread|${PTHREAD_LIBS}|' ${WRKSRC}/Makefile.settings
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>