aboutsummaryrefslogtreecommitdiff
path: root/ftp/curl/Makefile
diff options
context:
space:
mode:
authorPeter Pentchev <roam@FreeBSD.org>2009-01-26 02:11:01 +0000
committerPeter Pentchev <roam@FreeBSD.org>2009-01-26 02:11:01 +0000
commitbd3c754a8f797953190cee6b158b7161b1748bde (patch)
tree5a2b9272eb2761902bf188e1453c83709c6fb438 /ftp/curl/Makefile
parent731195e5196ba274b957a08babe0c77374bf7f39 (diff)
Notes
Diffstat (limited to 'ftp/curl/Makefile')
-rw-r--r--ftp/curl/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/ftp/curl/Makefile b/ftp/curl/Makefile
index 46ef4acdf402..2ca954c957be 100644
--- a/ftp/curl/Makefile
+++ b/ftp/curl/Makefile
@@ -202,6 +202,13 @@ post-install:
# Setting LC_ALL=C is a kludge; maybe curl/libcurl shouldn't actually use
# the user's locale when dates are sent to the server.
test: build
+.if defined(WITHOUT_PROXY)
+ @${ECHO_MSG} "******************************************"
+ @${ECHO_MSG} "* You have disabled curl proxy support. *"
+ @${ECHO_MSG} "* Some tests SHALL FAIL! *"
+ @${ECHO_MSG} "* This is being addressed. *"
+ @${ECHO_MSG} "******************************************"
+.endif
@cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} LC_ALL=C ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} test
.include <bsd.port.post.mk>