aboutsummaryrefslogtreecommitdiff
path: root/ftp/curl/Makefile
diff options
context:
space:
mode:
authorBill Fumerola <billf@FreeBSD.org>1999-02-09 15:31:34 +0000
committerBill Fumerola <billf@FreeBSD.org>1999-02-09 15:31:34 +0000
commitbb0aa544aed1628fdac5ed53ac5bcb9116c40bda (patch)
tree9232de9a1a9fc0932d28e277dd22f2e9256a2ee4 /ftp/curl/Makefile
parentad02b309744a7d9f2e3a30a01578ac0f3dfcbfe8 (diff)
downloadports-bb0aa544aed1628fdac5ed53ac5bcb9116c40bda.tar.gz
ports-bb0aa544aed1628fdac5ed53ac5bcb9116c40bda.zip
Notes
Diffstat (limited to 'ftp/curl/Makefile')
-rw-r--r--ftp/curl/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/ftp/curl/Makefile b/ftp/curl/Makefile
new file mode 100644
index 000000000000..585f969d95bd
--- /dev/null
+++ b/ftp/curl/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: curl
+# Version required: 5.5
+# Date created: 12 December 1998
+# Whom: Neil Blakey-Milner <nbm@rucus.ru.ac.za>
+#
+# $Id:$
+
+DISTNAME= curl-5.5
+CATEGORIES= net www
+MASTER_SITES= http://www.fts.frontec.se/~dast/stuff/ \
+ ftp://ftp.rhrz.uni-bonn.de/pub-koeln/net/inet/ \
+ ftp://ftp.win.or.jp/pub/network/www/misc/ \
+ ftp://ftp.all.de/pub2/unix/network/www/curl/ \
+ ftp://crydee.sai.msu.ru/zeus/unix/WWW/tools/mirror/
+
+MAINTAINER= kkennawa@physics.adelaide.edu.au
+
+.if defined(USE_SSL)
+BUILD_DEPENDS= ssleay:${PORTSDIR}/security/SSLeay
+.endif
+
+.if defined(USE_SSL)
+CONFIGURE_ENV+= CPPFLAGS='-I${PREFIX}/include' LDFLAGS='-L${PREFIX}/lib'
+.endif
+
+USE_AUTOCONF= yes
+MAKEFILES= Makefile src/Makefile
+
+post-configure:
+
+.for x in ${MAKEFILES}
+ @ ${MV} ${WRKSRC}/${x} ${WRKSRC}/${x}.pre_sed
+ @ ${SED} -e 's#@SHELL@#${SH}#' \
+ ${WRKSRC}/${x}.pre_sed > ${WRKSRC}/${x}
+.endfor
+
+.include <bsd.port.mk>