aboutsummaryrefslogtreecommitdiff
path: root/ftp/curl
diff options
context:
space:
mode:
authorPeter Pentchev <roam@FreeBSD.org>2010-09-12 21:05:48 +0000
committerPeter Pentchev <roam@FreeBSD.org>2010-09-12 21:05:48 +0000
commit8a7e06be2a217a5e53fffcac03a772a1067289da (patch)
tree2cce3f8aeafdfff2cd5fc1cab6680f60ca5ddb32 /ftp/curl
parent85fb73d571682097e4c9e1cd6f4cec86f2f0db1a (diff)
downloadports-8a7e06be2a217a5e53fffcac03a772a1067289da.tar.gz
ports-8a7e06be2a217a5e53fffcac03a772a1067289da.zip
Notes
Diffstat (limited to 'ftp/curl')
-rw-r--r--ftp/curl/Makefile24
-rw-r--r--ftp/curl/distinfo6
-rw-r--r--ftp/curl/files/patch-Makefile.in6
-rw-r--r--ftp/curl/files/patch-configure16
-rw-r--r--ftp/curl/files/patch-lib::url.c10
-rw-r--r--ftp/curl/files/patch-src::main.c4
-rw-r--r--ftp/curl/files/patch-tests::libtest::lib505.c53
-rw-r--r--ftp/curl/files/patch-tests::libtest::lib541.c53
-rw-r--r--ftp/curl/pkg-plist1
9 files changed, 51 insertions, 122 deletions
diff --git a/ftp/curl/Makefile b/ftp/curl/Makefile
index b13bd3865a87..0f4756f083df 100644
--- a/ftp/curl/Makefile
+++ b/ftp/curl/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= curl
-PORTVERSION= 7.20.1
+PORTVERSION= 7.21.1
CATEGORIES= ftp ipv6 www
MASTER_SITES= http://curl.haxx.se/download/ \
ftp://ftp.sunet.se/pub/www/utilities/curl/ \
@@ -53,7 +53,8 @@ PLIST_SUB= SHLIB_VER="${SHLIB_VER}"
USE_PERL5_BUILD= yes
USE_BZIP2= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS+=--enable-pop3 --enable-smtp --enable-imap --enable-rtsp
+CONFIGURE_ARGS+=--enable-pop3 --enable-smtp --enable-imap --enable-rtsp \
+ --disable-threaded-resolver
MAKE_JOBS_SAFE= yes
OPTIONS= CARES "Asynchronous DNS resolution via c-ares" off \
@@ -69,7 +70,9 @@ OPTIONS= CARES "Asynchronous DNS resolution via c-ares" off \
OPENSSL "OpenSSL support" on \
CA_BUNDLE "Install CA bundle for OpenSSL" on \
PROXY "Proxy support" on \
- TRACKMEMORY "Enable curl memory diagnostic output" off
+ RTMP "RTMP streams support" off \
+ TRACKMEMORY "Enable curl memory diagnostic output" off \
+ WERROR "Treat compilation warnings as errors" on
.include <bsd.port.pre.mk>
@@ -176,8 +179,17 @@ CONFIGURE_ARGS+= --without-libssh2
CONFIGURE_ARGS+= --enable-debug
.endif
+.if defined(WITH_RTMP)
+LIB_DEPENDS+= rtmp.0:${PORTSDIR}/multimedia/rtmpdump
+CONFIGURE_ARGS+= --with-librtmp=${LOCALBASE}
+.else
+CONFIGURE_ARGS+= --without-librtmp
+.endif
+
.if defined(WITH_TRACKMEMORY)
CONFIGURE_ARGS+= --enable-curldebug
+.else
+CONFIGURE_ARGS+= --disable-curldebug
.endif
.if defined(WITH_NTLM)
@@ -192,6 +204,12 @@ CONFIGURE_ARGS+= --enable-proxy
CONFIGURE_ARGS+= --disable-proxy
.endif
+.if defined(WITH_WERROR)
+CONFIGURE_ARGS+= --enable-werror
+.else
+CONFIGURE_ARGS+= --disable-werror
+.endif
+
.if defined(ADDFLAGS)
CONFIGURE_ENV+= LDFLAGS="${LDFLAGS}"
.endif
diff --git a/ftp/curl/distinfo b/ftp/curl/distinfo
index b697b7d29e60..2778eab4299a 100644
--- a/ftp/curl/distinfo
+++ b/ftp/curl/distinfo
@@ -1,3 +1,3 @@
-MD5 (curl-7.20.1.tar.bz2) = 244b16b2a38c70e47130c8494b7371b9
-SHA256 (curl-7.20.1.tar.bz2) = 70664da8e2a8c84327abd10ed30d5a3fc9fa2151def9ee5b75f27e3538554e56
-SIZE (curl-7.20.1.tar.bz2) = 2097637
+MD5 (curl-7.21.1.tar.bz2) = eafde5b933bce1c1dca82d1054c8d967
+SHA256 (curl-7.21.1.tar.bz2) = 653b3214005c778a8c642af4e5dea46c74f7bf51017a568bb8725ea9eda73643
+SIZE (curl-7.21.1.tar.bz2) = 2150291
diff --git a/ftp/curl/files/patch-Makefile.in b/ftp/curl/files/patch-Makefile.in
index 034a19f3d018..792d2b7fa1b4 100644
--- a/ftp/curl/files/patch-Makefile.in
+++ b/ftp/curl/files/patch-Makefile.in
@@ -1,11 +1,11 @@
Description: Build and install the documentation as usual, no special handling.
Forwarded: https://sourceforge.net/tracker/?func=detail&aid=2897155&group_id=976&atid=100976
Author: Peter Pentchev <roam@FreeBSD.org>
-Last-Update: 2010-06-11
+Last-Update: 2010-09-12
--- a/Makefile.in
+++ b/Makefile.in
-@@ -301,9 +301,9 @@
+@@ -310,9 +310,9 @@
libcurl.pc.in vc6curl.dsw MacOSX-Framework Android.mk $(CMAKE_DIST)
bin_SCRIPTS = curl-config
@@ -18,7 +18,7 @@ Last-Update: 2010-06-11
pkgconfig_DATA = libcurl.pc
all: all-recursive
-@@ -864,12 +864,10 @@
+@@ -873,12 +873,10 @@
# We extend the standard install with a custom hook:
install-data-hook:
cd include && $(MAKE) install
diff --git a/ftp/curl/files/patch-configure b/ftp/curl/files/patch-configure
new file mode 100644
index 000000000000..2212a3d5f530
--- /dev/null
+++ b/ftp/curl/files/patch-configure
@@ -0,0 +1,16 @@
+Description: Fix a bashism - "test" uses "=", not "==".
+Forwarded: http://sourceforge.net/tracker/?func=detail&aid=3064939&group_id=976&atid=100976
+Author: Peter Pentchev <roam@FreeBSD.org>
+Last-Update: 2010-09-12
+
+--- a/configure
++++ b/configure
+@@ -2992,7 +2992,7 @@
+
+
+ CURL_CFLAG_EXTRAS=""
+-if test X"$want_werror" == Xyes; then
++if test X"$want_werror" = Xyes; then
+ CURL_CFLAG_EXTRAS="-Werror"
+ fi
+
diff --git a/ftp/curl/files/patch-lib::url.c b/ftp/curl/files/patch-lib::url.c
index 3c4cc2f12f22..7b04ddeb1e98 100644
--- a/ftp/curl/files/patch-lib::url.c
+++ b/ftp/curl/files/patch-lib::url.c
@@ -1,11 +1,11 @@
Description: Different handling of signals and threads.
Forwarded: not-needed
Author: Peter Pentchev <roam@FreeBSD.org>
-Last-Update: 2010-03-30
+Last-Update: 2010-09-12
--- a/lib/url.c
+++ b/lib/url.c
-@@ -831,6 +831,10 @@
+@@ -842,6 +842,10 @@
data->progress.flags |= PGRS_HIDE;
data->state.current_speed = -1; /* init to negative == impossible */
@@ -13,6 +13,6 @@ Last-Update: 2010-03-30
+ data->set.no_signal = TRUE; /* different handling of signals and threads */
+#endif /* __FreeBSD_version */
+
- /* This no longer creates a connection cache here. It is instead made on
- the first call to curl_easy_perform() or when the handle is added to a
- multi stack. */
+ data->wildcard.state = CURLWC_INIT;
+ data->wildcard.filelist = NULL;
+ data->set.fnmatch = ZERO_NULL;
diff --git a/ftp/curl/files/patch-src::main.c b/ftp/curl/files/patch-src::main.c
index fd2dd6fe35d5..b3b6a9bd4f86 100644
--- a/ftp/curl/files/patch-src::main.c
+++ b/ftp/curl/files/patch-src::main.c
@@ -1,11 +1,11 @@
Description: Use fstat() instead of stat() to avoid a race condition.
Forwarded: not-needed
Author: Peter Pentchev <roam@FreeBSD.org>
-Last-Update: 2010-06-11
+Last-Update: 2010-09-12
--- a/src/main.c
+++ b/src/main.c
-@@ -4658,33 +4658,34 @@
+@@ -4842,33 +4842,34 @@
break;
}
diff --git a/ftp/curl/files/patch-tests::libtest::lib505.c b/ftp/curl/files/patch-tests::libtest::lib505.c
deleted file mode 100644
index f5d8c0e7bc57..000000000000
--- a/ftp/curl/files/patch-tests::libtest::lib505.c
+++ /dev/null
@@ -1,53 +0,0 @@
-Description: Use fstat() instead of stat() to avoid a race condition.
-Forwarded: not-needed
-Author: Peter Pentchev <roam@FreeBSD.org>
-Last-Update: 2010-06-11
-
---- a/tests/libtest/lib505.c
-+++ b/tests/libtest/lib505.c
-@@ -54,12 +54,24 @@
- return -1;
- }
-
-+ /* get a FILE * of the same file, could also be made with
-+ fdopen() from the previous descriptor, but hey this is just
-+ an example! */
-+ hd_src = fopen(libtest_arg2, "rb");
-+ if(NULL == hd_src) {
-+ error = ERRNO;
-+ fprintf(stderr, "fopen() failed with error: %d %s\n",
-+ error, strerror(error));
-+ fprintf(stderr, "Error opening file: %s\n", libtest_arg2);
-+ return -2; /* if this happens things are major weird */
-+ }
-+
- /* get the file size of the local file */
-- hd = stat(libtest_arg2, &file_info);
-+ hd = fstat(fileno(hd_src), &file_info);
- if(hd == -1) {
- /* can't open file, bail out */
- error = ERRNO;
-- fprintf(stderr, "stat() failed with error: %d %s\n",
-+ fprintf(stderr, "fstat() failed with error: %d %s\n",
- error, strerror(error));
- fprintf(stderr, "WARNING: cannot open file %s\n", libtest_arg2);
- return -1;
-@@ -70,18 +82,6 @@
- return -4;
- }
-
-- /* get a FILE * of the same file, could also be made with
-- fdopen() from the previous descriptor, but hey this is just
-- an example! */
-- hd_src = fopen(libtest_arg2, "rb");
-- if(NULL == hd_src) {
-- error = ERRNO;
-- fprintf(stderr, "fopen() failed with error: %d %s\n",
-- error, strerror(error));
-- fprintf(stderr, "Error opening file: %s\n", libtest_arg2);
-- return -2; /* if this happens things are major weird */
-- }
--
- if (curl_global_init(CURL_GLOBAL_ALL) != CURLE_OK) {
- fprintf(stderr, "curl_global_init() failed\n");
- fclose(hd_src);
diff --git a/ftp/curl/files/patch-tests::libtest::lib541.c b/ftp/curl/files/patch-tests::libtest::lib541.c
deleted file mode 100644
index 98d1f3f47b60..000000000000
--- a/ftp/curl/files/patch-tests::libtest::lib541.c
+++ /dev/null
@@ -1,53 +0,0 @@
-Description: Use fstat() instead of stat() to avoid a race condition.
-Forwarded: not-needed
-Author: Peter Pentchev <roam@FreeBSD.org>
-Last-Update: 2010-06-11
-
---- a/tests/libtest/lib541.c
-+++ b/tests/libtest/lib541.c
-@@ -46,12 +46,24 @@
- return -1;
- }
-
-+ /* get a FILE * of the same file, could also be made with
-+ fdopen() from the previous descriptor, but hey this is just
-+ an example! */
-+ hd_src = fopen(libtest_arg2, "rb");
-+ if(NULL == hd_src) {
-+ error = ERRNO;
-+ fprintf(stderr, "fopen() failed with error: %d %s\n",
-+ error, strerror(error));
-+ fprintf(stderr, "Error opening file: %s\n", libtest_arg2);
-+ return -2; /* if this happens things are major weird */
-+ }
-+
- /* get the file size of the local file */
-- hd = stat(libtest_arg2, &file_info);
-+ hd = fstat(fileno(hd_src), &file_info);
- if(hd == -1) {
- /* can't open file, bail out */
- error = ERRNO;
-- fprintf(stderr, "stat() failed with error: %d %s\n",
-+ fprintf(stderr, "fstat() failed with error: %d %s\n",
- error, strerror(error));
- fprintf(stderr, "WARNING: cannot open file %s\n", libtest_arg2);
- return -1;
-@@ -62,18 +74,6 @@
- return -4;
- }
-
-- /* get a FILE * of the same file, could also be made with
-- fdopen() from the previous descriptor, but hey this is just
-- an example! */
-- hd_src = fopen(libtest_arg2, "rb");
-- if(NULL == hd_src) {
-- error = ERRNO;
-- fprintf(stderr, "fopen() failed with error: %d %s\n",
-- error, strerror(error));
-- fprintf(stderr, "Error opening file: %s\n", libtest_arg2);
-- return -2; /* if this happens things are major weird */
-- }
--
- if (curl_global_init(CURL_GLOBAL_ALL) != CURLE_OK) {
- fprintf(stderr, "curl_global_init() failed\n");
- fclose(hd_src);
diff --git a/ftp/curl/pkg-plist b/ftp/curl/pkg-plist
index becd90eb80d1..dad259efc611 100644
--- a/ftp/curl/pkg-plist
+++ b/ftp/curl/pkg-plist
@@ -167,6 +167,7 @@ libdata/pkgconfig/libcurl.pc
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/evhiperfifo.c
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/fileupload.c
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/fopen.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ftp-wildcard.c
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ftpget.c
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ftpgetinfo.c
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ftpgetresp.c