aboutsummaryrefslogtreecommitdiff
path: root/ftp/curl
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2014-02-06 11:40:40 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2014-02-06 11:40:40 +0000
commit49b8a762e304185190a187a47c2a2a1e47f9094e (patch)
tree5608efd2dd752883ecd253cdf24fa482fb6d65f8 /ftp/curl
parent2603c504ec6df83187f5627b15285fab62e2c4f9 (diff)
downloadports-49b8a762e304185190a187a47c2a2a1e47f9094e.tar.gz
ports-49b8a762e304185190a187a47c2a2a1e47f9094e.zip
Notes
Diffstat (limited to 'ftp/curl')
-rw-r--r--ftp/curl/Makefile5
-rw-r--r--ftp/curl/distinfo4
-rw-r--r--ftp/curl/files/patch-CVE-2013-642232
3 files changed, 4 insertions, 37 deletions
diff --git a/ftp/curl/Makefile b/ftp/curl/Makefile
index 05980d04bddb..8e5f4df99236 100644
--- a/ftp/curl/Makefile
+++ b/ftp/curl/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= curl
-PORTVERSION= 7.33.0
-PORTREVISION= 2
+PORTVERSION= 7.34.0
CATEGORIES= ftp www
MASTER_SITES= http://curl.haxx.se/download/ \
LOCAL/sunpoet
@@ -159,7 +158,7 @@ post-install:
# Setting LC_ALL=C is a kludge; maybe curl/libcurl shouldn't actually use
# the user's locale when dates are sent to the server.
-regression-test test: build
+x-regression-test test: build
.if !${PORT_OPTIONS:MPROXY}
@${ECHO_MSG} "******************************************"
@${ECHO_MSG} "* You have disabled curl proxy support. *"
diff --git a/ftp/curl/distinfo b/ftp/curl/distinfo
index 695bcee97917..b3dcba7767fb 100644
--- a/ftp/curl/distinfo
+++ b/ftp/curl/distinfo
@@ -1,2 +1,2 @@
-SHA256 (curl-7.33.0.tar.lzma) = 17eaa3503d84b1aebc2fbf25b9649246f5cbd7c859a497c2aa42f04d0f83a046
-SIZE (curl-7.33.0.tar.lzma) = 2244539
+SHA256 (curl-7.34.0.tar.lzma) = 8ea8b72ccaa07625609fee2e41591162d245d416adbd0a3242d44dff8e3ad6f9
+SIZE (curl-7.34.0.tar.lzma) = 2256196
diff --git a/ftp/curl/files/patch-CVE-2013-6422 b/ftp/curl/files/patch-CVE-2013-6422
deleted file mode 100644
index 3c29829f945c..000000000000
--- a/ftp/curl/files/patch-CVE-2013-6422
+++ /dev/null
@@ -1,32 +0,0 @@
---- ./lib/gtls.c.orig 2013-10-12 15:05:06.000000000 -0700
-+++ ./lib/gtls.c 2013-12-18 15:00:22.000000000 -0800
-@@ -5,7 +5,7 @@
- * | (__| |_| | _ <| |___
- * \___|\___/|_| \_\_____|
- *
-- * Copyright (C) 1998 - 2012, Daniel Stenberg, <daniel@haxx.se>, et al.
-+ * Copyright (C) 1998 - 2013, Daniel Stenberg, <daniel@haxx.se>, et al.
- *
- * This software is licensed as described in the file COPYING, which
- * you should have received as part of this distribution. The terms
-@@ -633,10 +633,8 @@
- else
- infof(data, "\t server certificate verification OK\n");
- }
-- else {
-+ else
- infof(data, "\t server certificate verification SKIPPED\n");
-- goto after_server_cert_verification;
-- }
-
- /* initialize an X.509 certificate structure. */
- gnutls_x509_crt_init(&x509_cert);
-@@ -766,8 +764,6 @@
-
- gnutls_x509_crt_deinit(x509_cert);
-
--after_server_cert_verification:
--
- /* compression algorithm (if any) */
- ptr = gnutls_compression_get_name(gnutls_compression_get(session));
- /* the *_get_name() says "NULL" if GNUTLS_COMP_NULL is returned */