aboutsummaryrefslogtreecommitdiff
path: root/ftp/curlpp
diff options
context:
space:
mode:
authorPeter Pentchev <roam@FreeBSD.org>2006-09-26 14:46:02 +0000
committerPeter Pentchev <roam@FreeBSD.org>2006-09-26 14:46:02 +0000
commit207f43b8e96e50da5fb50e83e8d8b8a5c41c93c5 (patch)
treeaf7a38f1ad1fbbe82b8e935bd704a01b000ccac6 /ftp/curlpp
parent9b74482bde2bc380b1b003838b43cc7727012a28 (diff)
downloadports-207f43b8e96e50da5fb50e83e8d8b8a5c41c93c5.tar.gz
ports-207f43b8e96e50da5fb50e83e8d8b8a5c41c93c5.zip
Notes
Diffstat (limited to 'ftp/curlpp')
-rw-r--r--ftp/curlpp/Makefile6
-rw-r--r--ftp/curlpp/distinfo6
-rw-r--r--ftp/curlpp/files/patch-ltmain.sh15
-rw-r--r--ftp/curlpp/pkg-plist50
4 files changed, 55 insertions, 22 deletions
diff --git a/ftp/curlpp/Makefile b/ftp/curlpp/Makefile
index b655c9a07b47..c4a75ca8c9b9 100644
--- a/ftp/curlpp/Makefile
+++ b/ftp/curlpp/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= curlpp
-PORTVERSION= 0.5.2
+PORTVERSION= 0.6.1
CATEGORIES= ftp
MASTER_SITES= http://rrette.com/downloads/sources/
@@ -21,12 +21,12 @@ GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
CONFIGURE_ARGS= --disable-ewarning
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
.include <bsd.port.pre.mk>
.if ${ARCH} == "alpha" && ${OSVERSION} < 500000
-BROKEN= "Does not compile on alpha 4.x"
+BROKEN= Does not compile on alpha 4.x
.endif
pre-everything::
diff --git a/ftp/curlpp/distinfo b/ftp/curlpp/distinfo
index d3e22f4a6010..9009fbffd451 100644
--- a/ftp/curlpp/distinfo
+++ b/ftp/curlpp/distinfo
@@ -1,3 +1,3 @@
-MD5 (curlpp-0.5.2.tar.gz) = 5eea4648956238d3f12ec69da71941d2
-SHA256 (curlpp-0.5.2.tar.gz) = 5fca703e392d93bcf8a991d8cd183e322bfa7ea9a1f5d9dc3ce87e7a540738d5
-SIZE (curlpp-0.5.2.tar.gz) = 406164
+MD5 (curlpp-0.6.1.tar.gz) = 9f843154cc3d23fd547cc6cbfdb99e90
+SHA256 (curlpp-0.6.1.tar.gz) = 7812059a562dbd4b26b69e4c32d9a4149b4957e4a0428efed7b712fc8f704afe
+SIZE (curlpp-0.6.1.tar.gz) = 433513
diff --git a/ftp/curlpp/files/patch-ltmain.sh b/ftp/curlpp/files/patch-ltmain.sh
deleted file mode 100644
index 49640ca98b52..000000000000
--- a/ftp/curlpp/files/patch-ltmain.sh
+++ /dev/null
@@ -1,15 +0,0 @@
---- ltmain.sh.orig Thu Nov 27 11:22:47 2003
-+++ ltmain.sh Thu Nov 27 11:22:57 2003
-@@ -4344,10 +4344,12 @@
- fi
-
- # Install the pseudo-library for information purposes.
-+ if /usr/bin/false ; then
- name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
- instname="$dir/$name"i
- $show "$install_prog $instname $destdir/$name"
- $run eval "$install_prog $instname $destdir/$name" || exit $?
-+ fi
-
- # Maybe install the static library, too.
- test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
diff --git a/ftp/curlpp/pkg-plist b/ftp/curlpp/pkg-plist
index 6bf34a25533f..5dcd1cb17047 100644
--- a/ftp/curlpp/pkg-plist
+++ b/ftp/curlpp/pkg-plist
@@ -2,8 +2,12 @@ bin/curlpp-config
include/curlpp/CurlHandle.hpp
include/curlpp/CurlHandle.inl
include/curlpp/Easy.hpp
+include/curlpp/Easy.inl
include/curlpp/Exception.hpp
include/curlpp/Form.hpp
+include/curlpp/Info.hpp
+include/curlpp/Info.inl
+include/curlpp/Infos.hpp
include/curlpp/NonCopyable.hpp
include/curlpp/Option.hpp
include/curlpp/Option.inl
@@ -19,11 +23,48 @@ include/curlpp/SList.hpp
include/curlpp/StorageOptions.hpp
include/curlpp/StorageOptions.inl
include/curlpp/TypeTrait.hpp
-include/curlpp/cURL.hpp
+include/curlpp/Types.hpp
include/curlpp/cURLpp.hpp
include/curlpp/dllfct.h
+include/curlpp/utilspp/singleton/CreationStatic.hpp
+include/curlpp/utilspp/singleton/CreationStatic.inl
+include/curlpp/utilspp/singleton/CreationUsingNew.hpp
+include/curlpp/utilspp/singleton/CreationUsingNew.inl
+include/curlpp/utilspp/singleton/LifetimeDefault.hpp
+include/curlpp/utilspp/singleton/LifetimeDefault.inl
+include/curlpp/utilspp/singleton/LifetimeLibrary.hpp
+include/curlpp/utilspp/singleton/LifetimeLibrary.inl
+include/curlpp/utilspp/singleton/LifetimeWithLongevity.hpp
+include/curlpp/utilspp/singleton/LifetimeWithLongevity.inl
+include/curlpp/utilspp/singleton/PrivateMembers.hpp
+include/curlpp/utilspp/singleton/PrivateMembers.inl
+include/curlpp/utilspp/singleton/SingletonHolder.hpp
+include/curlpp/utilspp/singleton/SingletonHolder.inl
+@dirrm include/curlpp/utilspp/singleton
+@dirrm include/curlpp/utilspp
@dirrm include/curlpp
+include/utilspp/EmptyType.hpp
+include/utilspp/Functors.hpp
+include/utilspp/NonCopyable.hpp
+include/utilspp/NullType.hpp
+include/utilspp/Singleton.hpp
+include/utilspp/SmartPtr.hpp
+include/utilspp/ThreadingFactoryMutex.hpp
+include/utilspp/ThreadingFactoryMutex.inl
+include/utilspp/ThreadingSingle.hpp
+include/utilspp/ThreadingSingle.inl
+include/utilspp/TypeList.hpp
+include/utilspp/functor/Binder.hpp
+include/utilspp/functor/Binder.inl
+include/utilspp/functor/FunctorHandler.hpp
+include/utilspp/functor/Functor.hpp
+include/utilspp/functor/FunctorImpl.hpp
+include/utilspp/functor/Functor.inl
+include/utilspp/functor/MemFunHandler.hpp
+@dirrm include/utilspp/functor
+@dirrm include/utilspp
lib/libcurlpp.a
+lib/libcurlpp.la
lib/libcurlpp.so
lib/libcurlpp.so.0
libdata/pkgconfig/curlpp.pc
@@ -34,5 +75,12 @@ libdata/pkgconfig/curlpp.pc
%%PORTDOCS%%%%EXAMPLESDIR%%/example03.cpp
%%PORTDOCS%%%%EXAMPLESDIR%%/example04.cpp
%%PORTDOCS%%%%EXAMPLESDIR%%/example05.cpp
+%%PORTDOCS%%%%EXAMPLESDIR%%/example06.cpp
+%%PORTDOCS%%%%EXAMPLESDIR%%/example07.cpp
+%%PORTDOCS%%%%EXAMPLESDIR%%/example08.cpp
+%%PORTDOCS%%%%EXAMPLESDIR%%/example09.cpp
+%%PORTDOCS%%%%EXAMPLESDIR%%/example10.cpp
+%%PORTDOCS%%%%EXAMPLESDIR%%/example11.cpp
+%%PORTDOCS%%%%EXAMPLESDIR%%/example12.cpp
%%PORTDOCS%%@dirrm %%DOCSDIR%%
%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%