aboutsummaryrefslogtreecommitdiff
path: root/ftp/filezilla
diff options
context:
space:
mode:
authorAlejandro Pulver <alepulver@FreeBSD.org>2006-10-31 19:05:50 +0000
committerAlejandro Pulver <alepulver@FreeBSD.org>2006-10-31 19:05:50 +0000
commit468dc002c2d476e1bc8b8f5adab2dd1640801504 (patch)
tree8973906c33d156538865114038090be08b54e78c /ftp/filezilla
parent4ef0bfb4a61395f967b8a04643ad2510fd811abd (diff)
downloadports-468dc002c2d476e1bc8b8f5adab2dd1640801504.tar.gz
ports-468dc002c2d476e1bc8b8f5adab2dd1640801504.zip
Notes
Diffstat (limited to 'ftp/filezilla')
-rw-r--r--ftp/filezilla/Makefile38
-rw-r--r--ftp/filezilla/distinfo3
-rw-r--r--ftp/filezilla/files/patch-src__interface__FileZilla.cpp10
-rw-r--r--ftp/filezilla/pkg-descr21
-rw-r--r--ftp/filezilla/pkg-plist136
5 files changed, 208 insertions, 0 deletions
diff --git a/ftp/filezilla/Makefile b/ftp/filezilla/Makefile
new file mode 100644
index 000000000000..c8d76c7d7048
--- /dev/null
+++ b/ftp/filezilla/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: filezilla
+# Date created: 2006-10-24
+# Whom: alepulver
+#
+# $FreeBSD$
+#
+
+PORTNAME= filezilla
+DISTVERSION= 3.0.0-beta2
+CATEGORIES= ftp
+MASTER_SITES= SF
+DISTNAME= FileZilla_${DISTVERSION}_src
+
+MAINTAINER= alepulver@FreeBSD.org
+COMMENT= Fast FTP and SFTP client with a lot of features
+
+LIB_DEPENDS= idn.16:${PORTSDIR}/dns/libidn
+
+USE_BZIP2= yes
+USE_GETTEXT= yes
+USE_GMAKE= yes
+USE_WX= 2.6
+WX_CONF_ARGS= relative
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
+WRKSRC= ${WRKDIR}/${PORTNAME}-${DISTVERSION}
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|dummy wxrc|&-gtk2-${WX_VERSION}|' \
+ ${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+IGNORE= does not build
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/ftp/filezilla/distinfo b/ftp/filezilla/distinfo
new file mode 100644
index 000000000000..0f2fea684bec
--- /dev/null
+++ b/ftp/filezilla/distinfo
@@ -0,0 +1,3 @@
+MD5 (FileZilla_3.0.0-beta2_src.tar.bz2) = ceb2b927490f1e4659167a66ce5c9425
+SHA256 (FileZilla_3.0.0-beta2_src.tar.bz2) = 10b4cd8524cd5823df82439705c3fb082f9d5e31fb124789e0fc7fdff5522555
+SIZE (FileZilla_3.0.0-beta2_src.tar.bz2) = 1163527
diff --git a/ftp/filezilla/files/patch-src__interface__FileZilla.cpp b/ftp/filezilla/files/patch-src__interface__FileZilla.cpp
new file mode 100644
index 000000000000..7b82a2085827
--- /dev/null
+++ b/ftp/filezilla/files/patch-src__interface__FileZilla.cpp
@@ -0,0 +1,10 @@
+--- ./src/interface/FileZilla.cpp.orig Sun Oct 15 12:36:01 2006
++++ ./src/interface/FileZilla.cpp Tue Oct 24 20:50:08 2006
+@@ -533,7 +533,6 @@
+ wxPathList pathList;
+ pathList.AddEnvList(_T("PATH"));
+ executable = pathList.FindAbsoluteValidPath(program);
+- bool found = false;
+ if (executable != _T(""))
+ found = true;
+ }
diff --git a/ftp/filezilla/pkg-descr b/ftp/filezilla/pkg-descr
new file mode 100644
index 000000000000..f3e437245484
--- /dev/null
+++ b/ftp/filezilla/pkg-descr
@@ -0,0 +1,21 @@
+FileZilla is a powerful FTP-client. It has been designed for ease of use and
+with support for as many features as possible, while still being fast and
+reliable.
+
+The main features of FileZilla are:
+
+* Ability to resume Uploads/Downloads (if the server supports it).
+* Custom Commands.
+* Site Manager with folders.
+* Keep Alive system.
+* Timeout detection.
+* Firewall support.
+* SOCKS4/5 and HTTP1.1 Proxy support.
+* SSL secured connections.
+* SFTP support.
+* Upload/Download Queue.
+* Drag&Drop.
+* Multi-language support.
+* GSS authentication and encryption using Kerberos.
+
+WWW: http://filezilla.sourceforge.net/
diff --git a/ftp/filezilla/pkg-plist b/ftp/filezilla/pkg-plist
new file mode 100644
index 000000000000..14e811650e90
--- /dev/null
+++ b/ftp/filezilla/pkg-plist
@@ -0,0 +1,136 @@
+bin/filezilla
+bin/fzsftp
+%%DATADIR%%/locales/ar_EG/filezilla.mo
+%%DATADIR%%/locales/bg/filezilla.mo
+%%DATADIR%%/locales/ca_ES/filezilla.mo
+%%DATADIR%%/locales/cs/filezilla.mo
+%%DATADIR%%/locales/da_DK/filezilla.mo
+%%DATADIR%%/locales/de/filezilla.mo
+%%DATADIR%%/locales/es/filezilla.mo
+%%DATADIR%%/locales/et_EE/filezilla.mo
+%%DATADIR%%/locales/eu/filezilla.mo
+%%DATADIR%%/locales/fr_CA/filezilla.mo
+%%DATADIR%%/locales/fr_FR/filezilla.mo
+%%DATADIR%%/locales/gl/filezilla.mo
+%%DATADIR%%/locales/id_ID/filezilla.mo
+%%DATADIR%%/locales/it_IT/filezilla.mo
+%%DATADIR%%/locales/ja_JP/filezilla.mo
+%%DATADIR%%/locales/km/filezilla.mo
+%%DATADIR%%/locales/ko_KR/filezilla.mo
+%%DATADIR%%/locales/ku/filezilla.mo
+%%DATADIR%%/locales/lt/filezilla.mo
+%%DATADIR%%/locales/mk/filezilla.mo
+%%DATADIR%%/locales/nb_NO/filezilla.mo
+%%DATADIR%%/locales/nl/filezilla.mo
+%%DATADIR%%/locales/pl_PL/filezilla.mo
+%%DATADIR%%/locales/pt_BR/filezilla.mo
+%%DATADIR%%/locales/pt_PT/filezilla.mo
+%%DATADIR%%/locales/ro_RO/filezilla.mo
+%%DATADIR%%/locales/sk/filezilla.mo
+%%DATADIR%%/locales/sl/filezilla.mo
+%%DATADIR%%/locales/sv_SE/filezilla.mo
+%%DATADIR%%/locales/tr/filezilla.mo
+%%DATADIR%%/locales/zh_CN/filezilla.mo
+%%DATADIR%%/locales/zh_TW/filezilla.mo
+%%DATADIR%%/resources/16x16/cancel.png
+%%DATADIR%%/resources/16x16/disconnect.png
+%%DATADIR%%/resources/16x16/download.png
+%%DATADIR%%/resources/16x16/downloadadd.png
+%%DATADIR%%/resources/16x16/file.png
+%%DATADIR%%/resources/16x16/filter.png
+%%DATADIR%%/resources/16x16/folder.png
+%%DATADIR%%/resources/16x16/folderclosed.png
+%%DATADIR%%/resources/16x16/localtreeview.png
+%%DATADIR%%/resources/16x16/logview.png
+%%DATADIR%%/resources/16x16/processqueue.png
+%%DATADIR%%/resources/16x16/queueview.png
+%%DATADIR%%/resources/16x16/reconnect.png
+%%DATADIR%%/resources/16x16/refresh.png
+%%DATADIR%%/resources/16x16/remotetreeview.png
+%%DATADIR%%/resources/16x16/server.png
+%%DATADIR%%/resources/16x16/sitemanager.png
+%%DATADIR%%/resources/16x16/unknown.png
+%%DATADIR%%/resources/16x16/upload.png
+%%DATADIR%%/resources/16x16/uploadadd.png
+%%DATADIR%%/resources/32x32/file.png
+%%DATADIR%%/resources/cyril/16x16/ascii.png
+%%DATADIR%%/resources/cyril/16x16/auto.png
+%%DATADIR%%/resources/cyril/16x16/binary.png
+%%DATADIR%%/resources/cyril/16x16/bookmark.png
+%%DATADIR%%/resources/cyril/16x16/cancel.png
+%%DATADIR%%/resources/cyril/16x16/compare.png
+%%DATADIR%%/resources/cyril/16x16/disconnect.png
+%%DATADIR%%/resources/cyril/16x16/download.png
+%%DATADIR%%/resources/cyril/16x16/downloadadd.png
+%%DATADIR%%/resources/cyril/16x16/file.png
+%%DATADIR%%/resources/cyril/16x16/folder.png
+%%DATADIR%%/resources/cyril/16x16/folderback.png
+%%DATADIR%%/resources/cyril/16x16/folderclosed.png
+%%DATADIR%%/resources/cyril/16x16/folderup.png
+%%DATADIR%%/resources/cyril/16x16/help.png
+%%DATADIR%%/resources/cyril/16x16/localtreeview.png
+%%DATADIR%%/resources/cyril/16x16/logview.png
+%%DATADIR%%/resources/cyril/16x16/processqueue.png
+%%DATADIR%%/resources/cyril/16x16/queueview.png
+%%DATADIR%%/resources/cyril/16x16/reconnect.png
+%%DATADIR%%/resources/cyril/16x16/refresh.png
+%%DATADIR%%/resources/cyril/16x16/remotetreeview.png
+%%DATADIR%%/resources/cyril/16x16/server.png
+%%DATADIR%%/resources/cyril/16x16/showhidden.png
+%%DATADIR%%/resources/cyril/16x16/sitemanager.png
+%%DATADIR%%/resources/cyril/16x16/speedlimits.png
+%%DATADIR%%/resources/cyril/16x16/synchronize.png
+%%DATADIR%%/resources/cyril/16x16/upload.png
+%%DATADIR%%/resources/cyril/16x16/uploadadd.png
+%%DATADIR%%/resources/dialogs.xrc
+%%DATADIR%%/resources/down.png
+%%DATADIR%%/resources/dropdown.png
+%%DATADIR%%/resources/empty.png
+%%DATADIR%%/resources/filezilla.png
+%%DATADIR%%/resources/filezilla.xpm
+%%DATADIR%%/resources/leds.png
+%%DATADIR%%/resources/menus.xrc
+%%DATADIR%%/resources/netconfwizard.xrc
+%%DATADIR%%/resources/quickconnectbar.xrc
+%%DATADIR%%/resources/themes.xml
+%%DATADIR%%/resources/toolbar.xrc
+%%DATADIR%%/resources/up.png
+@dirrm %%DATADIR%%/resources/cyril/16x16
+@dirrm %%DATADIR%%/resources/cyril
+@dirrm %%DATADIR%%/resources/32x32
+@dirrm %%DATADIR%%/resources/16x16
+@dirrm %%DATADIR%%/resources
+@dirrm %%DATADIR%%/locales/zh_TW
+@dirrm %%DATADIR%%/locales/zh_CN
+@dirrm %%DATADIR%%/locales/tr
+@dirrm %%DATADIR%%/locales/sv_SE
+@dirrm %%DATADIR%%/locales/sl
+@dirrm %%DATADIR%%/locales/sk
+@dirrm %%DATADIR%%/locales/ro_RO
+@dirrm %%DATADIR%%/locales/pt_PT
+@dirrm %%DATADIR%%/locales/pt_BR
+@dirrm %%DATADIR%%/locales/pl_PL
+@dirrm %%DATADIR%%/locales/nl
+@dirrm %%DATADIR%%/locales/nb_NO
+@dirrm %%DATADIR%%/locales/mk
+@dirrm %%DATADIR%%/locales/lt
+@dirrm %%DATADIR%%/locales/ku
+@dirrm %%DATADIR%%/locales/ko_KR
+@dirrm %%DATADIR%%/locales/km
+@dirrm %%DATADIR%%/locales/ja_JP
+@dirrm %%DATADIR%%/locales/it_IT
+@dirrm %%DATADIR%%/locales/id_ID
+@dirrm %%DATADIR%%/locales/gl
+@dirrm %%DATADIR%%/locales/fr_FR
+@dirrm %%DATADIR%%/locales/fr_CA
+@dirrm %%DATADIR%%/locales/eu
+@dirrm %%DATADIR%%/locales/et_EE
+@dirrm %%DATADIR%%/locales/es
+@dirrm %%DATADIR%%/locales/de
+@dirrm %%DATADIR%%/locales/da_DK
+@dirrm %%DATADIR%%/locales/cs
+@dirrm %%DATADIR%%/locales/ca_ES
+@dirrm %%DATADIR%%/locales/bg
+@dirrm %%DATADIR%%/locales/ar_EG
+@dirrm %%DATADIR%%/locales
+@dirrm %%DATADIR%%