aboutsummaryrefslogtreecommitdiff
path: root/ftp/frox
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2002-06-23 07:36:16 +0000
committerWill Andrews <will@FreeBSD.org>2002-06-23 07:36:16 +0000
commit858f8aa4b506ba433311952140627c0fcee3db9c (patch)
tree03e733f7db063794a0678c0921ed193e67f2ee44 /ftp/frox
parent5dd9c94e7292b2d6b855b8bcd818197539b4fd14 (diff)
downloadports-858f8aa4b506ba433311952140627c0fcee3db9c.tar.gz
ports-858f8aa4b506ba433311952140627c0fcee3db9c.zip
Notes
Diffstat (limited to 'ftp/frox')
-rw-r--r--ftp/frox/Makefile76
-rw-r--r--ftp/frox/distinfo1
-rw-r--r--ftp/frox/files/frox.sh23
-rw-r--r--ftp/frox/files/patch-aa51
-rw-r--r--ftp/frox/pkg-comment1
-rw-r--r--ftp/frox/pkg-descr16
-rw-r--r--ftp/frox/pkg-message14
-rw-r--r--ftp/frox/pkg-plist8
8 files changed, 190 insertions, 0 deletions
diff --git a/ftp/frox/Makefile b/ftp/frox/Makefile
new file mode 100644
index 000000000000..953081ac9233
--- /dev/null
+++ b/ftp/frox/Makefile
@@ -0,0 +1,76 @@
+# New ports collection makefile for: frox
+# Date created: 11 June 2002
+# Whom: Sergey Matveychuk <sem@ciam.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= frox
+PORTVERSION= 0.7.4
+CATEGORIES= ftp
+MASTER_SITES= http://www.hollo.org/frox/download/ \
+ http://frox.sourceforge.net/download/
+
+MAINTAINER= sem@ciam.ru
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+
+MAN1= frox.1
+MAN5= frox.conf.5
+
+DOCS= FAQ SECURITY CREDITS ChangeLog
+
+PKGMESSAGE= ${WRKDIR}/pkg-message
+
+CONFIGURE_ARGS= --enable-configfile=${PREFIX}/etc/frox.conf
+
+.if defined(WITH_HTTP_CACHE)
+CONFIGURE_ARGS+= --enable-http-cache
+.endif
+.if defined(WITH_IPFILTER)
+CONFIGURE_ARGS+= --enable-ipfilter
+.endif
+.if defined(WITH_CCP)
+CONFIGURE_ARGS+= --enable-ccp
+.endif
+.if defined(RUN_AS_ROOT)
+CONFIGURE_ARGS+= --enable-run-as-root
+.endif
+
+pre-fetch:
+ @${ECHO} ""
+ @${ECHO} "You can use the following build options:"
+ @${ECHO} ""
+ @${ECHO} " WITH_HTTP_CACHE=yes enable http-cache (like squid) using;"
+ @${ECHO} " WITH_IPFILTER=yes force use ipfilter instead of ipfw;"
+ @${ECHO} " WITH_CCP=yes enable ftp-proxy style command control programs;"
+ @${ECHO} " RUN_AS_ROOT=yes allow frox running as root (not recomended)"
+ @${ECHO} " for using port number <1024."
+ @${ECHO} ""
+
+pre-patch:
+ @${SED} 's|%%PREFIX%%|${PREFIX}|g' ${PKGDIR}/pkg-message >${PKGMESSAGE}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/frox ${PREFIX}/sbin
+ ${INSTALL_DATA} ${WRKSRC}/src/frox.conf ${PREFIX}/etc/frox.conf.sample
+ ${INSTALL_MAN} ${WRKSRC}/doc/frox.man ${PREFIX}/man/man1/frox.1
+ ${INSTALL_MAN} ${WRKSRC}/doc/frox.conf.man ${PREFIX}/man/man5/frox.conf.5
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for file in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/doc/${file} ${DOCSDIR}
+.endfor
+.endif
+ @${STRIP_CMD} ${PREFIX}/sbin/frox
+ @if [ ! -f ${PREFIX}/etc/rc.d/${PORTNAME}.sh ]; then \
+ ${ECHO_CMD} "Install ${PREFIX}/etc/rc.d/${PORTNAME}.sh startup file."; \
+ ${INSTALL_SCRIPT} -m 751 ${FILESDIR}/${PORTNAME}.sh ${PREFIX}/etc/rc.d/${PORTNAME}.sh; \
+ fi
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/ftp/frox/distinfo b/ftp/frox/distinfo
new file mode 100644
index 000000000000..4b557c654b21
--- /dev/null
+++ b/ftp/frox/distinfo
@@ -0,0 +1 @@
+MD5 (frox-0.7.4.tar.bz2) = b7f1665635aaf5bc72b82809ee7c4f98
diff --git a/ftp/frox/files/frox.sh b/ftp/frox/files/frox.sh
new file mode 100644
index 000000000000..19ec73242849
--- /dev/null
+++ b/ftp/frox/files/frox.sh
@@ -0,0 +1,23 @@
+#!/bin/sh
+
+if ! PREFIX=$(expr $0 : "\(/.*\)/etc/rc\.d/$(basename $0)\$"); then
+ echo "$0: Cannot determine the PREFIX" >&2
+ exit 1
+fi
+
+case "$1" in
+start)
+ [ -x ${PREFIX}/sbin/frox -a -f ${PREFIX}/etc/frox.conf ]
+ grep -q '^ *# *FromInetd *yes' ${PREFIX}/etc/frox.conf && \
+ ${PREFIX}/sbin/frox && \
+ echo -n ' frox'
+ ;;
+stop)
+ kill `cat /var/run/frox.pid` && echo -n ' frox'
+ ;;
+*)
+ echo "Usage: `basename $0` {start|stop}" >&2
+ ;;
+esac
+
+exit 0
diff --git a/ftp/frox/files/patch-aa b/ftp/frox/files/patch-aa
new file mode 100644
index 000000000000..628926bbadbf
--- /dev/null
+++ b/ftp/frox/files/patch-aa
@@ -0,0 +1,51 @@
+--- src/frox.conf.orig Wed Jun 12 08:01:44 2002
++++ src/frox.conf Wed Jun 12 08:12:27 2002
+@@ -18,6 +18,7 @@
+ # commented out to listen on all local IPs.
+ #
+ # Listen firewall.localnet
++# Change it with your ip!
+ Listen 192.168.2.1
+
+ # Port to listen on. Must be supplied.
+@@ -26,7 +27,8 @@
+
+ # If specified then bind to this device
+ #
+-BindToDevice eth0
++# DON'T USE: It's not supported for FreeBSD
++#BindToDevice eth0
+
+ # Whether to run from inetd. You should still define Port above, but
+ # it isn't used for much.
+@@ -39,7 +41,7 @@
+ # comment this out and copy resolver libraries into the chroot jail instead.
+ # See FAQ section 3.2 for details.
+ #
+-ResolvLoadHack wontresolve.doesntexist.abc
++#ResolvLoadHack wontresolve.doesntexist.abc
+
+ # Another ftp proxy to forward on to. Frox will contact this ftp
+ # proxy, and send it a login name of the form "user@host:port" where
+@@ -54,8 +56,8 @@
+ # you really want to run as root (not a good idea) you must say so
+ # specifically, and have compiled with --enable-run-as-root.
+ #
+-# User nobody
+-# Group nogroup
++User nobody
++Group nogroup
+
+ # This is frox's working directory - it must be specified. Temporary
+ # files and sockets will be created here. If you are using local
+@@ -64,8 +66,8 @@
+ # also chroot to this dir on startup. To avoid this you must specifically
+ # set DontChroot to Yes.
+ #
+-# WorkingDir /usr/local/lib/frox
+-# DontChroot Yes
++WorkingDir /tmp
++DontChroot Yes
+
+ # Logging level. 0=No logging. 5=Critical errors only. 10= All errors.
+ # 15=Errors, other important stuf. 20= Errors, connections, cache
diff --git a/ftp/frox/pkg-comment b/ftp/frox/pkg-comment
new file mode 100644
index 000000000000..b136a5e6d124
--- /dev/null
+++ b/ftp/frox/pkg-comment
@@ -0,0 +1 @@
+Transparent FTP proxy with caching support
diff --git a/ftp/frox/pkg-descr b/ftp/frox/pkg-descr
new file mode 100644
index 000000000000..ca6c38f01384
--- /dev/null
+++ b/ftp/frox/pkg-descr
@@ -0,0 +1,16 @@
+This is frox, a transparent ftp proxy by James Hollingshead.
+
+Current features include:
+
+ o rfc959 compliant (I think) transparent proxying of ftp
+ connections.
+ o active --> passive mode conversion for data connections.
+ o Optional caching support either locally or through an external
+ HTTP cache.
+ o Optional virus scanning
+ o Optional non-transparent proxy support by logging in with
+ user@host:port.
+ o Options to bind to a specific interface, chroot, and drop
+ priveleges for security.
+
+WWW: http://www.hollo.org/frox/
diff --git a/ftp/frox/pkg-message b/ftp/frox/pkg-message
new file mode 100644
index 000000000000..a4d0edca9159
--- /dev/null
+++ b/ftp/frox/pkg-message
@@ -0,0 +1,14 @@
+**************************************************************************
+NOTES:
+Don't forget to create %%PREFIX%%/etc/frox.conf
+from %%PREFIX%%/etc/frox.conf.sample and then run frox by
+%%PREFIX%%/etc/rc.d/frox.sh start
+
+Or you can run frox with inetd this way:
+* uncomment 'FromInetd yes' in your %%PREFIX%%/etc/frox.conf (so frox
+would not run on startup by %%PREFIX%%/etc/rc.d/frox.sh)
+* add this line in /etc/inetd.conf:
+frox stream tcp nowait nobody %%PREFIX%%/sbin/frox frox
+* and assign port number for frox you want in /etc/services (e.g. 2121):
+frox 2121/tcp
+**************************************************************************
diff --git a/ftp/frox/pkg-plist b/ftp/frox/pkg-plist
new file mode 100644
index 000000000000..e9891cce765c
--- /dev/null
+++ b/ftp/frox/pkg-plist
@@ -0,0 +1,8 @@
+sbin/frox
+etc/frox.conf.sample
+etc/rc.d/frox.sh
+%%PORTDOCS%%share/doc/frox/FAQ
+%%PORTDOCS%%share/doc/frox/SECURITY
+%%PORTDOCS%%share/doc/frox/CREDITS
+%%PORTDOCS%%share/doc/frox/ChangeLog
+%%PORTDOCS%%@dirrm share/doc/frox