aboutsummaryrefslogtreecommitdiff
path: root/ftp/ftpsesame
diff options
context:
space:
mode:
authorSergey Matveychuk <sem@FreeBSD.org>2006-04-30 21:47:33 +0000
committerSergey Matveychuk <sem@FreeBSD.org>2006-04-30 21:47:33 +0000
commit02e9fa7f97834375653c874a746824346e25a7f4 (patch)
tree6a7764db9010f321518fbc1eec48da06477afeec /ftp/ftpsesame
parent65e029f972a0d0d9117b46b631277439cbb4d273 (diff)
downloadports-02e9fa7f97834375653c874a746824346e25a7f4.tar.gz
ports-02e9fa7f97834375653c874a746824346e25a7f4.zip
Notes
Diffstat (limited to 'ftp/ftpsesame')
-rw-r--r--ftp/ftpsesame/Makefile27
-rw-r--r--ftp/ftpsesame/distinfo3
-rw-r--r--ftp/ftpsesame/files/patch-Makefile12
-rw-r--r--ftp/ftpsesame/files/patch-ftpsesame.c11
-rw-r--r--ftp/ftpsesame/pkg-descr6
5 files changed, 59 insertions, 0 deletions
diff --git a/ftp/ftpsesame/Makefile b/ftp/ftpsesame/Makefile
new file mode 100644
index 000000000000..39d5d217adcd
--- /dev/null
+++ b/ftp/ftpsesame/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: ftpsesame
+# Date created: 1 May 2006
+# Whom: Sergey Matveychuk <sem@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ftpsesame
+PORTVERSION= 0.95
+CATEGORIES= ftp
+MASTER_SITES= http://www.sentia.org/downloads/
+
+MAINTAINER= sem@FreeBSD.org
+COMMENT= Helper for the FTP protocol get through your pf firewall
+
+MAN8= ftpsesame.8
+PLIST_FILES= bin/ftpsesame
+
+MAKE_ARGS= PREFIX=${PREFIX} MANPREFIX=${MANPREFIX}
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 502106
+IGNORE= There is no pf(4) in the base system
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/ftp/ftpsesame/distinfo b/ftp/ftpsesame/distinfo
new file mode 100644
index 000000000000..a1f002538da4
--- /dev/null
+++ b/ftp/ftpsesame/distinfo
@@ -0,0 +1,3 @@
+MD5 (ftpsesame-0.95.tar.gz) = df9f143f6615daf67369e3e3c444f62e
+SHA256 (ftpsesame-0.95.tar.gz) = 9ce486590caf422acf3620dfb15a577d20b2c5e6d554d9f26d6721d472c0bbb7
+SIZE (ftpsesame-0.95.tar.gz) = 10974
diff --git a/ftp/ftpsesame/files/patch-Makefile b/ftp/ftpsesame/files/patch-Makefile
new file mode 100644
index 000000000000..06d2208921f7
--- /dev/null
+++ b/ftp/ftpsesame/files/patch-Makefile
@@ -0,0 +1,12 @@
+--- Makefile.orig Mon May 1 01:32:30 2006
++++ Makefile Mon May 1 01:39:28 2006
+@@ -8,7 +8,7 @@
+ LDADD+= -lpcap
+
+ install:
+- install -s -o root -g bin -m 555 ftpsesame /usr/local/bin
+- install -o root -g bin -m 444 ftpsesame.cat8 /usr/local/man/cat8/ftpsesame.0
++ install -s -o root -g bin -m 555 ftpsesame ${PREFIX}/bin
++ install -o root -g bin -m 444 ftpsesame.8 ${MANPREFIX}/man/man8
+
+ .include <bsd.prog.mk>
diff --git a/ftp/ftpsesame/files/patch-ftpsesame.c b/ftp/ftpsesame/files/patch-ftpsesame.c
new file mode 100644
index 000000000000..754e59326314
--- /dev/null
+++ b/ftp/ftpsesame/files/patch-ftpsesame.c
@@ -0,0 +1,11 @@
+--- ftpsesame.c.orig Mon May 1 01:30:43 2006
++++ ftpsesame.c Mon May 1 01:30:51 2006
+@@ -663,7 +663,7 @@
+ gotsig_close = 1;
+ }
+
+-__dead void
++void
+ usage(void)
+ {
+ fprintf(stderr, "usage: %s [-d] [-D level] [-i interface] " \
diff --git a/ftp/ftpsesame/pkg-descr b/ftp/ftpsesame/pkg-descr
new file mode 100644
index 000000000000..51209d644d81
--- /dev/null
+++ b/ftp/ftpsesame/pkg-descr
@@ -0,0 +1,6 @@
+ftpsesame helps the FTP protocol get through your pf firewall.
+It does this by passively analysing FTP control connections
+and adding rules into a pf anchor when an FTP data connection
+is about to commence.
+
+WWW: http://www.sentia.org/projects/ftpsesame/