aboutsummaryrefslogtreecommitdiff
path: root/ftp/gftp/Makefile
diff options
context:
space:
mode:
authorOliver Lehmann <oliver@FreeBSD.org>2003-08-08 13:27:51 +0000
committerOliver Lehmann <oliver@FreeBSD.org>2003-08-08 13:27:51 +0000
commit0079714ffab59fb9baaefea13e184725d9a9708b (patch)
tree1a64184eaca3ed43167c3fd2e4881499f219775a /ftp/gftp/Makefile
parent4e00dbebbe8675f4356208e10188f1f5611e5969 (diff)
Notes
Diffstat (limited to 'ftp/gftp/Makefile')
-rw-r--r--ftp/gftp/Makefile15
1 files changed, 11 insertions, 4 deletions
diff --git a/ftp/gftp/Makefile b/ftp/gftp/Makefile
index f748d8afb73a..410d85948daa 100644
--- a/ftp/gftp/Makefile
+++ b/ftp/gftp/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= gftp
-PORTVERSION= 2.0.15.r1
+PORTVERSION= 2.0.15.r2
PORTREVISION= 0
CATEGORIES= ftp
MASTER_SITES= http://gftp.seul.org/ \
@@ -18,6 +18,7 @@ COMMENT= A free multithreaded GTK-based GUI ftp and sftp client
GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --without-included-gettext
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
@@ -71,9 +72,15 @@ pre-everything::
@${ECHO} ""
post-patch:
+# @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
+# s|DATADIRNAME=lib|DATADIRNAME=share|g ; \
+# s|USE_INCLUDED_LIBINTL=yes|#USE_INCLUDED_LIBINTL=yes|g ; \
+# s|\$$\(top_builddir\)/intl/libintl.a|-lintl|g' ${WRKSRC}/configure
+
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
- s|DATADIRNAME=lib|DATADIRNAME=share|g ; \
- s|USE_INCLUDED_LIBINTL=yes|#USE_INCLUDED_LIBINTL=yes|g ; \
- s|\$$\(top_builddir\)/intl/libintl.a|-lintl|g' ${WRKSRC}/configure
+ s|DATADIRNAME=lib|DATADIRNAME=share|g ; \
+ s|"-lssl |& -lcrypto|' ${WRKSRC}/configure
+# @${REINPLACE_CMD} -e 's|LDADD = |& @LIBINTL@ |g' \
+# ${WRKSRC}/src/text/Makefile.in ${WRKSRC}/src/gtk/Makefile.in
.include <bsd.port.post.mk>