aboutsummaryrefslogtreecommitdiff
path: root/ftp/gnustep-ftp/Makefile
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2006-11-05 13:34:23 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2006-11-05 13:34:23 +0000
commita15e12be305d67bd3e56b22c4e4dc7c746581c91 (patch)
tree3a2e443047ede0fbca2f47be2d3b0e451fb7301a /ftp/gnustep-ftp/Makefile
parent68abe5337865cc385d1864b115b2bdba022426c6 (diff)
downloadports-a15e12be305d67bd3e56b22c4e4dc7c746581c91.tar.gz
ports-a15e12be305d67bd3e56b22c4e4dc7c746581c91.zip
Notes
Diffstat (limited to 'ftp/gnustep-ftp/Makefile')
-rw-r--r--ftp/gnustep-ftp/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/ftp/gnustep-ftp/Makefile b/ftp/gnustep-ftp/Makefile
new file mode 100644
index 000000000000..c1d656f2a497
--- /dev/null
+++ b/ftp/gnustep-ftp/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: ftp
+# Date created: 05 Nov 2006
+# Whom: dirk.meyer@dinoex.sub.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= ftp
+PORTVERSION= 0.1
+CATEGORIES= ftp
+MASTER_SITES= http://download.savannah.gnu.org/releases/gap/
+PKGNAMEPREFIX= gnustep-
+DISTNAME= FTP-${PORTVERSION}
+
+MAINTAINER= dinoex@FreeBSD.org
+COMMENT= Compact and handy FTP client for GNUstep
+
+USE_GMAKE= yes
+USE_GNUSTEP= yes
+USE_GNUSTEP_PREFIX= yes
+USE_GNUSTEP_BACK= yes
+USE_GNUSTEP_BUILD= yes
+USE_GNUSTEP_INSTALL= yes
+MAKEFILE= GNUmakefile
+
+post-patch:
+ ${REINPLACE_CMD} -e 's|^GNUSTEP_INSTALLATION_DIR|#GNUSTEP_INSTALLATION_DIR|' \
+ ${WRKSRC}/GNUmakefile
+
+.include <bsd.port.mk>