aboutsummaryrefslogtreecommitdiff
path: root/ftp/gwget
diff options
context:
space:
mode:
authorMichael Johnson <ahze@FreeBSD.org>2005-04-02 23:54:25 +0000
committerMichael Johnson <ahze@FreeBSD.org>2005-04-02 23:54:25 +0000
commit24fa71b26b9ae4056fdd067058058a26ea1b337e (patch)
tree2375e861ed7191f33449a86040534c727162ef60 /ftp/gwget
parenta3e782767ee8df6c116fafc799453f716d82d940 (diff)
downloadports-24fa71b26b9ae4056fdd067058058a26ea1b337e.tar.gz
ports-24fa71b26b9ae4056fdd067058058a26ea1b337e.zip
Notes
Diffstat (limited to 'ftp/gwget')
-rw-r--r--ftp/gwget/Makefile11
-rw-r--r--ftp/gwget/distinfo4
-rw-r--r--ftp/gwget/files/patch-src_main.c36
-rw-r--r--ftp/gwget/files/patch-src_wget-log.c63
-rw-r--r--ftp/gwget/pkg-descr2
-rw-r--r--ftp/gwget/pkg-plist2
6 files changed, 105 insertions, 13 deletions
diff --git a/ftp/gwget/Makefile b/ftp/gwget/Makefile
index e04a98bab604..17af5d6f6589 100644
--- a/ftp/gwget/Makefile
+++ b/ftp/gwget/Makefile
@@ -6,15 +6,18 @@
#
PORTNAME= gwget
-PORTVERSION= 0.93
-PORTREVISION= 2
+PORTVERSION= 0.94
CATEGORIES= ftp www gnome
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= ${PORTNAME}
+MASTER_SITES= ${MASTER_SITE_GNOME}
+MASTER_SITE_SUBDIR= sources/${PORTNAME}/${PORTVERSION}
+DIST_SUBDIR= gnome2
MAINTAINER= radek@raadradd.com
COMMENT= A download manager for GNOME, based on wget
+RUN_DEPENDS= wget:${PORTSDIR}/ftp/wget
+
+USE_BZIP2= yes
USE_GMAKE= yes
USE_GNOME= gnomehack gnomeprefix intlhack libgnomeui
USE_LIBTOOL_VER=15
diff --git a/ftp/gwget/distinfo b/ftp/gwget/distinfo
index 928e7eb686ab..5a3354fb361c 100644
--- a/ftp/gwget/distinfo
+++ b/ftp/gwget/distinfo
@@ -1,2 +1,2 @@
-MD5 (gwget-0.93.tar.gz) = 79a3625ef99a5a417164e0d97020fcc5
-SIZE (gwget-0.93.tar.gz) = 526996
+MD5 (gnome2/gwget-0.94.tar.bz2) = 15a9d6120c52c20aa44934bb75738385
+SIZE (gnome2/gwget-0.94.tar.bz2) = 398490
diff --git a/ftp/gwget/files/patch-src_main.c b/ftp/gwget/files/patch-src_main.c
index 9bba1055e4a1..32dd57953a4b 100644
--- a/ftp/gwget/files/patch-src_main.c
+++ b/ftp/gwget/files/patch-src_main.c
@@ -1,18 +1,42 @@
---- src/main.c.orig Mon Jan 24 20:50:50 2005
-+++ src/main.c Mon Jan 24 20:51:46 2005
-@@ -145,12 +145,13 @@
+--- src/main.c.orig Sat Apr 2 22:26:21 2005
++++ src/main.c Sat Apr 2 22:52:48 2005
+@@ -120,6 +120,7 @@
+ Args *args_original = (Args*)client_data;
+ int argc_original = (*args_original).argc;
+ char **argv_original = (*args_original).argv;
++ int i, iPos, iL, iSize;
+
+ int argc;
+ char **argv;
+@@ -166,13 +167,12 @@
+ argc = argc_original + 2;
+ argv = g_malloc0(sizeof(char*)*argc);
+
+- int iPos = -1;
+- int i;
++ iPos = -1;
+ for (i=0;i<argc_original;i++)
+ if (strcmp(argv_original[i],"--force-tray-only") != 0) {
+ iPos++;
+- int iL = strlen(argv_original[i]);
+- int iSize = sizeof(char)*iL;
++ iL = strlen(argv_original[i]);
++ iSize = sizeof(char)*iL;
+ argv[iPos] = g_malloc0(iSize);
+ strcpy(argv[iPos],argv_original[i]);
+ }
+@@ -191,12 +191,13 @@
static void
gnome_session_join(int argc,char *argv[])
{
-- Args *args = g_malloc(sizeof(Args));
+ GnomeClient* client;
-+ Args *args= g_malloc(sizeof(Args));
+ Args *args = g_malloc(sizeof(Args));
(*args).argc = argc;
(*args).argv = argv;
- GnomeClient* client = gnome_master_client();
-+ client = gnome_master_client();
++ client = gnome_master_client();
gnome_client_set_restart_style(client,GNOME_RESTART_IF_RUNNING);
gtk_signal_connect(GTK_OBJECT(client),"save_yourself",
diff --git a/ftp/gwget/files/patch-src_wget-log.c b/ftp/gwget/files/patch-src_wget-log.c
new file mode 100644
index 000000000000..84565ee69416
--- /dev/null
+++ b/ftp/gwget/files/patch-src_wget-log.c
@@ -0,0 +1,63 @@
+--- src/wget-log.c.orig Sat Apr 2 23:05:09 2005
++++ src/wget-log.c Sat Apr 2 23:31:55 2005
+@@ -58,11 +58,13 @@
+ static int
+ wget_log_process_line (GwgetData *gwgetdata)
+ {
+- if (gwgetdata->line == NULL)
+- return 0;
+-
+ gchar *p;
+ struct stat file_stat;
++ char *sName;
++ int iL;
++
++ if (gwgetdata->line == NULL)
++ return 0;
+
+ switch (gwgetdata->state) {
+ case DL_NOT_CONNECTED:
+@@ -72,10 +74,10 @@
+ * filesystem filename and set gwgetdata->filename
+ */
+ if (strstr(gwgetdata->line," => `")) {
+- int iL = strlen(gwgetdata->line);
++ iL = strlen(gwgetdata->line);
+ gwgetdata->line[iL-1] = 0; // Chop the final '
+
+- char *sName = gwgetdata->line;
++ sName = gwgetdata->line;
+ /*
+ * Now sName contains the whole pathname. No filename can
+ * contain '/' so the following search for the last component
+@@ -272,11 +274,14 @@
+
+ void
+ wget_log_read_log_line(GwgetData *gwgetdata) {
++ char c;
++ int iRes, iBlockCount, iWritePos;
++ gchar *buffer;
++
+ g_free(gwgetdata->line);
+ gwgetdata->line = NULL;
+-
+- char c;
+- int iRes = read(gwgetdata->log_fd,&c,1);
++
++ iRes = read(gwgetdata->log_fd,&c,1);
+
+ if (iRes < 1) {
+ /*
+@@ -286,9 +291,9 @@
+ return;
+ }
+
+- int iBlockCount = 1;
+- gchar *buffer = g_malloc(sizeof(gchar)*(iBlockCount*BLOCK_SIZE));
+- int iWritePos = 0;
++ iBlockCount = 1;
++ buffer = g_malloc(sizeof(gchar)*(iBlockCount*BLOCK_SIZE));
++ iWritePos = 0;
+
+ buffer[iWritePos++] = c;
+ while (c != '\n') {
diff --git a/ftp/gwget/pkg-descr b/ftp/gwget/pkg-descr
index 15a547859968..222bc7145722 100644
--- a/ftp/gwget/pkg-descr
+++ b/ftp/gwget/pkg-descr
@@ -2,4 +2,4 @@ Gwget is a download manager for GNOME which uses wget as its backend.
The most important features include pause/continue support, resuming
and recursive downloading.
-WWW: http://gwget.sourceforge.net/
+WWW: http://gnome.org/projects/gwget/
diff --git a/ftp/gwget/pkg-plist b/ftp/gwget/pkg-plist
index 04d0d6dbdf7a..67bb64d016a5 100644
--- a/ftp/gwget/pkg-plist
+++ b/ftp/gwget/pkg-plist
@@ -34,6 +34,7 @@ share/locale/eu/LC_MESSAGES/gwget.mo
share/locale/fi/LC_MESSAGES/gwget.mo
share/locale/fr/LC_MESSAGES/gwget.mo
share/locale/hu/LC_MESSAGES/gwget.mo
+share/locale/it/LC_MESSAGES/gwget.mo
share/locale/ja/LC_MESSAGES/gwget.mo
share/locale/lt/LC_MESSAGES/gwget.mo
share/locale/mk/LC_MESSAGES/gwget.mo
@@ -45,6 +46,7 @@ share/locale/pt_BR/LC_MESSAGES/gwget.mo
share/locale/ro/LC_MESSAGES/gwget.mo
share/locale/ru/LC_MESSAGES/gwget.mo
share/locale/sk/LC_MESSAGES/gwget.mo
+share/locale/sq/LC_MESSAGES/gwget.mo
share/locale/sv/LC_MESSAGES/gwget.mo
share/locale/tr/LC_MESSAGES/gwget.mo
share/locale/zh_CN/LC_MESSAGES/gwget.mo