aboutsummaryrefslogtreecommitdiff
path: root/ftp/kbear
diff options
context:
space:
mode:
authorMarkus Brueffer <markus@FreeBSD.org>2004-08-19 11:49:41 +0000
committerMarkus Brueffer <markus@FreeBSD.org>2004-08-19 11:49:41 +0000
commit63fa38ff59cd5c9a2f144073062a4a68a62f74a4 (patch)
tree8efc3a5cfef235b37597a0c9a58e5905fa0de9de /ftp/kbear
parent0a39da053ff92cb45b8f19c8e43fe7b5b24af6bf (diff)
downloadports-63fa38ff59cd5c9a2f144073062a4a68a62f74a4.tar.gz
ports-63fa38ff59cd5c9a2f144073062a4a68a62f74a4.zip
Notes
Diffstat (limited to 'ftp/kbear')
-rw-r--r--ftp/kbear/Makefile5
-rw-r--r--ftp/kbear/distinfo2
-rw-r--r--ftp/kbear/files/patch-kbearcopyjob.cpp14
-rw-r--r--ftp/kbear/files/patch-kbearsynchjob.cpp10
-rw-r--r--ftp/kbear/files/patch-misc.cpp10
-rw-r--r--ftp/kbear/files/patch-sitemanager.xml970
-rw-r--r--ftp/kbear/files/patch-transferqueueconfigwidget.cpp11
7 files changed, 6 insertions, 1016 deletions
diff --git a/ftp/kbear/Makefile b/ftp/kbear/Makefile
index 8e806b44f4b9..88e726978971 100644
--- a/ftp/kbear/Makefile
+++ b/ftp/kbear/Makefile
@@ -12,6 +12,9 @@ MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
DISTNAME= ${PORTNAME}-${PORTVERSION:S/.a.1/alpha1b/}-1.src
+PATCH_SITES= http://www.brueffer.de/distfiles/
+PATCHFILES= ${DISTNAME:S/.src/-patch/}.gz
+
MAINTAINER= markus@FreeBSD.org
COMMENT= A graphical FTP client for KDE
@@ -25,7 +28,7 @@ GNU_CONFIGURE= yes
CONFIGURE_ENV= XML2POT=${TRUE} PO2XML=${TRUE} LDFLAGS="${PTHREAD_LIBS}"
post-patch:
- @${REINPLACE_CMD} -e 's|-O2||g; s|-lpthread|${PTHREAD_LIBS}|g' \
+ @${REINPLACE_CMD} -e 's|-O2|-fPIC|g; s|-lpthread|${PTHREAD_LIBS}|g' \
${WRKSRC}/configure
.include <bsd.port.mk>
diff --git a/ftp/kbear/distinfo b/ftp/kbear/distinfo
index 2443d462f0e3..9e2889a581e9 100644
--- a/ftp/kbear/distinfo
+++ b/ftp/kbear/distinfo
@@ -1,2 +1,4 @@
MD5 (kbear-3.0alpha1b-1.src.tar.bz2) = 4c2e050b6012ffcee53194dfed431bb1
SIZE (kbear-3.0alpha1b-1.src.tar.bz2) = 1237169
+MD5 (kbear-3.0alpha1b-1-patch.gz) = 93b84d8df390f325341e1e8c94b9b3b4
+SIZE (kbear-3.0alpha1b-1-patch.gz) = 7367
diff --git a/ftp/kbear/files/patch-kbearcopyjob.cpp b/ftp/kbear/files/patch-kbearcopyjob.cpp
deleted file mode 100644
index e81d74493b58..000000000000
--- a/ftp/kbear/files/patch-kbearcopyjob.cpp
+++ /dev/null
@@ -1,14 +0,0 @@
---- kbear/lib/jobclasses/kbearcopyjob.cpp.orig Mon Feb 9 13:13:28 2004
-+++ kbear/lib/jobclasses/kbearcopyjob.cpp Mon Feb 9 13:13:56 2004
-@@ -1080,11 +1080,7 @@
- } else if (m_mode == Move) // Moving a file
- {
- KBearFileCopyJob * moveJob = KBearFileCopyJob::file_move( m_destID, m_sourceID, (*it).uSource, (*it).uDest, (*it).permissions, bOverwrite, false, false/*no GUI*/ );
-- #if KDE_VERSION_MINOR < 2
- moveJob->setSourceSize( (*it).size );
-- #else
-- moveJob->setSourceSize64( (*it).size );
-- #endif
- newjob = moveJob;
- kdDebug(7007) << "KBearCopyJob::copyNextFile : Moving " << (*it).uSource.prettyURL() << " to " << (*it).uDest.prettyURL() << endl;
- emit moving( this, (*it).uSource, (*it).uDest );
diff --git a/ftp/kbear/files/patch-kbearsynchjob.cpp b/ftp/kbear/files/patch-kbearsynchjob.cpp
deleted file mode 100644
index ec6862ee4e53..000000000000
--- a/ftp/kbear/files/patch-kbearsynchjob.cpp
+++ /dev/null
@@ -1,10 +0,0 @@
---- kbear/lib/jobclasses/kbearsynchjob.cpp.orig Fri Jul 18 12:56:43 2003
-+++ kbear/lib/jobclasses/kbearsynchjob.cpp Fri Jul 18 12:56:53 2003
-@@ -19,6 +19,7 @@
- #include "kbearcopyjob.h"
- #include "kbeardeletejob.h"
- #include "kbearlistjob.h"
-+#include "connectionmanager.h"
-
- using namespace KBear;
-
diff --git a/ftp/kbear/files/patch-misc.cpp b/ftp/kbear/files/patch-misc.cpp
deleted file mode 100644
index cb810e877455..000000000000
--- a/ftp/kbear/files/patch-misc.cpp
+++ /dev/null
@@ -1,10 +0,0 @@
---- kbear/lib/interfaces/misc.cpp.orig Fri Jul 18 16:02:57 2003
-+++ kbear/lib/interfaces/misc.cpp Fri Jul 18 16:03:34 2003
-@@ -36,6 +36,7 @@
- #include <X11/Xlib.h>
- #include <string.h>
- #include <netdb.h>
-+#include <netinet/in.h>
- //////////////////////////////////////////////////////
- // Application specific includes
- #include "misc.h"
diff --git a/ftp/kbear/files/patch-sitemanager.xml b/ftp/kbear/files/patch-sitemanager.xml
deleted file mode 100644
index ec559094c576..000000000000
--- a/ftp/kbear/files/patch-sitemanager.xml
+++ /dev/null
@@ -1,970 +0,0 @@
---- kbear/plugins/sitemanager/sitemanager.xml.orig Fri Jul 18 13:00:26 2003
-+++ kbear/plugins/sitemanager/sitemanager.xml Fri Jul 18 13:00:27 2003
-@@ -345,16 +345,957 @@
- <group label="Imported Bookmarks" />
- <group label="Personal" />
- <group label="BSD Sites" >
--<site label="FreeBSD" >
--<protocol>ftp</protocol>
--<host>ftp.freebsd.org</host>
--<port>21</port>
--<remote_path>/pub/FreeBSD</remote_path>
--<description/>
--<anonymous/>
--<mark_partial/>
--<auto_reconnect sleep="30" count="10" />
--</site>
-+ <group label="FreeBSD">
-+ <site label="FreeBSD" >
-+ <protocol>ftp</protocol>
-+ <host>ftp.freebsd.org</host>
-+ <port>21</port>
-+ <remote_path>/pub/FreeBSD</remote_path>
-+ <description/>
-+ <anonymous/>
-+ <mark_partial/>
-+ <auto_reconnect sleep="30" count="10" />
-+ </site>
-+ <group label="FreeBSD Mirrors in Africa">
-+ <site label="South Africa" >
-+ <protocol>ftp</protocol>
-+ <host>ftp.za.freebsd.org</host>
-+ <port>21</port>
-+ <remote_path>/pub/FreeBSD</remote_path>
-+ <description/>
-+ <anonymous/>
-+ <mark_partial/>
-+ <auto_reconnect sleep="30" count="10" />
-+ </site>
-+ <site label="South Africa (ftp2)" >
-+ <protocol>ftp</protocol>
-+ <host>ftp2.za.freebsd.org</host>
-+ <port>21</port>
-+ <remote_path>/pub/FreeBSD</remote_path>
-+ <description/>
-+ <anonymous/>
-+ <mark_partial/>
-+ <auto_reconnect sleep="30" count="10" />
-+ </site>
-+ <site label="South Africa (ftp3)" >
-+ <protocol>ftp</protocol>
-+ <host>ftp3.za.freebsd.org</host>
-+ <port>21</port>
-+ <remote_path>/pub/FreeBSD</remote_path>
-+ <description/>
-+ <anonymous/>
-+ <mark_partial/>
-+ <auto_reconnect sleep="30" count="10" />
-+ </site>
-+ <site label="South Africa (ftp4)" >
-+ <protocol>ftp</protocol>
-+ <host>ftp4.za.freebsd.org</host>
-+ <port>21</port>
-+ <remote_path>/pub/FreeBSD</remote_path>
-+ <description/>
-+ <anonymous/>
-+ <mark_partial/>
-+ <auto_reconnect sleep="30" count="10" />
-+ </site>
-+
-+ </group>
-+ <group label="FreeBSD Mirrors in Asia">
-+ <site label="China" >
-+ <protocol>ftp</protocol>
-+ <host>ftp.cn.freebsd.org</host>
-+ <port>21</port>
-+ <remote_path>/pub/FreeBSD</remote_path>
-+ <description/>
-+ <anonymous/>
-+ <mark_partial/>
-+ <auto_reconnect sleep="30" count="10" />
-+ </site>
-+ <site label="Hong Kong" >
-+ <protocol>ftp</protocol>
-+ <host>ftp.hk.freebsd.org</host>
-+ <port>21</port>
-+ <remote_path>/pub/FreeBSD</remote_path>
-+ <description/>
-+ <anonymous/>
-+ <mark_partial/>
-+ <auto_reconnect sleep="30" count="10" />
-+ </site>
-+ <site label="Israel" >
-+ <protocol>ftp</protocol>
-+ <host>ftp.il.freebsd.org</host>
-+ <port>21</port>
-+ <remote_path>/pub/FreeBSD</remote_path>
-+ <description/>
-+ <anonymous/>
-+ <mark_partial/>
-+ <auto_reconnect sleep="30" count="10" />
-+ </site>
-+ <site label="Japan" >
-+ <protocol>ftp</protocol>
-+ <host>ftp.jp.freebsd.org</host>
-+ <port>21</port>
-+ <remote_path>/pub/FreeBSD</remote_path>
-+ <description/>
-+ <anonymous/>
-+ <mark_partial/>
-+ <auto_reconnect sleep="30" count="10" />
-+ </site>
-+ <site label="Japan (ftp2)" >
-+ <protocol>ftp</protocol>
-+ <host>ftp2.jp.freebsd.org</host>
-+ <port>21</port>
-+ <remote_path>/pub/FreeBSD</remote_path>
-+ <description/>
-+ <anonymous/>
-+ <mark_partial/>
-+ <auto_reconnect sleep="30" count="10" />
-+ </site>
-+ <site label="Japan (ftp3)" >
-+ <protocol>ftp</protocol>
-+ <host>ftp3.jp.freebsd.org</host>
-+ <port>21</port>
-+ <remote_path>/pub/FreeBSD</remote_path>
-+ <description/>
-+ <anonymous/>
-+ <mark_partial/>
-+ <auto_reconnect sleep="30" count="10" />
-+ </site>
-+ <site label="Japan (ftp4)" >
-+ <protocol>ftp</protocol>
-+ <host>ftp4.jp.freebsd.org</host>
-+ <port>21</port>
-+ <remote_path>/pub/FreeBSD</remote_path>
-+ <description/>
-+ <anonymous/>
-+ <mark_partial/>
-+ <auto_reconnect sleep="30" count="10" />
-+ </site>
-+ <site label="Japan (ftp5)" >
-+ <protocol>ftp</protocol>
-+ <host>ftp5.jp.freebsd.org</host>
-+ <port>21</port>
-+ <remote_path>/pub/FreeBSD</remote_path>
-+ <description/>
-+ <anonymous/>
-+ <mark_partial/>
-+ <auto_reconnect sleep="30" count="10" />
-+ </site>
-+ <site label="Japan (ftp6)" >
-+ <protocol>ftp</protocol>
-+ <host>ftp6.jp.freebsd.org</host>
-+ <port>21</port>
-+ <remote_path>/pub/FreeBSD</remote_path>
-+ <description/>
-+ <anonymous/>
-+ <mark_partial/>
-+ <auto_reconnect sleep="30" count="10" />
-+ </site>
-+ <site label="Japan (ftp7)" >
-+ <protocol>ftp</protocol>
-+ <host>ftp7.jp.freebsd.org</host>
-+ <port>21</port>
-+ <remote_path>/pub/FreeBSD</remote_path>
-+ <description/>
-+ <anonymous/>
-+ <mark_partial/>
-+ <auto_reconnect sleep="30" count="10" />
-+ </site>
-+
-+ <site label="Korea" >
-+ <protocol>ftp</protocol>
-+ <host>ftp.kr.freebsd.org</host>
-+ <port>21</port>
-+ <remote_path>/pub/FreeBSD</remote_path>
-+ <description/>
-+ <anonymous/>
-+ <mark_partial/>
-+ <auto_reconnect sleep="30" count="10" />
-+ </site>
-+ <site label="Korea (ftp3)" >
-+ <protocol>ftp</protocol>
-+ <host>ftp3.kr.freebsd.org</host>
-+ <port>21</port>
-+ <remote_path>/pub/FreeBSD</remote_path>
-+ <description/>
-+ <anonymous/>
-+ <mark_partial/>
-+ <auto_reconnect sleep="30" count="10" />
-+ </site>
-+ <site label="Korea (ftp4)" >
-+ <protocol>ftp</protocol>
-+ <host>ftp4.kr.freebsd.org</host>
-+ <port>21</port>
-+ <remote_path>/pub/FreeBSD</remote_path>
-+ <description/>
-+ <anonymous/>
-+ <mark_partial/>
-+ <auto_reconnect sleep="30" count="10" />
-+ </site>
-+ <site label="Korea (ftp5)" >
-+ <protocol>ftp</protocol>
-+ <host>ftp5.kr.freebsd.org</host>
-+ <port>21</port>
-+ <remote_path>/pub/FreeBSD</remote_path>
-+ <description/>
-+ <anonymous/>
-+ <mark_partial/>
-+ <auto_reconnect sleep="30" count="10" />
-+ </site>
-+ <site label="Korea (ftp6)" >
-+ <protocol>ftp</protocol>
-+ <host>ftp6.kr.freebsd.org</host>
-+ <port>21</port>
-+ <remote_path>/pub/FreeBSD</remote_path>
-+ <description/>
-+ <anonymous/>
-+ <mark_partial/>
-+ <auto_reconnect sleep="30" count="10" />
-+ </site>
-+ <site label="Korea (ftp7)" >
-+ <protocol>ftp</protocol>
-+ <host>ftp7.kr.freebsd.org</host>
-+ <port>21</port>
-+ <remote_path>/pub/FreeBSD</remote_path>
-+ <description/>
-+ <anonymous/>
-+ <mark_partial/>
-+ <auto_reconnect sleep="30" count="10" />
-+ </site>
-+ <site label="Saudi Arabia" >
-+ <protocol>ftp</protocol>
-+ <host>ftp.sa.freebsd.org</host>
-+ <port>21</port>
-+ <remote_path>/pub/FreeBSD</remote_path>
-+ <description/>
-+ <anonymous/>
-+ <mark_partial/>
-+ <auto_reconnect sleep="30" count="10" />
-+ </site>
-+ <site label="Taiwan" >
-+ <protocol>ftp</protocol>
-+ <host>ftp.tw.freebsd.org</host>
-+ <port>21</port>
-+ <remote_path>/pub/FreeBSD</remote_path>
-+ <description/>
-+ <anonymous/>
-+ <mark_partial/>
-+ <auto_reconnect sleep="30" count="10" />
-+ </site>
-+ <site label="Taiwan (ftp3)" >
-+ <protocol>ftp</protocol>
-+ <host>ftp3.tw.freebsd.org</host>
-+ <port>21</port>
-+ <remote_path>/pub/FreeBSD</remote_path>
-+ <description/>
-+ <anonymous/>
-+ <mark_partial/>
-+ <auto_reconnect sleep="30" count="10" />
-+ </site>
-+ <site label="Taiwan (ftp4)" >
-+ <protocol>ftp</protocol>
-+ <host>ftp4.tw.freebsd.org</host>
-+ <port>21</port>
-+ <remote_path>/pub/FreeBSD</remote_path>
-+ <description/>
-+ <anonymous/>
-+ <mark_partial/>
-+ <auto_reconnect sleep="30" count="10" />
-+ </site>
-+ <site label="Taiwan (ftp8)" >
-+ <protocol>ftp</protocol>
-+ <host>ftp8.tw.freebsd.org</host>
-+ <port>21</port>
-+ <remote_path>/pub/FreeBSD</remote_path>
-+ <description/>
-+ <anonymous/>
-+ <mark_partial/>
-+ <auto_reconnect sleep="30" count="10" />
-+ </site>
-+ <site label="Taiwan (ftp9)" >
-+ <protocol>ftp</protocol>
-+ <host>ftp9.tw.freebsd.org</host>
-+ <port>21</port>
-+ <remote_path>/pub/FreeBSD</remote_path>
-+ <description/>
-+ <anonymous/>
-+ <mark_partial/>
-+ <auto_reconnect sleep="30" count="10" />
-+ </site>
-+ <site label="Taiwan (ftp10)" >
-+ <protocol>ftp</protocol>
-+ <host>ftp10.tw.freebsd.org</host>
-+ <port>21</port>
-+ <remote_path>/pub/FreeBSD</remote_path>
-+ <description/>
-+ <anonymous/>
-+ <mark_partial/>
-+ <auto_reconnect sleep="30" count="10" />
-+ </site>
-+ <site label="Taiwan (ftp11)" >
-+ <protocol>ftp</protocol>
-+ <host>ftp11.tw.freebsd.org</host>
-+ <port>21</port>
-+ <remote_path>/pub/FreeBSD</remote_path>
-+ <description/>
-+ <anonymous/>
-+ <mark_partial/>
-+ <auto_reconnect sleep="30" count="10" />
-+ </site>
-+ <site label="Thailand" >
-+ <protocol>ftp</protocol>
-+ <host>ftp.nectec.or.th</host>
-+ <port>21</port>
-+ <remote_path>/pub/FreeBSD</remote_path>
-+ <description/>
-+ <anonymous/>
-+ <mark_partial/>
-+ <auto_reconnect sleep="30" count="10" />
-+ </site>
-+
-+ </group>
-+ <group label="FreeBSD Mirrors in Europe">
-+ <site label="Austria" >
-+ <protocol>ftp</protocol>
-+ <host>ftp.at.freebsd.org</host>
-+ <port>21</port>
-+ <remote_path>/pub/FreeBSD</remote_path>
-+ <description/>
-+ <anonymous/>
-+ <mark_partial/>
-+ <auto_reconnect sleep="30" count="10" />
-+ </site>
-+ <site label="Czech Republic" >
-+ <protocol>ftp</protocol>
-+ <host>ftp.cz.freebsd.org</host>
-+ <port>21</port>
-+ <remote_path>/pub/FreeBSD</remote_path>
-+ <description/>
-+ <anonymous/>
-+ <mark_partial/>
-+ <auto_reconnect sleep="30" count="10" />
-+ </site>
-+ <site label="Denmark" >
-+ <protocol>ftp</protocol>
-+ <host>ftp.dk.freebsd.org</host>
-+ <port>21</port>
-+ <remote_path>/pub/FreeBSD</remote_path>
-+ <description/>
-+ <anonymous/>
-+ <mark_partial/>
-+ <auto_reconnect sleep="30" count="10" />
-+ </site>
-+ <site label="Denmark (ftp2)" >
-+ <protocol>ftp</protocol>
-+ <host>ftp2.dk.freebsd.org</host>
-+ <port>21</port>
-+ <remote_path>/pub/FreeBSD</remote_path>
-+ <description/>
-+ <anonymous/>
-+ <mark_partial/>
-+ <auto_reconnect sleep="30" count="10" />
-+ </site>
-+ <site label="Denmark (ftp3)" >
-+ <protocol>ftp</protocol>
-+ <host>ftp3.dk.freebsd.org</host>
-+ <port>21</port>
-+ <remote_path>/pub/FreeBSD</remote_path>
-+ <description/>
-+ <anonymous/>
-+ <mark_partial/>
-+ <auto_reconnect sleep="30" count="10" />
-+ </site>
-+ <site label="Estonia" >
-+ <protocol>ftp</protocol>
-+ <host>ftp.ee.freebsd.org</host>
-+ <port>21</port>
-+ <remote_path>/pub/FreeBSD</remote_path>
-+ <description/>
-+ <anonymous/>
-+ <mark_partial/>
-+ <auto_reconnect sleep="30" count="10" />
-+ </site>
-+ <site label="Finland" >
-+ <protocol>ftp</protocol>
-+ <host>ftp.fi.freebsd.org</host>
-+ <port>21</port>
-+ <remote_path>/pub/FreeBSD</remote_path>
-+ <description/>
-+ <anonymous/>
-+ <mark_partial/>
-+ <auto_reconnect sleep="30" count="10" />
-+ </site>
-+ <site label="France" >
-+ <protocol>ftp</protocol>
-+ <host>ftp.fr.freebsd.org</host>
-+ <port>21</port>
-+ <remote_path>/pub/FreeBSD</remote_path>
-+ <description/>
-+ <anonymous/>
-+ <mark_partial/>
-+ <auto_reconnect sleep="30" count="10" />
-+ </site>
-+ <site label="France (ftp3)" >
-+ <protocol>ftp</protocol>
-+ <host>ftp3.fr.freebsd.org</host>
-+ <port>21</port>
-+ <remote_path>/pub/FreeBSD</remote_path>
-+ <description/>
-+ <anonymous/>
-+ <mark_partial/>
-+ <auto_reconnect sleep="30" count="10" />
-+ </site>
-+ <site label="France (ftp6)" >
-+ <protocol>ftp</protocol>
-+ <host>ftp6.fr.freebsd.org</host>
-+ <port>21</port>
-+ <remote_path>/pub/FreeBSD</remote_path>
-+ <description/>
-+ <anonymous/>
-+ <mark_partial/>
-+ <auto_reconnect sleep="30" count="10" />
-+ </site>
-+ <site label="France (ftp8)" >
-+ <protocol>ftp</protocol>
-+ <host>ftp8.fr.freebsd.org</host>
-+ <port>21</port>
-+ <remote_path>/pub/FreeBSD</remote_path>
-+ <description/>
-+ <anonymous/>
-+ <mark_partial/>
-+ <auto_reconnect sleep="30" count="10" />
-+ </site>
-+ <site label="Germany" >
-+ <protocol>ftp</protocol>
-+ <host>ftp.de.freebsd.org</host>
-+ <port>21</port>
-+ <remote_path>/pub/FreeBSD</remote_path>
-+ <description/>
-+ <anonymous/>
-+ <mark_partial/>
-+ <auto_reconnect sleep="30" count="10" />
-+ </site>
-+ <site label="Germany (ftp2)" >
-+ <protocol>ftp</protocol>
-+ <host>ftp2.de.freebsd.org</host>
-+ <port>21</port>
-+ <remote_path>/pub/FreeBSD</remote_path>
-+ <description/>
-+ <anonymous/>
-+ <mark_partial/>
-+ <auto_reconnect sleep="30" count="10" />
-+ </site>
-+ <site label="Germany (ftp3)" >
-+ <protocol>ftp</protocol>
-+ <host>ftp3.de.freebsd.org</host>
-+ <port>21</port>
-+ <remote_path>/pub/FreeBSD</remote_path>
-+ <description/>
-+ <anonymous/>
-+ <mark_partial/>
-+ <auto_reconnect sleep="30" count="10" />
-+ </site>
-+ <site label="Germany (ftp4)" >
-+ <protocol>ftp</protocol>
-+ <host>ftp4.de.freebsd.org</host>
-+ <port>21</port>
-+ <remote_path>/pub/FreeBSD</remote_path>
-+ <description/>
-+ <anonymous/>
-+ <mark_partial/>
-+ <auto_reconnect sleep="30" count="10" />
-+ </site>
-+ <site label="Germany (ftp7)" >
-+ <protocol>ftp</protocol>
-+ <host>ftp7.de.freebsd.org</host>
-+ <port>21</port>
-+ <remote_path>/pub/FreeBSD</remote_path>
-+ <description/>
-+ <anonymous/>
-+ <mark_partial/>
-+ <auto_reconnect sleep="30" count="10" />
-+ </site>
-+ <site label="Iceland" >
-+ <protocol>ftp</protocol>
-+ <host>ftp.is.freebsd.org</host>
-+ <port>21</port>
-+ <remote_path>/pub/FreeBSD</remote_path>
-+ <description/>
-+ <anonymous/>
-+ <mark_partial/>
-+ <auto_reconnect sleep="30" count="10" />
-+ </site>
-+ <site label="Ireland" >
-+ <protocol>ftp</protocol>
-+ <host>ftp.ie.freebsd.org</host>
-+ <port>21</port>
-+ <remote_path>/pub/FreeBSD</remote_path>
-+ <description/>
-+ <anonymous/>
-+ <mark_partial/>
-+ <auto_reconnect sleep="30" count="10" />
-+ </site>
-+ <site label="Lithuania" >
-+ <protocol>ftp</protocol>
-+ <host>ftp.lt.freebsd.org</host>
-+ <port>21</port>
-+ <remote_path>/pub/FreeBSD</remote_path>
-+ <description/>
-+ <anonymous/>
-+ <mark_partial/>
-+ <auto_reconnect sleep="30" count="10" />
-+ </site>
-+ <site label="Netherlands" >
-+ <protocol>ftp</protocol>
-+ <host>ftp.nl.freebsd.org</host>
-+ <port>21</port>
-+ <remote_path>/pub/FreeBSD</remote_path>
-+ <description/>
-+ <anonymous/>
-+ <mark_partial/>
-+ <auto_reconnect sleep="30" count="10" />
-+ </site>
-+ <site label="Netherlands (ftp2)" >
-+ <protocol>ftp</protocol>
-+ <host>ftp2.nl.freebsd.org</host>
-+ <port>21</port>
-+ <remote_path>/pub/FreeBSD</remote_path>
-+ <description/>
-+ <anonymous/>
-+ <mark_partial/>
-+ <auto_reconnect sleep="30" count="10" />
-+ </site>
-+ <site label="Poland" >
-+ <protocol>ftp</protocol>
-+ <host>ftp.pl.freebsd.org</host>
-+ <port>21</port>
-+ <remote_path>/pub/FreeBSD</remote_path>
-+ <description/>
-+ <anonymous/>
-+ <mark_partial/>
-+ <auto_reconnect sleep="30" count="10" />
-+ </site>
-+ <site label="Poland (ftp2)" >
-+ <protocol>ftp</protocol>
-+ <host>ftp2.pl.freebsd.org</host>
-+ <port>21</port>
-+ <remote_path>/pub/FreeBSD</remote_path>
-+ <description/>
-+ <anonymous/>
-+ <mark_partial/>
-+ <auto_reconnect sleep="30" count="10" />
-+ </site>
-+ <site label="Portugal" >
-+ <protocol>ftp</protocol>
-+ <host>ftp.pt.freebsd.org</host>
-+ <port>21</port>
-+ <remote_path>/pub/FreeBSD</remote_path>
-+ <description/>
-+ <anonymous/>
-+ <mark_partial/>
-+ <auto_reconnect sleep="30" count="10" />
-+ </site>
-+ <site label="Portugal (ftp2)" >
-+ <protocol>ftp</protocol>
-+ <host>ftp2.pt.freebsd.org</host>
-+ <port>21</port>
-+ <remote_path>/pub/FreeBSD</remote_path>
-+ <description/>
-+ <anonymous/>
-+ <mark_partial/>
-+ <auto_reconnect sleep="30" count="10" />
-+ </site>
-+ <site label="Romania" >
-+ <protocol>ftp</protocol>
-+ <host>ftp.ro.freebsd.org</host>
-+ <port>21</port>
-+ <remote_path>/pub/FreeBSD</remote_path>
-+ <description/>
-+ <anonymous/>
-+ <mark_partial/>
-+ <auto_reconnect sleep="30" count="10" />
-+ </site>
-+ <site label="Slovak Republic" >
-+ <protocol>ftp</protocol>
-+ <host>ftp.sk.freebsd.org</host>
-+ <port>21</port>
-+ <remote_path>/pub/FreeBSD</remote_path>
-+ <description/>
-+ <anonymous/>
-+ <mark_partial/>
-+ <auto_reconnect sleep="30" count="10" />
-+ </site>
-+ <site label="Slovenia" >
-+ <protocol>ftp</protocol>
-+ <host>ftp.si.freebsd.org</host>
-+ <port>21</port>
-+ <remote_path>/pub/FreeBSD</remote_path>
-+ <description/>
-+ <anonymous/>
-+ <mark_partial/>
-+ <auto_reconnect sleep="30" count="10" />
-+ </site>
-+ <site label="Spain" >
-+ <protocol>ftp</protocol>
-+ <host>ftp.es.freebsd.org</host>
-+ <port>21</port>
-+ <remote_path>/pub/FreeBSD</remote_path>
-+ <description/>
-+ <anonymous/>
-+ <mark_partial/>
-+ <auto_reconnect sleep="30" count="10" />
-+ </site>
-+ <site label="Sweden" >
-+ <protocol>ftp</protocol>
-+ <host>ftp.se.freebsd.org</host>
-+ <port>21</port>
-+ <remote_path>/pub/FreeBSD</remote_path>
-+ <description/>
-+ <anonymous/>
-+ <mark_partial/>
-+ <auto_reconnect sleep="30" count="10" />
-+ </site>
-+ <site label="Sweden (ftp2)" >
-+ <protocol>ftp</protocol>
-+ <host>ftp2.se.freebsd.org</host>
-+ <port>21</port>
-+ <remote_path>/pub/FreeBSD</remote_path>
-+ <description/>
-+ <anonymous/>
-+ <mark_partial/>
-+ <auto_reconnect sleep="30" count="10" />
-+ </site>
-+ <site label="Sweden (ftp3)" >
-+ <protocol>ftp</protocol>
-+ <host>ftp3.se.freebsd.org</host>
-+ <port>21</port>
-+ <remote_path>/pub/FreeBSD</remote_path>
-+ <description/>
-+ <anonymous/>
-+ <mark_partial/>
-+ <auto_reconnect sleep="30" count="10" />
-+ </site>
-+ <site label="Ukraine" >
-+ <protocol>ftp</protocol>
-+ <host>ftp.ua.freebsd.org</host>
-+ <port>21</port>
-+ <remote_path>/pub/FreeBSD</remote_path>
-+ <description/>
-+ <anonymous/>
-+ <mark_partial/>
-+ <auto_reconnect sleep="30" count="10" />
-+ </site>
-+ <site label="UK" >
-+ <protocol>ftp</protocol>
-+ <host>ftp.uk.freebsd.org</host>
-+ <port>21</port>
-+ <remote_path>/pub/FreeBSD</remote_path>
-+ <description/>
-+ <anonymous/>
-+ <mark_partial/>
-+ <auto_reconnect sleep="30" count="10" />
-+ </site>
-+ <site label="UK (ftp2)" >
-+ <protocol>ftp</protocol>
-+ <host>ftp2.uk.freebsd.org</host>
-+ <port>21</port>
-+ <remote_path>/pub/FreeBSD</remote_path>
-+ <description/>
-+ <anonymous/>
-+ <mark_partial/>
-+ <auto_reconnect sleep="30" count="10" />
-+ </site>
-+ <site label="UK (ftp3)" >
-+ <protocol>ftp</protocol>
-+ <host>ftp3.uk.freebsd.org</host>
-+ <port>21</port>
-+ <remote_path>/pub/FreeBSD</remote_path>
-+ <description/>
-+ <anonymous/>
-+ <mark_partial/>
-+ <auto_reconnect sleep="30" count="10" />
-+ </site>
-+ <site label="UK (ftp4)" >
-+ <protocol>ftp</protocol>
-+ <host>ftp4.uk.freebsd.org</host>
-+ <port>21</port>
-+ <remote_path>/pub/FreeBSD</remote_path>
-+ <description/>
-+ <anonymous/>
-+ <mark_partial/>
-+ <auto_reconnect sleep="30" count="10" />
-+ </site>
-+ <site label="UK (ftp5)" >
-+ <protocol>ftp</protocol>
-+ <host>ftp5.uk.freebsd.org</host>
-+ <port>21</port>
-+ <remote_path>/pub/FreeBSD</remote_path>
-+ <description/>
-+ <anonymous/>
-+ <mark_partial/>
-+ <auto_reconnect sleep="30" count="10" />
-+ </site>
-+ </group>
-+ <group label="FreeBSD Mirrors in Russia">
-+ <site label="Russia" >
-+ <protocol>ftp</protocol>
-+ <host>ftp.ru.freebsd.org</host>
-+ <port>21</port>
-+ <remote_path>/pub/FreeBSD</remote_path>
-+ <description/>
-+ <anonymous/>
-+ <mark_partial/>
-+ <auto_reconnect sleep="30" count="10" />
-+ </site>
-+ <site label="Russia (ftp3)" >
-+ <protocol>ftp</protocol>
-+ <host>ftp3.ru.freebsd.org</host>
-+ <port>21</port>
-+ <remote_path>/pub/FreeBSD</remote_path>
-+ <description/>
-+ <anonymous/>
-+ <mark_partial/>
-+ <auto_reconnect sleep="30" count="10" />
-+ </site>
-+ </group>
-+ <group label="FreeBSD Mirrors in North America">
-+ <site label="Canada" >
-+ <protocol>ftp</protocol>
-+ <host>ftp.ca.freebsd.org</host>
-+ <port>21</port>
-+ <remote_path>/pub/FreeBSD</remote_path>
-+ <description/>
-+ <anonymous/>
-+ <mark_partial/>
-+ <auto_reconnect sleep="30" count="10" />
-+ </site>
-+ <site label="USA (ftp2)" >
-+ <protocol>ftp</protocol>
-+ <host>ftp2.freebsd.org</host>
-+ <port>21</port>
-+ <remote_path>/pub/FreeBSD</remote_path>
-+ <description/>
-+ <anonymous/>
-+ <mark_partial/>
-+ <auto_reconnect sleep="30" count="10" />
-+ </site>
-+ <site label="USA (ftp3)" >
-+ <protocol>ftp</protocol>
-+ <host>ftp3.freebsd.org</host>
-+ <port>21</port>
-+ <remote_path>/pub/FreeBSD</remote_path>
-+ <description/>
-+ <anonymous/>
-+ <mark_partial/>
-+ <auto_reconnect sleep="30" count="10" />
-+ </site>
-+ <site label="USA (ftp4)" >
-+ <protocol>ftp</protocol>
-+ <host>ftp4.freebsd.org</host>
-+ <port>21</port>
-+ <remote_path>/pub/FreeBSD</remote_path>
-+ <description/>
-+ <anonymous/>
-+ <mark_partial/>
-+ <auto_reconnect sleep="30" count="10" />
-+ </site>
-+ <site label="USA (ftp5)" >
-+ <protocol>ftp</protocol>
-+ <host>ftp5.freebsd.org</host>
-+ <port>21</port>
-+ <remote_path>/pub/FreeBSD</remote_path>
-+ <description/>
-+ <anonymous/>
-+ <mark_partial/>
-+ <auto_reconnect sleep="30" count="10" />
-+ </site>
-+ <site label="USA (ftp6)" >
-+ <protocol>ftp</protocol>
-+ <host>ftp6.freebsd.org</host>
-+ <port>21</port>
-+ <remote_path>/pub/FreeBSD</remote_path>
-+ <description/>
-+ <anonymous/>
-+ <mark_partial/>
-+ <auto_reconnect sleep="30" count="10" />
-+ </site>
-+ <site label="USA (ftp7)" >
-+ <protocol>ftp</protocol>
-+ <host>ftp7.freebsd.org</host>
-+ <port>21</port>
-+ <remote_path>/pub/FreeBSD</remote_path>
-+ <description/>
-+ <anonymous/>
-+ <mark_partial/>
-+ <auto_reconnect sleep="30" count="10" />
-+ </site>
-+ <site label="USA (ftp8)" >
-+ <protocol>ftp</protocol>
-+ <host>ftp8.freebsd.org</host>
-+ <port>21</port>
-+ <remote_path>/pub/FreeBSD</remote_path>
-+ <description/>
-+ <anonymous/>
-+ <mark_partial/>
-+ <auto_reconnect sleep="30" count="10" />
-+ </site>
-+ <site label="USA (ftp9)" >
-+ <protocol>ftp</protocol>
-+ <host>ftp9.freebsd.org</host>
-+ <port>21</port>
-+ <remote_path>/pub/FreeBSD</remote_path>
-+ <description/>
-+ <anonymous/>
-+ <mark_partial/>
-+ <auto_reconnect sleep="30" count="10" />
-+ </site>
-+ <site label="USA (ftp10)" >
-+ <protocol>ftp</protocol>
-+ <host>ftp10.freebsd.org</host>
-+ <port>21</port>
-+ <remote_path>/pub/FreeBSD</remote_path>
-+ <description/>
-+ <anonymous/>
-+ <mark_partial/>
-+ <auto_reconnect sleep="30" count="10" />
-+ </site>
-+ <site label="USA (ftp11)" >
-+ <protocol>ftp</protocol>
-+ <host>ftp11.freebsd.org</host>
-+ <port>21</port>
-+ <remote_path>/pub/FreeBSD</remote_path>
-+ <description/>
-+ <anonymous/>
-+ <mark_partial/>
-+ <auto_reconnect sleep="30" count="10" />
-+ </site>
-+ <site label="USA (ftp12)" >
-+ <protocol>ftp</protocol>
-+ <host>ftp12.freebsd.org</host>
-+ <port>21</port>
-+ <remote_path>/pub/FreeBSD</remote_path>
-+ <description/>
-+ <anonymous/>
-+ <mark_partial/>
-+ <auto_reconnect sleep="30" count="10" />
-+ </site>
-+ <site label="USA (ftp13)" >
-+ <protocol>ftp</protocol>
-+ <host>ftp13.freebsd.org</host>
-+ <port>21</port>
-+ <remote_path>/pub/FreeBSD</remote_path>
-+ <description/>
-+ <anonymous/>
-+ <mark_partial/>
-+ <auto_reconnect sleep="30" count="10" />
-+ </site>
-+
-+ </group>
-+ <group label="FreeBSD Mirrors in South America">
-+ <site label="Argentina" >
-+ <protocol>ftp</protocol>
-+ <host>ftp.ar.freebsd.org</host>
-+ <port>21</port>
-+ <remote_path>/pub/FreeBSD</remote_path>
-+ <description/>
-+ <anonymous/>
-+ <mark_partial/>
-+ <auto_reconnect sleep="30" count="10" />
-+ </site>
-+ <site label="Brazil" >
-+ <protocol>ftp</protocol>
-+ <host>ftp.br.freebsd.org</host>
-+ <port>21</port>
-+ <remote_path>/pub/FreeBSD</remote_path>
-+ <description/>
-+ <anonymous/>
-+ <mark_partial/>
-+ <auto_reconnect sleep="30" count="10" />
-+ </site>
-+ <site label="Brazil (ftp2)" >
-+ <protocol>ftp</protocol>
-+ <host>ftp2.br.freebsd.org</host>
-+ <port>21</port>
-+ <remote_path>/pub/FreeBSD</remote_path>
-+ <description/>
-+ <anonymous/>
-+ <mark_partial/>
-+ <auto_reconnect sleep="30" count="10" />
-+ </site>
-+ <site label="Brazil (ftp3)" >
-+ <protocol>ftp</protocol>
-+ <host>ftp3.br.freebsd.org</host>
-+ <port>21</port>
-+ <remote_path>/pub/FreeBSD</remote_path>
-+ <description/>
-+ <anonymous/>
-+ <mark_partial/>
-+ <auto_reconnect sleep="30" count="10" />
-+ </site>
-+ <site label="Brazil (ftp4)" >
-+ <protocol>ftp</protocol>
-+ <host>ftp4.br.freebsd.org</host>
-+ <port>21</port>
-+ <remote_path>/pub/FreeBSD</remote_path>
-+ <description/>
-+ <anonymous/>
-+ <mark_partial/>
-+ <auto_reconnect sleep="30" count="10" />
-+ </site>
-+ <site label="Brazil (ftp5)" >
-+ <protocol>ftp</protocol>
-+ <host>ftp5.br.freebsd.org</host>
-+ <port>21</port>
-+ <remote_path>/pub/FreeBSD</remote_path>
-+ <description/>
-+ <anonymous/>
-+ <mark_partial/>
-+ <auto_reconnect sleep="30" count="10" />
-+ </site>
-+ <site label="Brazil (ftp6)" >
-+ <protocol>ftp</protocol>
-+ <host>ftp6.br.freebsd.org</host>
-+ <port>21</port>
-+ <remote_path>/pub/FreeBSD</remote_path>
-+ <description/>
-+ <anonymous/>
-+ <mark_partial/>
-+ <auto_reconnect sleep="30" count="10" />
-+ </site>
-+ <site label="Brazil (ftp7)" >
-+ <protocol>ftp</protocol>
-+ <host>ftp7.br.freebsd.org</host>
-+ <port>21</port>
-+ <remote_path>/pub/FreeBSD</remote_path>
-+ <description/>
-+ <anonymous/>
-+ <mark_partial/>
-+ <auto_reconnect sleep="30" count="10" />
-+ </site>
-+
-+ </group>
-+ <group label="FreeBSD Mirrors in Australia, New Zealand">
-+ <site label="Australia" >
-+ <protocol>ftp</protocol>
-+ <host>ftp.au.freebsd.org</host>
-+ <port>21</port>
-+ <remote_path>/pub/FreeBSD</remote_path>
-+ <description/>
-+ <anonymous/>
-+ <mark_partial/>
-+ <auto_reconnect sleep="30" count="10" />
-+ </site>
-+ <site label="New Zealand" >
-+ <protocol>ftp</protocol>
-+ <host>ftp.nz.freebsd.org</host>
-+ <port>21</port>
-+ <remote_path>/pub/FreeBSD</remote_path>
-+ <description/>
-+ <anonymous/>
-+ <mark_partial/>
-+ <auto_reconnect sleep="30" count="10" />
-+ </site>
-+ </group>
-+ </group>
- <site label="NetBSD" >
- <protocol>ftp</protocol>
- <host>ftp.netbsd.org</host>
diff --git a/ftp/kbear/files/patch-transferqueueconfigwidget.cpp b/ftp/kbear/files/patch-transferqueueconfigwidget.cpp
deleted file mode 100644
index 93716ce26046..000000000000
--- a/ftp/kbear/files/patch-transferqueueconfigwidget.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- kbear/plugins/transferqueue/transferqueueconfigwidget.cpp.orig Sun Jun 6 03:12:32 2004
-+++ kbear/plugins/transferqueue/transferqueueconfigwidget.cpp Sun Jun 6 03:13:35 2004
-@@ -110,7 +110,7 @@
- m_config->sync();
- }
- m_sysShutdownCheckBox->setChecked( m_config->readBoolEntry( QString::fromLatin1("SysShutdownWhenDone"), false ) );
-- m_queueCheckBox->setChecked( m_config->readBoolEntry( QString::fromLatin1("QueueTransfers"), false ) );
-+ m_queueCheckBox->setChecked( m_config->readBoolEntry( QString::fromLatin1("QueueTransfers"), true ) );
- m_countSpinBox->setValue( m_config->readUnsignedNumEntry( QString::fromLatin1("NumberOfTransfers"), 1 ) );
- m_disconnectCommandLineEdit->setText( m_config->readEntry( QString::fromLatin1("DisconnectCommand"), QString::fromLatin1("kppp -k") ) );
-